ePrivacy and GPDR Cookie Consent by Cookie Consent Skip to content

Squad 5.0 Issue Reporting

OWI_IcareOWI_Icare Posts: 16 Moderator

Please report new issues with the v5.0 update here using the following format:

Bug Report Template:

  • Version: x.x (check on the main menu, bottom left)
  • Type: Map- the name of the map/Gameplay/Asset/Sound/Visual/Other bug
  • Description: Describe in detail the issue.
  • Screenshots/Video: Please include a screenshot of the issue and/or minimap location if applicable (and youtube/streamable video link if necessary)
  • Reproduction steps: how to reliably reproduce this bug (make sure it's reproducible in an online server, rather than in offline mode)
  • Any Exploit Bugs that are game-breaking should be sent via https://offworldindustries.zendesk.com/hc/en-us
  • Please do not report bugs from the Offline Testing Range.


  • Victor WestphalenVictor Westphalen Member Posts: 2 Civilian
    edited June 22
    • Version:Squad V5.0.0.141812.505-4.27.2
    • Type:1,Asset;2,Sound;3,Asset
    • Description:1,The AK12 has the wrong rate of fire. In the game it's 650 rounds per minute, but in reality it's 700 rounds per minute. Please fix AS soon as possible.
    • 2,AS Val's voice is inconsistent. Semi-automatic fire is significantly louder than fully automatic fire. This problem also occurs on the AK74 series. There is also the problem of the inconsistency between the sound of the gun firing and the actual fire. Please fix them as soon as possible.
    • 3,PLANMC's individual weapons are too uncharacteristic, please introduce new weapons like QBZ191 series and adjust the equipment variants and quantities as you did with VDV.


  • Victor WestphalenVictor Westphalen Member Posts: 2 Civilian
    • Version:Squad V5.0.0.141812.505-4.27.2
    • Type:1,Asset;2,Asset
    • Description:1,VDV now rarely uses BMD1, please introduce BMD2, which is more widely used. Preferably with an ATGM, let the crew launch in the open air.
    • 2,The scouts had only green dots, but no binoculars. This is ridiculous. Please increase it immediately. Consider adding Raiders to VDV and other regular armies. VDV Raiders can use ASVAL with iron aim (better than Green dot in my opinion).

  • Piranja13Piranja13 Member Posts: 2 Civilian

    Version:Squad V5.0.0.141812.505-4.27.2

    MAP: Black coast RAAS V.1

    Description : 50m² AOE underwater Visual glitch , 50 m west of derevnya

  • Ranger_5thDRanger_5thD Member Posts: 3 Civilian
    • Version:Squad V5.0.0.141812.505-4.27.2
    • Type: visual/gameplay
    • Description: friendly and enemy infantry have different render distances enemy infantry dose not load past 1 km were friendly can be seen from the other end of the map

  • Ranger_5thDRanger_5thD Member Posts: 3 Civilian

    Version: V5.0.0.141812.505-4.27.2

    Type: Gameplay

    Description: double pen bug were you were able to do more damage then intended were never properly fixed you can still deal 2x damage by first shooting the hull of a vic and then having the round overpenetrate into the turret in that order hitting the turret then hull was fixed this is most obvious on the abrums were the hit box of the turret ring extends into the hull but it works on all vics with a gun larger then 50cal

  • Ranger_5thDRanger_5thD Member Posts: 3 Civilian

    Version: V5.0.0.141812.505-4.27.2

    Type: Gameplay

    Description:the lav25 coyote humvee luvw and woodland challenger suffer from the same bug were they have something on them with 5mm or less of amour which allows them all to be killed with 50 cal and bigger this is most obvious with HE/AA allowing them to be killed more then twice as fast the if you used AP on lav25 coyote humvee luvw this is done by shoting the spare tire (side note the coyote has two spare tires the one in the front and an invisible one in the same spot as the lav25) the backpacks on the woodland challenger have this same bug and this means the open top 50 cal on the t62 can kill the woodland challenger faster then the main gun by about 1/2 a second

  • Ruby KurosawaRuby Kurosawa Member Posts: 2 Civilian

    Version: Squad V5.0.0.141812.505-4.27.2

    Type: Manicouagan

    Description: I'm under the water, please help me. Getting out of the vehicle doesn't fix it, going above or below water level does. The bug is only visual, no physics attached. Its obviously impossible to play like this, you're effectively blind when this happens.


    Reproduction steps: No clue, it just happened spontaneously.

  • Ruby KurosawaRuby Kurosawa Member Posts: 2 Civilian

    Id love to post a link to the video but unfortunately 'you have to be around a while longer before you can post links'

  • Dr_AculaDr_Acula Member Posts: 1 Civilian

    Version Squad V5.0.0.141812.505-4.27.2- Shipping

    Had this bug for last 3 month, prevents me from joining servers 8/10 times i boot up the game.

    Have tried- deleting EAC folder and verifying game files, restarting.

    Sometimes it helps to join proving ground (offline) and i can connect to a server, other times it doesn't help.

    I've seen people on reddit reinstalling windows with out luck.

  • PerkPerk Member Posts: 1 Civilian

    AK-12 + P178 scope fails to render around the horizon. Aim at the sky or ground you get a scope. Move your aimpoint to within about 20 degrees of the horizon and the scope disappears. You just get a blurred image with no scope graphic or reticle. This obviously makes it pretty hard to hit anything...


    Resolution: 5120x1440

    FOV: Below 100. Bug seems to go away with the FOV higher than 100. From 90 to 100 it occurs.

    All other settings do not impact. I've tried all Ambient Occlusion settings, all AA settings, all AS settings, and all Post Processing Settings. None make a difference to the repeatability of the bug. I've also tried both DX12 and DX11 render and fullscreen and fullscreen windowed with no difference.

    Bug persists through a Cache Clear and a Steam file validation.

    This does NOT impact other mounts for the P178. RPK + P178 on Airborne works normally. AK-12 Reddot also works fine.

  • Dani3lDani3l Member Posts: 185 ★★
    • Version:
    • Type: Serverbrowser
    • Description: TC filter not reliable
    • Screenshots/Video: see below
    • Reproduction steps: set filter as in screenshot, then wait for refresh to fully complete


  • Dani3lDani3l Member Posts: 185 ★★
    • Version:
    • Type: Gameplay
    • Description: vehicle wreck collision models are still desynced, for vehicles that were moving at fast speeds while being destroyed. There still are invisible wrecks that can act as very frustrating "invisible walls" for infantry and vehicles. In this example a british LPPV came in from the south-east.
    • Video: https://youtu.be/jJQmbEPD6AA
    • Reproduction steps: get shot or drive over AT-mine at fast speed. Now walk around the area behind the wreck (where the vehicle came from)
  • Dani3lDani3l Member Posts: 185 ★★
    • Version:
    • Type: Teambalance logic
    • Description: unable to switch team to the team with LESS players!! (default message "unbalanced teams" appears, instead of teamswitch attempt to only fail when you try to switch to a team that has at least 1 player more than the own team...)
    • Video: https://www.youtube.com/watch?v=FgdW_cnqOHI
    • Reproduction steps: join server with 19 and 20 players on both teams. Be in team with 20 players. Try to switch.
  • RetoremRetorem Member Posts: 1 Civilian
    edited July 5


    Type: Gameplay

    Description: After logging in to any server, the game crashes with a time interval of 10-40 minutes with the Unreal engine 4 error


    tips for solving the problem from the Internet do not help. reinstalled the drivers , deleted some files , formatted the disk and reinstalled the game but it didn't help

  • Trey of SpadesTrey of Spades Member Posts: 1 Civilian

    Mouse unable to move over to righthand 1/4th of screen. Cannot access settings button because of this, cannot play game. I'm almost at the point of demanding a refund.

  • Dani3lDani3l Member Posts: 185 ★★

    This is the 2nd time I hear about this issue. Is your game in "borderless"? Have you tried if the issue also persists in "fullscreen" mode??

  • Dani3lDani3l Member Posts: 185 ★★


    Type: object orientation

    Description: russian (airborne forces) helipads angled instead of horizontal flat (both of them)

    screenshots below

    Reproduction steps: run Goose Bay RAAS v1, spawn in russian mainbase, stand in front of helipads.

  • Dani3lDani3l Member Posts: 185 ★★
    edited July 6


    Type: squad management

    Description: "disband" squad function not working under specific circumstances, also lock icon getting replaced by the word "FULL"

    No screenshot sadly, forgot to take it

    Reproduction steps: create a locked squad, then click "invite all" (all players in the team. I clicked on it instead of "invite selected", by accident, and got kicked from the "Corrupted Infantry" server due to them not knowing of this bug...). Now more than 9 players have to press "page up" nearly at the same time to accept the invitation. Now right click your squad and click "disband". Nothing happens. Also, the red locking icon gets replaced by the word "FULL" for some reason.

  • Dani3lDani3l Member Posts: 185 ★★
    edited July 7


    Type: gameplay

    Description: Unable to observe own sniper rifle bullet impact through scope (without the scope shaking) before charging the reload handle/bolt. Affected weapons: SV-98M, C14 Timberwolf, Mosin Nagant M1891

    screenshot: not applicable

    Reproduction steps: hold right mousebutton to zoom in, then additionally hold left mousebutton to shoot and by that also delaying the reloading of next bullet. After 3 seconds, release left mousebutton. actual result: character instantly goes into reloading animation right after firing a shot, scope shaking a lot (unable to get a clear sight of bullet impact at target), regardless of left mousebutton state.

  • EggsDEggsD Member Posts: 4 Civilian

    Mouse unable to move over to righthand 1/4th of screen. Cannot access settings button because of this, cannot play game. I'm almost at the point of demanding a refund.

    I have this problem too. I have it set to 4K but the cursor is trapped and I can’t get it to the settings menu. No one has responded to my post from ages ago. Hella broken.
  • Dani3lDani3l Member Posts: 185 ★★
    edited July 24
    USMC kit bug STILL present... not previewing the weapon (in this example machinegun) while having kit selected after switching from medic kit... Thus unable to know which weapon which kit uses.


Sign In or Register to comment.