ePrivacy and GPDR Cookie Consent by Cookie Consent Skip to content

Squad 4.0 Technical Issues Report

OWI_IcareOWI_Icare Posts: 16 Moderator
edited February 8 in Game Support

Please report new issues here using the following format:

Bug Report Template:

  • Version: x.x (check on the main menu, bottom left)
  • Type: Map- the name of the map/Gameplay/Asset/Sound/Visual/Other bug
  • Description: Describe in detail the issue.
  • Screenshots/Video: Please include a screenshot of the issue and/or minimap location if applicable (and youtube/streamable video link if necessary)
  • Reproduction steps: how to reliably reproduce this bug (make sure it's reproducible in an online server, rather than in offline mode)
  • Any Exploit Bugs that are game-breaking should be sent via https://offworldindustries.zendesk.com/hc/en-us
  • Please do not report bugs from the Offline Testing Range.


  • AldebaranFSAldebaranFS Member Posts: 7 Civilian


    Type: Other bug

    Description: Game launched perfectly, but can't join any sever and get error message:"Cannot join an Anti-Cheat server without a valid steam connection to EAC." (Actually has been having this problem occurs since V3.4 patch came out...)

    Screenshots: as shown below

    Reproduction steps: join any server


    I tried:

    1. Reboot pc
    2. Reboot Steam
    3. Reinstall Squad
    4. Reinstall EAC
    5. Verify game integrity
    6. Checked Anti-virus/Firewall settings

    All didn't work.

    Any help would be appreciated!

  • AldebaranFSAldebaranFS Member Posts: 7 Civilian

    im losing it... cant play on server since the Harju patch came out. Is it only me having this problem in this community? im so unlucky,

  • AldebaranFSAldebaranFS Member Posts: 7 Civilian
    edited December 2022

    yeah maybe i could go to offline testing range to play PLA faction plus jerk off to have a good sleep. I will make a wish on my next birthday (after 7 months) and check if this EAC connection problem would fix itself

  • GCANickOGCANickO Member Posts: 1 Civilian

    Can't launch the game after the 4.0 update.

    Fails with the below error message and the EasyAntiCheat service is not starting. It is not possible to launch "EasyAntiCheat_EOS_Setup.exe" from the squad install folder either. Nothing at all happens when trying to start it.

    I am able to successfully launch and play both Post Scriptum and Albion Online that both use EasyAntiCheat.

    I have tried:

    Reinstalling Squad

    Deleting the squad appdata folder

    Verifying game files

    Renaming the EasyAntiCheat folder in Squad and verifying game files to create a new folder

    Disabling Anti-Virus and Firewall

    Trying to launch EasyAntiCheat_EOS_Setup.exe as admin

    Launching EasyAntiCheat_Setup.exe from the Post Scriptum folder (which works) and repairing EasyAntiCheat

    Launching EasyAntiCheat_Setup.exe from the Post Scriptum folder (which works) and uninstalling and then installing EasyAntiCheat whilst selecting "Squad" instead.

    Installed latest Visual C++ 2015-2022 Redist (x86 & x64)

    Restarted my computer several times

    I have never had this issue before trying to launch the game after the 4.0 update and I've played since closed beta. Although it was a few weeks ago I launched the game last.

  • 020208smd020208smd Member Posts: 1 Civilian

    Unable to start the game, prompting that Easy Anti-Cheat is not installed.

    The EAC (EasyAntiCheat_EOS_Setup) fix in the game directory also does not work.

    I see that other players have also reported this problem.

  • Mauro43Mauro43 Member Posts: 1 Civilian

    i have this problem since update 3.4 wait for 4.0 and still have the same problem

  • HomickHomick Member Posts: 1 Civilian
    edited December 2022
    • Water layer is not visible on Mutaha RAAS V7
    • Version: 4.0
    • Type: Mutaha - Visual/Gameplay
    • Description: Water is not visible on this layer, additionally gameplay elements linked to it are broken (possibly also cause CTD)
    • Screenshots/Video: Wish I could but this damn forum won't let me
    • Reproduction steps: Join Mutaha RAAS V7

  • sneakylikeasneksneakylikeasnek Member Posts: 91 ★★

    Version 4.0

    Type: Audio/vehicle

    ZBD4 Engine is Silent/extremely quiet and only audible at less than 5 meters or so.

    Reproduction steps: approach ZBD as infantry.

  • sneakylikeasneksneakylikeasnek Member Posts: 91 ★★

    Version 4.0

    Type: Graphical

    PLA infantry do not get muddy/sandy/dusty like other factions.

  • TheLoneRangoTheLoneRango Member Posts: 8 Civilian

    Version 4.0

    Type: Internal

    loading into game the very first loading screen prior to the main menu freezes after bouncing 3 helmets for a few moments. Stays frozen and not responsive in TM but has flow with CPU and MEM Usage.

    No menu sound functions either during process failure.


    Attempt to reverify integrity of files three times; Issue still concurrent.

    Attempt to uninstall all workshop mods and launch without reverification of integrity.

    Resolution: Invalid/Incompatible workshop mod.

    After uninstallation of all workshop mods the game launched through successfully with no issues or delays.

    If someone gives me information of where to provide the crash log I can specifically identify what workshop mod would be causing this issue.

    For anyone else who IS having this issue or any issue that is relative to menu/loading/ingame loading processes; It is best to just delete every mod from your workshop downloads and test without reverification first. I hope this helps people who are having issues.

  • SkylarkSkylark Member Posts: 1 Civilian

    I am having EAC problem get this after playing on a server for a about 20 minutes.

    I removed everything Game, easyanticheat, appdata, local cache and downloaded a the game fresh from steam (took 7 hours) and still have the problem. I can see EasyAntiCheat_EOS running under services and not crashing restarting or anything like that.

    I where to guess.. there is some session timeout with a connection with steam that either requires a heartbeat or needs be synced.

    I'm in Europe if that narrows things down.

    This is really bad timing, I was getting back to the game after some hiatus and trying to get my few friends to start playing this game and the smug smiles they gave me means I'm probably going to have to play whatever game they pick for some time.

    so no Squad in Squad for me......

  • ViajeroViajero Member Posts: 17 Civilian
    edited December 2022

    Apologies if reported already, There seems to be an issue in wide or ultrawide resolutions (in my case is 3440x1440) when it comes to use the new PLA AntiTank range finder. The top part of the screen is cropped before aiming down sights and the range digits can not be seen. See screenshots here before aiming down sights and after aiming down sights at 3440x1440:

    Before aiming down sights, you can see the red range digits at the top are cropped out of the view:

    And just for comparison purposes here is the same image after pressing shift for aiming down sights:

  • CassCass Member Posts: 6 Civilian

    I have an issue with my game crashing that began since the most recent update.


    Type: Game Crashing & Lagging Hard

    Description: I will be playing and then all of the sudden the game will freeze, the audio will loop and I will be unable even to open Task Manager. I have to log out of my Windows profile in order to stop Squad. I have an ultrawide monitor and play at 3840x1080 Native Resolution.

    I used to be able to Alt + Tab out of Squad to access other windows, but since the latest update, I am no longer able to do it anymore. I think they may have something to do with the issue.

    Screenshots/Video: I will try to capture a video if possible.

    Reproduction steps: I am unable to reproduce the issue, it will occur after 20 minutes of playing or during intense action.

  • AldebaranFSAldebaranFS Member Posts: 7 Civilian
    edited January 21

    It has been 2 months since this EAC problem occured, still not fixed. @OWI_Icare please at least respond.

  • WeLLKinGWeLLKinG Member Posts: 1 Civilian
    edited January 28

    Version: and (ALLVERSIONS)

    Type: VOIP/MIC

    Description: Hello, I and the whole community have a problem.

    I play squad with my usb headset and if I remove my usb or if it is accidentally removed, the voip stops capturing my mic. I have to restart the game again, my country(BR) has few online servers, and I have to wait 20~40 minutes in queue, it makes me upset.

    It isn't an isolated problem, it affects many people and impacts the quality of the players, losing the squad slot, the soldier kit and not being able to communicate during a confrontation, stopping to write is horrible. Please, I ask you to improve the squad. Thanks.

    Screenshots/Video: It's not possible, but it's public knowledge.

    Reproduction Steps: Step 1: Open the game. Step 2: Remove the USB headset or accidentally remove it. Step 3: Reconnect USB headset and voip stops.

This discussion has been closed.