Jump to content
D4rkS4v4nt

Unofficial CROSSFIRE configuration for Squad

Recommended Posts

Hi Folks,

 

Did some searching for specific AMD Crossfire settings and couldn't find anything so I've written down what I've configured to get Crossfire working on my setup also with Eyefinity.

 

EDIT: Found some posts but they weren't very specific so I've tried to get a more complete list of settings below.

 

With the settings below I can get 60FPS most of the time with VSYNC = ON @ 5760x1080 Eyefinity resolution.

  • Intel i5 3570k (Ivybridge) @ 4.6GHz
  • 8Gb (2x4Gb) Teamgroup Extreme @ 2133MHz
  • MSI Z77A-GD65 Motherboard
  • 2 x AMD R9 290 @ 1040 / 1350

I'm using AMD Crimson v15.11.

 

First following the FPS tweak guide here - http://forums.joinsq...-for-extra-fps/

 

Now here are the settings you are looking for -

 

NOTE: The important in-game graphics setting appears to be EFFECTS = LOW (as soon as I set this higher than low then the FPS drops considerably to around 10-20FPS)

 

zHDKMfm.jpg

 

MJT7jvs.jpg

 

AFR Friendly Method (causes Flickering)

Should look like the below -

 

NOTE: AMD Crossfire Mode = AFR Friendly

 

ccXWwd5.jpg

 

 

OK now load up Squad and these are my graphics settings below - (I'm running at 5760x1080 resolution however and with a FOV of 120)

 

NOTE: You HAVE to use FULL SCREEN mode to utilise more than 1 GPU.

 

You also need VSYNC = ON and need to maintain 60 FPS (if you are having trouble reaching 60FPS then reduce your settings until you can do so).

 

The only reason "borderless" is selected below is so I could screenshot the settings for this post.

 

UWADsWz.jpg

 

Cheers

 

-=SD=-D4rKS4v4nt

Share this post


Link to post
Share on other sites

how do you like the new drivers? I'm wayyyy back with my drivers, probably 15.7 ish or something, they work great but no Crossifre active in game... I have 290x in crossfire with the same CPU as yours and 1920x1080 27" monitor. Whats the usage you get on both cards in game, how much FPS boost you have over the single card? if any....

Share this post


Link to post
Share on other sites

I'm on 15.11.1 catalyst. No profiles. 7970s in xfire. Also I have everything on epic. 50 -60fps until fools road map. I can't play with my triple screens though. It feels so awkward.

Share this post


Link to post
Share on other sites

how do you like the new drivers? I'm wayyyy back with my drivers, probably 15.7 ish or something, they work great but no Crossifre active in game... I have 290x in crossfire with the same CPU as yours and 1920x1080 27" monitor. Whats the usage you get on both cards in game, how much FPS boost you have over the single card? if any....

 

I'm liking the new drivers a lot, much easier to configure settings per-game than the previous drivers and less reason to use third-party utilities to tweak the settings.

 

Most of the time whilst out in the open and looking around I see 100% usage across both cards, whilst in buildings or walled areas this drops sometimes to a single card at 100% and the other 0%. I was previously seeing around 30-40FPS on a single card at the same resolution and lower quality settings.

Share this post


Link to post
Share on other sites

I guess that explains me having 38-45 FPS on a 72-100 players server, will give this drivers a shot. Never updated the drivers because the current old version was crispy clean, but new games come out and time to update drivers. Thanks for the tips dude :)

Share this post


Link to post
Share on other sites

wow just tested the new drivers, I mean they are sooooo jittery ingame..... too many lag spikes, before I had more constant lag or no lag at all but was steady, now jitters every where because the usage of the GPU goes from 20-100% at any given time. As far as Crossfire.... no dice still the second card is sleeping, if this continues like this I might reverse to the old 15.7 drivers, these 15.12 seem really shitty.

Share this post


Link to post
Share on other sites

No problems here, Game runs sweet at epic 1440p on single 290 + i7 3770k.. 
The map my biggest performance killer atm is Fools Road that will drop me down to avg 30fps..... Thing to remember here guys we testing a very early game still in Alpha not only that also a very early Engine in Unreal 4.. 

 

This was on a 72 man server

interpolation_lanczos_none_output_format

 

http://images.akamai.steamusercontent.com/ugc/351643763268499170/22FE8F046DF8E5A35B8E34EFF98764D31219431D/?interpolation=lanczos-none&output-format=jpeg&output-quality=95&fit=inside|2048:1152&composite-to=*,*|2048:1152&background-color=black

Share this post


Link to post
Share on other sites

Hi Folks,

 

Did some searching for specific AMD Crossfire settings and couldn't find anything so I've written down what I've configured to get Crossfire working on my setup also with Eyefinity.

 

 

 

There are actually several crossfire post on the  forums. Links for two: http://forums.joinsquad.com/topic/8660-crossfire-support/, http://forums.joinsquad.com/topic/7756-unofficial-crossfire-fix-for-squad/.But on another note I did try your configuration will little  success unfortunately. Running a R9 295 x2 and actually saw a dip in frame rate when moving from full screen to border less. Although border less did remove the flickering apparent when in full screen. Possibly because when in border less there was little to no use of my second GPU, rarely using more than 15 percent on the second GPU. When in full screen how ever i would see 100% usage across both GPU's but with the obvious flickering. What was the GPU usage across your cards when in game in border less?

Share this post


Link to post
Share on other sites

wow just tested the new drivers, I mean they are sooooo jittery ingame..... too many lag spikes, before I had more constant lag or no lag at all but was steady, now jitters every where because the usage of the GPU goes from 20-100% at any given time. As far as Crossfire.... no dice still the second card is sleeping, if this continues like this I might reverse to the old 15.7 drivers, these 15.12 seem really shitty.

 

 

There are actually several crossfire post on the  forums. Links for two: http://forums.joinsquad.com/topic/8660-crossfire-support/, http://forums.joinsquad.com/topic/7756-unofficial-crossfire-fix-for-squad/.But on another note I did try your configuration will little  success unfortunately. Running a R9 295 x2 and actually saw a dip in frame rate when moving from full screen to border less. Although border less did remove the flickering apparent when in full screen. Possibly because when in border less there was little to no use of my second GPU, rarely using more than 15 percent on the second GPU. When in full screen how ever i would see 100% usage across both GPU's but with the obvious flickering. What was the GPU usage across your cards when in game in border less?

 

Hey - not sure how much of the screenshots you followed above but you should be using FULLSCREEN mode as using "borderless" or "windowed" mode will prevent you utilising more than 1 GPU.

 

Thanks for the links will check them out, I tried many ways of getting crossfire to work including using the builtin Skyrim and Batman profiles with no success.

 

EDIT: Yes saw those posts before - not much of a guide though and more a conversation with several people suggesting methods that *may* work but no definitive guide... Just for the record Optimize 1x1 did not work for me and gave me worse frames than a single card (10-20fps) and very laggy.

 

Also if you have updated your drivers did you clean out the old drivers first? You really should use a tool such as "Display Driver Uninstaller" to make sure there aren't any files / settings left behind by the previous version.

 

http://www.guru3d.com/files-details/display-driver-uninstaller-download.html

Share this post


Link to post
Share on other sites

Quick update - I'm also using the config file tweaks from this thread - http://forums.joinsquad.com/topic/5869-performance-tweaks-for-extra-fps/

 

You also NEED VSYNC ON... and you need to maintain 60 FPS otherwise you will get flickering.

 

By enabling VSYNC and changing the graphics settings until I could achieve 60 FPS around 90% of the time has reduced the flickering considerably for me and on less heavy maps I have no flickering at all.

Share this post


Link to post
Share on other sites

will give it a shot again today and see how it goes, yes I removed old drivers with drivers sweeper in safe mode after unistalling the manually first from the programs in the control panel

 

EDIT: just tested it out, yes lots of more GPU usage for sure and crossfire works too, but FPS are same or even worse then 15.7 drivers, this absolutely means for me I'm reverting to the old drivers.

Share this post


Link to post
Share on other sites

Just wanted to say thanks! I'm now running this game at 4k holding 60fps with your exact settings.. hell gpu usage isn't even close to 100% being capped at 60fps. 

Crimson Drivers and using 2 of my 290's. 

 

WOOO!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×