Jump to content
IrOnTaXi

Enabling texture streaming in current build. NOT TESTED

Recommended Posts

THIS HAS NOT BEEN TESTED BUT SHOULD WORK

 

The full effect of these optimizations wont be evident until the next patch comes out. 

 

Just wanted to make a quick post here about things you can do in the interm while we prepare the next big patch. 

 

It is possible although not tested to turn on texture streaming and set a memory pool appropriate to your system as well as disable frame smoothing. 

 

I will outline here. 

 

1. Enable texture streaming

 

Open the defaultengine.ini file in squad/config and look for the following line and change it to true. 

r.TextureStreaming=False

Save and run the game. 

 

2. Set approrpiate sized vram pools. 

 

Open the defaultscalability.ini in squad/config and add these sections to the bottom.

[[email protected]]r.Streaming.MipBias=1r.MaxAnisotropy=0r.Streaming.PoolSize=2000 [[email protected]]r.Streaming.MipBias=1r.MaxAnisotropy=2r.Streaming.PoolSize=2500 [[email protected]]r.Streaming.MipBias=0r.MaxAnisotropy=4r.Streaming.PoolSize=3000[[email protected]]r.Streaming.MipBias=0r.MaxAnisotropy=4r.Streaming.PoolSize=4000 

 

NOTE:
 
a. These settings will be associated with the texture quality settings in the graphics menu. 0 being LOW and 3 being EPIC
b. In our current build the dense maps are trying to allocate approx 3.5 - 4gig of texture memory. This has been optimized in next release (more like 2 ish)
 
Explanation: 

 

r.Streaming.MipBias - Each value above 0 will cut all textures in game by 50%. Using a value higer than 2 will look ridiculously low res. I would recommend 1 if you are struggling. 
r.MaxAnisotropy - Filter method for textures - 0 to 8. 16 is possible but probably kill your frames
r.Streaming.PoolSize - How much VRAM you want squad to use. at least 2000 is recommended. 1000 will probably work but will need to wait for our full patch to see the best benefits. 

 

1. Disable default Frame smoothing

 

Open file baseengine.ini in squad/engine/config

 

Find the following line and change it to false

bSmoothFrameRate=true 

Save and start game. 

 

I would love you guys to play with this and let me know how it goes. 

 

Net effect should be. - Properly sized VRAM pool and Texture sizes for your system. No clamp on frame rate in game. 

 

 

Cheers. 

Share this post


Link to post
Share on other sites

I'm at work and I wish I was home to test this!!!

no promises but this is what i have learned last few days. 

Share this post


Link to post
Share on other sites

My Findings with below PC setup (will also do another with a lower Vram Card later)

 

CPU - i7 4790k

GPU - r9 390x 8gb Vram

Ram - 8gb @ 1600

 

So I lowered all of my settings to the 'Low' Preset on Quality settings. (Wanted to also see which settings reduce fps the most when increased)

 

Decided to run the training map so i didnt take into account difference in server setups and player numbers and maps.

 

Structure of test:

- Launch Game > Training > USA > Create Squad > Squad Leader Role > Run up to hesco > Wait 2 minutes and note fps down using both Stat fps and Dxtory Fps counter 

 

With OUT any of the above changes i got a stable 122 fps.

 

With Changes i was on 180-188fps.

With Changes @ 100% Res Scale (Default on Low is 77% - or is in the 70's can't remember what exact number) i was on 138-144fps.

 

More tests to come along with Epic Preset Tests

 

I did not get any difference in either of the Texture ranges (from low to epic / 0 - 3) but thats because of the 8gb card

Share this post


Link to post
Share on other sites

My Findings with below PC setup (will also do another with a lower Vram Card later)

CPU - i7 4790k

GPU - r9 390x

Ram - 8gb @ 1600

So I lowered all of my settings to the 'Low' Preset on Quality settings. (Wanted to also see which settings reduce fps the most when increased)

Decided to run the training map so i didnt take into account difference in server setups and player numbers and maps.

Structure of test:

- Launch Game > Training > USA > Create Squad > Squad Leader Role > Run up to hesco > Wait 2 minutes and note fps down using both Stat fps and Dxtory Fps counter

With OUT any of the above changes i got a stable 122 fps.

With Changes i was on 180-188fps.

With Changes @ 100% Res Scale (Default on Low is 77% - or is in the 70's can't remember what exact number) i was on 138-144fps.

More tests to come along with Epic Preset Tests

I have a it 920 currently. I hope to get at least 50% of those results.

Share this post


Link to post
Share on other sites

Don't notice any visual difference when going from Low to Epic setting, but I was now able to play Chora without stuttering (server with 72 players). When we first released on Steam it was pretty bad for me. Turning or firing my gun would freeze everything for a while.

 

I tried r.TextureStreaming before EA and it brought along texture switching and terrain differences (seeing floating rocks, people in the ground, etc). Not happening any more.

Share this post


Link to post
Share on other sites

Why don't I have a defaultengine.ini in the squad/config folder? My engine.ini does not have anything in it but this:

 

[Core.System]
Paths=../../../Engine/Content
Paths=../../../Squad/Content
Paths=../../../Engine/Plugins/2D/Paper2D/Content
Paths=../../../Engine/Plugins/Runtime/LeapMotionController/Content
Paths=../../../Squad/Plugins/TrueSkyPlugin/Content

Share this post


Link to post
Share on other sites

Very limited test, just running around. Using epic textures, but a poolsize of 3000 (guessing its limited by vram, on a 280x). Everything else same as original post.

 

Joined HostileTakeover, 72 people on. Kohat Skirmish.

 

Spawned in a room. Some texture popin is noticable now when on the move. Like when I spawned in, was in a room and could notice the textures loading on the cupboard. But nothing wacky.

 

Can't comment if the FPS has increased because I have my FPS capped to 60 in MSI Afterburner. but the FPS dips aren't nearly as dramatic as before. Average frame time was around 20ms/50fps out of combat  like before but without the dips to 30 in some locations/instances. 

 

Looks promising, especially once you optimize the size of the maps.

Share this post


Link to post
Share on other sites

 

Why don't I have a defaultengine.ini in the squad/config folder? My engine.ini does not have anything in it but this:

 

[Core.System]
Paths=../../../Engine/Content
Paths=../../../Squad/Content
Paths=../../../Engine/Plugins/2D/Paper2D/Content
Paths=../../../Engine/Plugins/Runtime/LeapMotionController/Content
Paths=../../../Squad/Plugins/TrueSkyPlugin/Content

 

Think you're looking in the appdata Squad folder. Go in your Steam Squad folder. (Steam\SteamApps\common\Squad\Squad\Config)

Share this post


Link to post
Share on other sites

Think you're looking in the appdata Squad folder. Go in your Steam Squad folder. (Steam\SteamApps\common\Squad\Squad\Config)

 

That would do it. Thanks!

Share this post


Link to post
Share on other sites

These changes should help with lower performance systems. You will most likely not notice much on high end systems.

 

especially the frame drops on quick turning should be reduced.

Share this post


Link to post
Share on other sites

 

 

1. Disable default Frame smoothing

 

Open file baseengine.ini in squad/engine/config

 

Find the following line and change it to false

bSmoothFrameRate=true 

I find this setting at 164 and 1513. Line 1513 was already set to False though so I changed line 164 to match. Off to test now.

Share this post


Link to post
Share on other sites

Still getting the same fatal crash after 30 min :(

That's the issue I am having also. Going to test these settings now and I'll report back.

Share this post


Link to post
Share on other sites

I agree. Crashes very quickly now that I made the changes. reverting back for now. I used to soft crash to the desktop now I hard crash. Next step Blue screen! LOL

 

 

P.S. I have a I7 860 @stock speeds, 16gb Ram @1600 and a GTX 560Ti @ stock speeds.

 

All vitals look ok and this was right before a crash so... Good luck Devs! :P

79770b396ae8999e365be8657bca0057.png

Share this post


Link to post
Share on other sites

I agree. Crashes very quickly now that I made the changes. reverting back for now. I used to soft crash to the desktop now I hard crash. Next step Blue screen! LOL

P.S. I have a I7 860 @stock speeds, 16gb Ram @1600 and a GTX 560Ti @ stock speeds.

All vitals look ok and this was right before a crash so... Good luck Devs!

79770b396ae8999e365be8657bca0057.png

I feel like we might be hitting a gpu bug. Hmmm

Share this post


Link to post
Share on other sites

I think so. I reverted back and now I'm back to just crashing to the desktop.

 

I don't see how changing the settings we are messing with would change that but who knows PCs can be weird at times.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×