Jump to content
Sign in to follow this  
NanoAgeWarrior

60FPS and unplayable due to constant freezing

Recommended Posts

Ok so what happens is every 5-10secs or so, my game freezes up completely for 2-10secs making it unplayable. Some maps work better, but for example Chora or fools road, it's impossible to even walk in a straight line. I told this to Irontaxi ingame he said for me to check the forums, i looked around and didnt see anyone with this particular problem so here i am. CPU never goes above 60%.

Specs:
R9 270X 2GB GDDR5

i5 3570k O.C 4.2Ghz
8GB DDR3 2133mhz
Asrock Z77 Pro3
Samsung SSD 840 EVO
using Windows 7 x64bits


I have tried changing AMD drivers to the beta ones, changed every possible config (theres almost no difference in FPS between low and medium/high). Went as far as put the game on 1280x1024 and I still had the exact same issues.

HELP!

EDIT: What I'm experiencing also is performance degradation. I start the match at full 110 FPS, and over time it goes down. During the round and in-between them. Usually happens when a firefight starts going on and people throw smoke grenades (these are killer for FPS btw, i tested in training, just 4 smokes will get your FPS from 120 to 40ish). When the FPS get to around 30-40 the freezes start getting more severe, between 1 to 3 secs, all the way to 15secs and complete freeze. Only fix is to restart the game.

SOLVED: bought 2x4GB ram, i have 16GB now. Played a full round of Fools road with 0 issues. Still doesnt make sense how people with only 8GB can play with no problems while my game takes likes 11GB of ram. Oh well, thanks for the help!

Share this post


Link to post
Share on other sites

Do you have an antivir software running? Try disabling it while playing squad. You only have one of those cards and are not running crossfire right?

Share this post


Link to post
Share on other sites

I've got a similar system and got exactly the same issue here. There are 3 possible solutions at the moment

1. Wait until Unreal Engine 4.11 gets released (supposed to fix performance issues)

2. Wait intil AMD releases a new graphic driver

3. You can try installing 15.7 drivers for your gpu (No freezes for me but i get crashes to desktop)

Share this post


Link to post
Share on other sites

Ok so what happens is every 5-10secs or so, my game freezes up completely for 2-10secs making it unplayable. Some maps work better, but for example Chora or fools road, it's impossible to even walk in a straight line. I told this to Irontaxi ingame he said for me to check the forums, i looked around and didnt see anyone with this particular problem so here i am. CPU never goes above 60%.

Specs:

R9 270X 2GB GDDR5

i5 3570k O.C 4.2Ghz

8GB DDR3 2133mhz

Asrock Z77 Pro3

installed on a samsung SSD 840 EVO

I have tried changing AMD drivers to the beta ones, changed every possible config (theres almost no difference in FPS between low and medium/high). Went as far as put the game on 1280x1024 and I still had the exact same issues.

HELP!

 

Very cool rig , not your fail bro!

Wait amd driver update and squad patch!

 

best regards!

Share this post


Link to post
Share on other sites

Do you have an antivir software running? Try disabling it while playing squad. You only have one of those cards and are not running crossfire right?

I dont even have an anti virus installed.

Yes, single card, no OC on the GPU.

Share this post


Link to post
Share on other sites

I've got a similar system and got exactly the same issue here. There are 3 possible solutions at the moment

1. Wait until Unreal Engine 4.11 gets released (supposed to fix performance issues)

2. Wait intil AMD releases a new graphic driver

3. You can try installing 15.7 drivers for your gpu (No freezes for me but i get crashes to desktop)

you gotta be kidding me : /

I'll try the 15.7 drivers, maybe ill get lucky.

Share this post


Link to post
Share on other sites

you gotta be kidding me : /

I'll try the 15.7 drivers, maybe ill get lucky.

Make sure you uninstall your current driver using DDU. You can find it here:

http://www.guru3d.com/files-details/display-driver-uninstaller-download.html

 

EDIT: Looks like i found a solution to the problem.

1. Uninstall Squad, Go to steam , click on Squad and then on "delete local content"

2. Go to the folder where squad is installed and delete it  ->  \steamapps\common (Don't forget to empty the recycle bin)

3. Go to C:\Users\YourUserName\AppData\local   - Delete Squad folder (Don't forget to empty the recycle bin)

4. Uninstall your current graphics drivers using DDU and install 15.11.1 CATALYST NOT CRIMSON (!)

5. Redownload the game through Steam

6 (OPTIONAL) Install a program called "Clockblocker" what it does is prevents your AMD GPU from downclocking

 

 

My specs in case someone else is having the issue:

R9 390 8GB GDDR5

i5 4690k O.C 4.4Ghz

8GB DDR3 2400mhz

Gigabyte Gaming 3 Z97

Game installed on a Samsung SSD 850 EVO

Share this post


Link to post
Share on other sites

Make sure you uninstall your current driver using DDU. You can find it here:

http://www.guru3d.com/files-details/display-driver-uninstaller-download.html

 

EDIT: Looks like i found a solution to the problem.

1. Uninstall Squad, Go to steam , click on Squad and then on "delete local content"

2. Go to the folder where squad is installed and delete it  ->  \steamapps\common (Don't forget to empty the recycle bin)

3. Go to C:\Users\YourUserName\AppData\local   - Delete Squad folder (Don't forget to empty the recycle bin)

4. Uninstall your current graphics drivers using DDU and install 15.11.1 CATALYST NOT CRIMSON (!)

5. Redownload the game through Steam

6 (OPTIONAL) Install a program called "Clockblocker" what it does is prevents your AMD GPU from downclocking

 

 

My specs in case someone else is having the issue:

R9 390 8GB GDDR5

i5 4690k O.C 4.4Ghz

8GB DDR3 2400mhz

Gigabyte Gaming 3 Z97

Game installed on a Samsung SSD 850 EVO

Thanks for the heads up man, im tearing my hair out. I'll give this a go.

Share this post


Link to post
Share on other sites

Ok so what happens is every 5-10secs or so, my game freezes up completely for 2-10secs making it unplayable. Some maps work better, but for example Chora or fools road, it's impossible to even walk in a straight line. I told this to Irontaxi ingame he said for me to check the forums, i looked around and didnt see anyone with this particular problem so here i am. CPU never goes above 60%.

Specs:

R9 270X 2GB GDDR5

i5 3570k O.C 4.2Ghz

8GB DDR3 2133mhz

Asrock Z77 Pro3

installed on a samsung SSD 840 EVO

I have tried changing AMD drivers to the beta ones, changed every possible config (theres almost no difference in FPS between low and medium/high). Went as far as put the game on 1280x1024 and I still had the exact same issues.

HELP!

I have better experience with the one year old 14.501.1003 drivers (also, not using the Crimson software but the 14.12 AMD Catalyst Omega Software instead!),

way less/no stuttering that with the newer drivers.

​What OS are you using?

​Windows 7 x64 Archive

​Windows 8.1 x64 Archive

Share this post


Link to post
Share on other sites

Thanks for the heads up man, im tearing my hair out. I'll give this a go.

I've had these issues since V2, it was so annoying. Since i already found a solution that worked for me, please let me know if that worked for you too. Thanks

Share this post


Link to post
Share on other sites

i have win 7 64x bits, i edited the original post, thanks for the drivers link! Theres no 15.11 so im getting the 15.17.1 i hope its ok.

 

Did you try updating DirectX?

 

EDT: Also maybe try disabling Steam ingame overlay for Squad.

 Yes to both, no luck.

Share this post


Link to post
Share on other sites

Tried does. I joined Red coats #1, the freezing was so bad i had to ctrl + alt +del out of the game, couldnt even open the menu. This is incredibly frustrating i appreciate you trying anyway.

Helped for me. Weird.

Share this post


Link to post
Share on other sites

Join a 50 slot server. Might be better

Played logar 30vs30, ZERO ISSUES. Chora / Fools Road, so bad i cant even exit the game through the menu. Something is wrong here

 

Helped for me. Weird.

Thanks man, i appreciate the effort

 

I play in borderless. That might help some.

Did, no luck. Havent tried in window though, gonna give it a shot.

Tried it , same thing.

 

Share this post


Link to post
Share on other sites

Have you tried putting shadows to high and reducing textures to 512?

Disable radio filter in audio.

Share this post


Link to post
Share on other sites

Have you tried putting shadows to high and reducing textures to 512?

Disable radio filter in audio.

No change.

Played a game of logar at night, had maybe 1, 2sec freeze in 15min of gameplay. I guess i just need to leave when i see fools road or chora...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×