Jump to content
MWard

New Rig - Low FPS

Recommended Posts

Hi guys, sorry if this is a repeat. I did a search as best I could and couldn't quite find what I was looking for.

 

Built a new computer this week, specs as follows

 

Windows 10 Home 64 bit

 

i7 4790k not o/c'd

msi gtx 970 4gb 

msi z97 5

2 x HyperX Fury 8gb

Samsung Evo 250 SSD (OS and game installed on same)

rosewill hive 750w PSU

CM 212 Evo

 

I believe that I have both the c++ and dirextx runtime prereqs properly installed.

 

 

My issues is that in game my fps hovers around 20, more often around the 16 fps mark. There is little change with any number of changes to the graphics settings in game, including using all the preset functions from epic to low.

 

This is only true when in a server. When using the training function, my FPS are triple digit. I don't believe it is an issue with my internet speed -

 

4905470071.png

 

 

 

CPU core temps 30C =/- idle, never pushing 62C under load.

 

This is my first build, and I could very easily be overlooking something silly.

 

EDIT: For reference, I did test in more than one server. 

Share this post


Link to post
Share on other sites

Try stat unit in console and see which is giving highest/worst result.

 

Use an on screen display to see CPU and GPU utilization. (Afterburner is good for this)

 

I have same CPU, get decent FPS but it's OC'd to 4.6-4.7GHz and using a 980ti. At stock 4.4 turbo it's fine though.

My mate has no issues on a 970 either, same CPU again.

 

Even screen cap HWMonitor (if u download it), screen cap your OSD in game - showing clock speeds, memory use, CPU+GPU utilizations, etc.

 

Someone more knowledgeable will probably pop up and fix :P

Share this post


Link to post
Share on other sites

some other guy had a similair issue and it turned out to be his windows power settings were set to power saver ( which underclocks all your stuff to save power)
make sure its set to high performance.

Share this post


Link to post
Share on other sites

As always, the simplest solution. Sitting pretty (and feeling a little dumb) with 70 FPS on epic. Thank you, thank you, thank you! 

Share this post


Link to post
Share on other sites

Power settings - set to max performance

Run it with no other unnecessary programs running.  (ts3 or anything)

Test on multiple servers.   There's one tacticalgamer server where I can never load-in correctly, for example.

Adjust your graphics settings to mid or low.

Delete all Squad files, including AppData files, re-install

Check for any driver/Windows OS/Program updates.

 

if that fails.

 

Get faster RAM.   What is it, 1600Mhz?

 

This is what I get for reading everything but the last post.

Share this post


Link to post
Share on other sites

Taking it off power saving mode. Didn't realize I had turned it on. The computer had been going to sleep quite quickly, and this solved that little problem too.

Share this post


Link to post
Share on other sites

Also check the power settings in your nvidia control panel, pretty sure they always default away from performance mode whenever your GPU driver is updated.

Share this post


Link to post
Share on other sites

Could someone explain how to change theses settings ? Cant seem to be able to ... (Win10 64bit)

windows key +i

system

power and sleep

additional power settings

show additional plans

select high performance

change plan settings

advanced power settings

hard disk power off - never

processor power max = 100

system cooling active

minimum state (i have 100 but can put to 25)

give that a try

Share this post


Link to post
Share on other sites

windows key +i

system

power and sleep

additional power settings

show additional plans

select high performance

change plan settings

advanced power settings

hard disk power off - never

processor power max = 100

system cooling active

minimum state (i have 100 but can put to 25)

give that a try

 

It helped me gain 5~10fps, but I'm still at around 20~25fps (50players game)

Share this post


Link to post
Share on other sites

It helped me gain 5~10fps, but I'm still at around 20~25fps (50players game)

 

If you are having FPS trouble I would suggest checking your graphic card settings, and ensure they are set to high performance. Make sure your drivers are up to date aswell.

 

I was having microstutters, and all of the others horrors of FPS lag, but since I changed my settings everything has seemed to resolve itself. Also shadows are the heaviest in terms of performance, so try tweaking those settings if changing your card/power settings do not improve performance.

Share this post


Link to post
Share on other sites

If you are having FPS trouble I would suggest checking your graphic card settings, and ensure they are set to high performance.

 

Again I'm not really sure on how to do that. I have a GTX970, so I guess theses settings are in GeForce Experience ?

Share this post


Link to post
Share on other sites

My nvidia recommended settings:

3D settings: Use the advanced 3D image settings

Global settings

Max pre-rendered frames: 1

Multi-display/mix-gpu accel: Single display performance mode

Power management mode: Prefer maximum performance

Preferredd refresh rate: Highest available

Texture filtering - Quality: High performance

Vertical sync: Off

 

Adjust desktop size and position:

No scaling

Share this post


Link to post
Share on other sites

My nvidia recommended settings:

3D settings: Use the advanced 3D image settings

Global settings

Max pre-rendered frames: 1

Multi-display/mix-gpu accel: Single display performance mode

Power management mode: Prefer maximum performance

Preferredd refresh rate: Highest available

Texture filtering - Quality: High performance

Vertical sync: Off

 

Adjust desktop size and position:

No scaling

 

What I meant is where do you go to change theses settings ?

Share this post


Link to post
Share on other sites

Is the onboard video disabled in the bios? I think it might be using up ram?? Might be a stupid question but id look into the onboard video that those cpu's have and I heard if there on in the bios even though u have an added gpu card, it will still bog down games..

Share this post


Link to post
Share on other sites

It's pretty clear that there is a ton of optimization yet to be done on this title. It's not that the graphics are great, and they don't need to be for a game like this. But there's tons of work that needs to be done under the hood. 

Share this post


Link to post
Share on other sites

It's pretty clear that there is a ton of optimization yet to be done on this title. It's not that the graphics are great, and they don't need to be for a game like this. But there's tons of work that needs to be done under the hood.

Optimization is still evident. Runs fine for a lot of people.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×