Jump to content
dougwvb

Horrible lag spikes when you turn

Recommended Posts

That gamebooster thing looks super dodgy. How about an actual fix that doesn't involve downloading some random exe from the web?

Share this post


Link to post
Share on other sites

That gamebooster thing looks super dodgy. How about an actual fix that doesn't involve downloading some random exe from the web?

I think it's safe to say that a number of people have used it and it fixed the problem and their computer isn't on fire.

Share this post


Link to post
Share on other sites

I, for one, am not putting random weird programs on my computer to fix something the devs will probably fix in a few weeks. 

Share this post


Link to post
Share on other sites

Hello Squad friends,

 

We have a clan of 10 members and we all decided that Squad would be our next game. We are all having problems with lag, FPS drops and atm the game is almost unplayable for all of us. My specs are:

 

i5 2500 @4.3ghz

GTX 960 2gb

12 gb Ram

win 10 64 bit

 

I get 25-30 FPS with horrible lag and FPS spikes.

 

Also, the visibility on the maps is very poor even though its set to epic. We understand its an ALPHA but then the devs must understand that the 40$ pricetag is overpriced if this is going to be an excuse for the current problems.

I can see that a lot of people are having the same issues. If there are workarounds or  temp fixes it should be posted on the forums since i can see people starting to hate the game because of the lag

Share this post


Link to post
Share on other sites

I think it's safe to say that a number of people have used it and it fixed the problem and their computer isn't on fire.

 

Obviously I'm not concerned with spontaneous combustion, rather subtler things a random closed-source program from the internet could do. Things like stealing personal data, logging keystrokes, creating a backdoor for any other number of programs to exploit... I'll wait for a proper fix.

Share this post


Link to post
Share on other sites

Obviously I'm not concerned with spontaneous combustion, rather subtler things a random closed-source program from the internet could do. Things like stealing personal data, logging keystrokes, creating a backdoor for any other number of programs to exploit... I'll wait for a proper fix.

Lol how very paranoid of you. I'm sure a Google search would give you a number of reviews from people who have used it and not had their identity sold to African royalty!

Share this post


Link to post
Share on other sites

Obviously I'm not concerned with spontaneous combustion, rather subtler things a random closed-source program from the internet could do. Things like stealing personal data, logging keystrokes, creating a backdoor for any other number of programs to exploit... I'll wait for a proper fix.

 

With some knowledge/research you would know that these guys of IOBit are great dudes that do a great job for ages.

The IOBit one is the same like Razor Game Booster, but it detects more unnecessary programs.

 

I never needed a game booster, but if it fixes Squad for me and is safe, why not?!

Share this post


Link to post
Share on other sites

I've tried Razer Cortex Booster, it gave me a nice FPS boost but didn't resolve the lags issue.

 

I've also tried to set the 3d settings to "performance" instead of "quality" in nvidia control panel as someone said somewhere else but didn't make it either for me  :unsure:

Share this post


Link to post
Share on other sites

Obviously I'm not concerned with spontaneous combustion, rather subtler things a random closed-source program from the internet could do. Things like stealing personal data, logging keystrokes, creating a backdoor for any other number of programs to exploit... I'll wait for a proper fix.

 

If youre so worried about your private life, wait for Squad being released on Linux. I'm certainly as conscious as you of that problem and as worried about it as you are, but if you're playing under Windows, dont tell me you wont test it (read all I could about it and looks safe) if it can fix all your problems just because youre worried about backdoors ;)

 

With some knowledge/research you would know that these guys of IOBit are great dudes that do a great job for ages.

The IOBit one is the same like Razor Game Booster, but it detects more unnecessary programs.

 

I never needed a game booster, but if it fixes Squad for me and is safe, why not?!

 

+1

Share this post


Link to post
Share on other sites

WHAT THE FUCK?

 

Yesterday the IOBIt Game Booster saved my evening on different servers and I fell in love with it.

Now, finally weekend, and I get the same lags again!! (Yes, Booster is running)

Anyone got an idea why the fuck that's happening to me?  :angry:

Share this post


Link to post
Share on other sites

WHAT THE FUCK?

 

Yesterday the IOBIt Game Booster saved my evening on different servers and I fell in love with it.

Now, finally weekend, and I get the same lags again!! (Yes, Booster is running)

Anyone got an idea why the fuck that's happening to me?  :angry:

It probably heavily depends on map, player count and server performance.

​Even after having a completely optimized system myself I tend to have these lagspikes on certain maps more than on others (fools road a little more than logar f.e.) and it seems to be related to loading (the task before rendering can start before you are getting new objects rendered). It seems that turning around makes more stuff load into the cache and therefore cause that lag. Just my feeling about this whole process.

Share this post


Link to post
Share on other sites

So I went from GTX 770 to GTX 970, from win 8.1 to 10 (fresh instal) and I have everything on max with no lags at all.


So I went from GTX 770 to GTX 970, from win 8.1 to 10 (fresh instal) and I have everything on max with no lags at all.

Share this post


Link to post
Share on other sites

Yep, just joined another busy server and got no problem at all. Weird as fuck, it's defo up the devs now.

Share this post


Link to post
Share on other sites

I ran the game booster linked as the solution and it improved the situation for me somewhat. I am able to run the game on max settings and it runs pretty great most of the time with the occasional pause. The framerate is good but it does stutter still every now and again. But, it's playable :)

Share this post


Link to post
Share on other sites

Sign me up to this issue too.

 

Mates are having a blast on this, hope Admins can get a fix sorted.

 

i5 4690k @ 4.4GHz

AMD R9 270X

8GB RAM

Windows 8.1 64bit

 

I've tried:

 

Four different sets of drivers

Installed 'Game Booster',

Disabled 'Radio Filtering' in game

Set power performance to maximum (though I'm desktop anyway).

Re-installed the game to SSD

Vsync off/on

 

I can actually get the game to run at 120+ FPS on lowest but the micro stuttering makes it unplayable for me.

Share this post


Link to post
Share on other sites

Was hoping the patch out today would fix it for me; didn't. The game runs fine when I spawn but after moving away, or upon firing a weapon, etc., the framerate drops down to mid 20s. Hoping to see it fixed, it's a shame.

Share this post


Link to post
Share on other sites

Was hoping the patch out today would fix it for me; didn't. The game runs fine when I spawn but after moving away, or upon firing a weapon, etc., the framerate drops down to mid 20s. Hoping to see it fixed, it's a shame.

I fixed it by disabling one of my GPUs (I'm on a Crossfire configuration). The game was using VRAM as if I had 4 GB instead of 2 GB, and when I disabled one of them it went to normal.

There's also the option of changing the r.TextureStreaming option in DefaultEngine.ini, which helped with reducing usage as well, but it makes your game look like arse.

 

EDIT: Yes, I quoted myself, just so anyone interested  can reference what issue I was having. Hopefully it helps someone.

Share this post


Link to post
Share on other sites

Was hoping the patch out today would fix it for me; didn't. The game runs fine when I spawn but after moving away, or upon firing a weapon, etc., the framerate drops down to mid 20s. Hoping to see it fixed, it's a shame.

 

There's a particularly nasty sound bug related to AMD hardware the developers are currently working on. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×