Jump to content
Kdotman

Unofficial Crossfire Fix for Squad?

Recommended Posts

As many  of you may be aware there is now an unofficial SLI fix for Squad posted by UKEF-JD , which has resolved the lack of SLI support on unreal engine 4 temporally . Unfortunately for me I am AMD TILL I DIE. There is a post by sn1p3, where he suggest using the AFR friendly mode to solve your crossfire woes how ever using AFR mode results in texture flickering to an unplayable level. 

 

I attempted using the Batman Arkam Origins profile like suggested on the SLI post however this just killed in game fps to below 10 , honestly didn't think it would work, but worth a try :P !

 

What I'm hopping for is an  AMD Fan on this site who has the time and knowledge to find out if there is a similar Fix for us AMD users, possibly utilizing one of the predefined profiles in Radeon Settings? 

 

Lets not let these Nvidea Geeks steel the show. Any support that leads to an Crossfire fix would be appreciated.

 

Lets Show these Nvidea geeks what were made of!!!

Share this post


Link to post
Share on other sites

Hi friend wow,

                        Yeah this issue, longtime issue, started in 2013 when AMD promised its consumers it will solve it for good. 

 

Setting AMD crossfire mode to Optomize 1x1 ratio can help but still get screen flicker here and there

 

Setting it to Use AMD pre-defined profile and using the oblivion profile had more results then any you may need to rename the tesv profile to oblivion to do this 

 

Setting  waitbusyrendering can help  setting vsync  can as well 

 

Try these out and let me know :-)

 

 

​Edit sorry what OS are you ruining by chance to please if you don't mind me asking 

Share this post


Link to post
Share on other sites

Hi friend wow,

                        Yeah this issue, longtime issue, started in 2013 when AMD promised its consumers it will solve it for good. 

 

Setting AMD crossfire mode to Optomize 1x1 ratio can help but still get screen flicker here and there

 

Setting it to Use AMD pre-defined profile and using the oblivion profile had more results then any you may need to rename the tesv profile to oblivion to do this 

 

Setting  waitbusyrendering can help  setting vsync  can as well 

 

Try these out and let me know :-)

 

 

​Edit sorry what OS are you ruining by chance to please if you don't mind me asking 

 

Thanks for a hasty response. Im running windows 10 Home 64 bit

Share this post


Link to post
Share on other sites

Thanks for a hasty response. Im running windows 10 Home 64 bit

Ok yeah win10 , give them settings ago see what results are , we can take things from there , set you expectations low that way any increase will be positive :-)

 

 

Cool thing about win 10 is you can mix GPU manufacturers up , have AMD GPU and Nivd, why you ask..why not :-)

Share this post


Link to post
Share on other sites

Cool had no idea. Set the profile to 1x1 but saw an fps drop. The game was utilizing both GPU's how ever I was only achieving around 25 fps, so no gain!. Couldn't find a profile for Oblivion in the pre defined profiles, Could it be listed under another name? I am running the latest Radeon Software Update aswell.

Share this post


Link to post
Share on other sites

Cool had no idea. Set the profile to 1x1 but saw an fps drop. The game was utilizing both GPU's how ever I was only achieving around 25 fps, so no gain!. Couldn't find a profile for Oblivion in the pre defined profiles, Could it be listed under another name? I am running the latest Radeon Software Update aswell.

 

 

well you could always try the assassins  Creed profile , i had mixed results with this though

 

Edit: your adding the settings right aye :-) 3D application/ setting/ add a setting for/

Share this post


Link to post
Share on other sites

Found the TESV.exe profile under skyrim. Works like a charm thanks, getting a stable 30<40 fps now, thanks for you help Harron21.

Share this post


Link to post
Share on other sites

Weird bug has come about where the Skyrim TESV.exe profile, now only utilizes one GPU! If i set the AMD CrossFire mode to AFR friendly or another predefined profile it will use both GPU's but with the obvious flickering or low fps! Whilst it was working earlier this afternoon, for some reason, it isn't any more and no longer using my second GPU whilst playing Squad using that profile... Very Odd. I have changed nothing just turned off my PC for a few hours.

Share this post


Link to post
Share on other sites

well you could always try the assassins  Creed profile , i had mixed results with this though

 

Edit: your adding the settings right aye :-) 3D application/ setting/ add a setting for/

 

No idea why but the TESV.exe profile stopped working. Tried the assassins creed profile but that unfortunately lowered the fps.

Share this post


Link to post
Share on other sites
Guest Tophu

I noticed the game sometimes switches itself to full-screen windowed mode even if you have full screen set as an option and crossfire stops working.

Share this post


Link to post
Share on other sites

I have 2 Radeon HD 5850 in CrossfireX forced enabled CrossfireX in Radeon settings, standard profile. I don't have any issues.

But I have compared my FPS with CrossfireX on or off.

 

(Old PC I know, Get a new i Q4 this year

Share this post


Link to post
Share on other sites

I did the above mod and both GPU's were active but I had terrible microstutter even while running at 80 FPS....

 

After two days of pulling my hair out, I uninstallled the sweetfx mod and ran Squad in fullscreen and now it runs perfect.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×