Jump to content
sgtcaboose

What FPS do you get playing Squad with your rig?

Recommended Posts

FPS: 55-70
CPU: Intel® Corei7-4790k
GPU: NVidia GEforceGTX980
RAM: 16GB
RES: 2560x1600 (on a 4k monitor)
SETTINGS:All on High

 

Runs very good for me.

Share this post


Link to post
Share on other sites

FPS: 60-90 (60 Players)

CPU: i7-2600k @4,5GHz

GPU: EVGA GTX970 SSC+

RAM: 8096MB DDR3-1600

Res: 1920x1080 @144Hz

Settings: Epic, AA off, shadows medium @2048, SweetFX SMAA

Share this post


Link to post
Share on other sites

FPS: 60 on Afgan maps, down to around 40 on Fools Road and Op First Light

CPU: Intel i5 3750k @ 4,2 Ghz

GPU: AMD Radeon 7970Ghz Edition

RAM: 2x4GB DDR3 800 mhz

Res: Full HD

Settings: Full HD, FXAA High, Shadows High, rest is Epic

Share this post


Link to post
Share on other sites

FPS: 40-50
CPU: i7-3720QM
GPU: 680M 4gb
RAM: 16gb
Res: 2560x1080
Settings:  Vsync off / AA- off / MSAA None / View High / Shadow Low/ Shadow Q Off / 512 / Post Pro Low / Texture High / Effect High /

Share this post


Link to post
Share on other sites

SSD

4790k @4.6GHz

GTX 980Ti @1266MHz ( could OC up to 1450Mhz)

 

with <60 players on the servers : steady 60 fpsd with epic setting ( except FXAA and MSAA are turned off) and scale resoltion is set to 120%

 

CPU load < 50%

GPU load between 35-85%

 

Adaptative Vsync on / 1080p

Share this post


Link to post
Share on other sites

i5-6600K

MSI GTX 970

16 GB G-Skill DDR4 RAM

Gigabyte Z170X UD5 MOBO

EVGA 750W PSU

Samsung 840/850 EVO SSD

Share this post


Link to post
Share on other sites

fps: variable between 45-60

 

CPU: i5-6600K quad core

SSD 250Gb

Vid Card: GeForce GTX680

RAM: 16GB G-Skill DDR4

Res: 2560x1440 (refresh rate 144Hz) (settings = epic) (G-sync on)

O/S: Win 10 Pro

Share this post


Link to post
Share on other sites

fps: variable between 45-60

 

CPU: i5-6600K quad core

SSD 250Gb

Vid Card: GeForce GTX680

RAM: 16GB G-Skill DDR4

Res: 2560x1440 (refresh rate 144Hz) (settings = epic) (G-sync on)

O/S: Win 10 Pro

 

Nope! No 45-60 with a GTX680 on EPIC with 2560x1440 !

Share this post


Link to post
Share on other sites

i5-6600K

MSI GTX 970

16 GB G-Skill DDR4 RAM

Gigabyte Z170X UD5 MOBO

EVGA 750W PSU

Samsung 840/850 EVO SSD

Aha man, the specs I was looking for and you forget to post your FPS..

Share this post


Link to post
Share on other sites
FPS: 50-100CPU: i5 4670kGPU: GTX 980OCRAM: 16GB 1600MhzRes: 120hz 1920x1080Settings: HIGH (Shadows off completely) 

I plan on 1 more GTX 980 and a 2400Mhz Kit of ram 16GB in near future. Is the overclocked ram speeds really worth it?

Share this post


Link to post
Share on other sites

Aha man, the specs I was looking for and you forget to post your FPS..

The latest patch made a big difference with fps on populated servers for me so it would be nice for op to do this all again with a 3.8 thread.

Share this post


Link to post
Share on other sites

FPS:30-50
CPU
: AMD FX 8350 4.0Ghz
GPU
: Gigabyte 970 4GB
RAM
: HYPRE 16GB 1800
Res: 1920 * 1080
Settings: Epic


ive played many more games that use a lot more resouces and i get better results than this... BUT bearing in mind i do remind my self that this is still in alpha ! KEEP UP THE GOOD WORK

 

Share this post


Link to post
Share on other sites

Game version 3.8

FPS: 40-60 (Vsync ON)

CPU: i5 4440 3.10 GHz

GPU: Asus GTX 780 3GB

RAM: 8GB Kingston HyperBlu

Resolution: 1920x1080

Settings: Epic (with MSAA off)

On 72 slot servers it usually drops to about 40 FPS in certain situations, some maps have better performance some a bit worse but everything is always playable

Share this post


Link to post
Share on other sites

FPS: 20-30 (avg-25) (72-man servers)

FPS: 25-35 (avg 30) (72 man servers) since the optimization update (Jan-2016)

FPS: 30-40 (avg 35) (72-man servers) since the 4.0 update (Feb 2016)

FPS 20-42 (AVG 33) (72-man servers) since the 5.0 update (March 2016) [Wilder/Heavier FPS-Drops, but higher FPS in general]
 

CPU: AMD FX 8350 OC*-4.5Ghz
GPU
: R9-280X OC*
RAM
: 8GB DDR3
Res: 1600 * 900
Settings: Low (Settings matter little in-game)

 

Edited by Ingram

Share this post


Link to post
Share on other sites

FPS: 50-60 (cap at 60)
CPU:
i5 3570k @3.4ghz (stock)
GPU:
EVGA 970 SSC 4gb (overclocked slightly)
RAM: 
8GB of i-dont-know RAM
Res: 
1920x1080

Settings: Epic preset

Running on a SSD if that matters.

Share this post


Link to post
Share on other sites

i7 2600K 3,4Ghz

8GB 1600 DDR3

GTX 770 2GB OC 

 

changed nvidia preference settings to performance( force msaa is also an option)

digital vibrance +70

sweetfx mod for more crispy detaill https://sfx.thelazy.net/games/preset/4918/

ini mods see other topics (not sure it still has effect since latest patch)

ingame settings see below:

 

i think if i upgrade the gpu with more vram , i will have better results

 

 

e3fc2cce_l.jpeg

Share this post


Link to post
Share on other sites

Squad 3.8.4

 

FPS: 75-144 (cap at 144) empty server, 40-85 populated server
CPU: i7 3770k @3.9ghz (stock)
GPU: 
Gigabyte 780ti 3gb (factory overclocked)
RAM:
16Gb
Res: 1920x1080

Settings: Epic, AA off, MSAA None, Shadows Medium, Shadow Qlty Med, Shadow Res 1024, Post Process High, VRAM 3Gb

 

In Nvidia control panel I have set  Anisotropic 4x, FXAA off, AA 32x CSAA

Share this post


Link to post
Share on other sites

FPS: 35-45

CPU: i7 4790K @ 4 GHz

GPU: MSI R9 390

RAM: 16GB DDR3L 1600MHz

Res: 1080p

Settings: Epic

Share this post


Link to post
Share on other sites
Guest Ubuntufoo

FPS: 30-40
CPU: Phenom II x4 955
GPU: Radeon R9 270
RAM: 8GB DDR3 1600
Res: 1920x1080

Settings: Low

 

 

I run Win7 but I'm about to install my first SSD and Win10, which I hear is boost to older multi-core CPU's. I've tried every tweak I can get my hands on to boost FPS. I know I need to upgrade some things here, not sure where to start. Any recommendations?

Share this post


Link to post
Share on other sites

http://forums.joinsquad.com/topic/9335-gameserver-fps/

 

Read and you will understand that it's not so much about your rig. It's the servers that are not multithreaded which makes your fps drop.

Sorry but you are making assumptions and you don't really know what causes the fps drops on populated servers. Devs have said it's down to how the animations are played for everyone and are working to fix it. I believe them right now and wait to see more info on your other thread.

Please keep this thread free just for people to compare specs and those who might be able to tweak to get some more fps in the current build.

Share this post


Link to post
Share on other sites

FPS: 35-45 when 40 and more on server. 50-80 when 40 and less...
CPU: i3-4360 3.70GHz
GPU: GTX960 4Go
RAM: 16GB 1600MHz DDR 3 RAM (2x8GB) GSKILL
Res: 1920x1080
Settings: Epic (or low, doesn't change anything)

Share this post


Link to post
Share on other sites

the fps issue is defiantly due to the player models being rendered even when you don't see them.

 

was a in server with a hacker he caused the other team to stop repawning.

 

this server was around 60+, my gpu usage usually is 10-15 percent when im in a 60man+

 

the other team stopped repawning, instantly my gpu usage went from 15ish to 80-90%. my fps went from 30 to 80.

 

this went on for about 3 minutes as a walked around.

 

as soon as he left other team spawned back in and my gpu usage went back to 10-15 percent.

 

this fps issue has turned into a Salem witch hunt for amd and ati.

 

this has distracted the community from finding out the real issue being the player models.

 

I just wish I knew the cvars to lower the quality or how there rendered. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×