Jump to content
sgtcaboose

What FPS do you get playing Squad with your rig?

Recommended Posts

[Moved topic to General Hardware/Software Tech Support]

 

FPS: 20-30

CPU: i5 750 @ 3.2Ghz

GPU: EVGA GTX 980 SC

RAM: 16 GB

RES: 1920x1080

Share this post


Link to post
Share on other sites

[Moved topic to General Hardware/Software Tech Support]

 

FPS: 20-30

CPU: i5 750 @ 3.2Ghz

GPU: EVGA GTX 980 SC

RAM: 16 GB

RES: 1920x1080

your CPU is bottlenecking your GPU :huh:

 

Share this post


Link to post
Share on other sites

FPS: 50-60

CPU: I7 3770K @3,5 GHZ

GPU: Windforce GTX970

RAM: 16 GB

RES: 1920x1080

Setting: Epic

Share this post


Link to post
Share on other sites

FPS: 30FPS(but some big Lags)
CPU: Phenom II X4 965 (Overclocket to ~3.8ghz)
GPU: Radeon HD 7800 Series 2GB
RAM: 8GB DDR @1600
Res: 1080p HD
Settings: most Epic some Medium

 

Setings dont really care FPS.

in SP i got very stable 40FPS each Map

 

Edit: new Version Alpha 3

Update: since Alpha 3.5 lags/stuttering is better but still happen.

Share this post


Link to post
Share on other sites

FPS:40-90
CPU:i7 920 DO step. 2.6 ghz, OC to 4ghz.  asus p6t se mobo
GPU:evga 650 ti boost sc, 2 gb 192-bit ddr5
RAM: 12 gb 1333mhz oc to 1554.
Res: 1920x1080
Settings:high, fxaa, 8x af, shadows on medium.  Also use some of Sm00th's ini tweaks.

 

7 year old pc, insert smart buyer meme here.

Share this post


Link to post
Share on other sites

I've gone through the posts to date and came up with the below data. So far it looks like:

  • CPU: the most common bottleneck
  • GPU: require a GTX 960 / R9 380 or better to achieve near 60fps
  • RAM: little bottlenecking, even 8GB @ 1600MHz achieves 60fps
Far from an exact science, but starting to get a feel for it.

Wn9qGe7.png....TbI6qz7.png....USSwyzz.png

Share this post


Link to post
Share on other sites

FPS: 35-60 (avg 55+) Dips occur as the server gets more players and more sounds are going off.

CPU: Intel i7 4930K Hexacore (OC'd to 4.3 GHz)

GPU: GTX 980TI

RAM: 16GB DDR3 @2400

Res: 1080p HD

Settings: All Epic (no tweaks)

Share this post


Link to post
Share on other sites

FPS:40-90

CPU:i7 920 DO step. 2.6 ghz, OC to 4ghz.  asus p6t se mobo

GPU:evga 650 ti boost sc, 2 gb 192-bit ddr5

RAM: 12 gb 1333mhz oc to 1554.

Res: 1920x1080

Settings:high, fxaa, 8x af, shadows on medium.  Also use some of Sm00th's ini tweaks.

 

9 year old pc, insert smart buyer meme here.

 

9 years seems a bit too much for this, doesn't it?

Share this post


Link to post
Share on other sites

9 years seems a bit too much for this, doesn't it?

yea, my bad, it's more like 7 years.  I bought it when it first released. Just looked it up and it says it was released in 2008.  

Time sure flies though.

Share this post


Link to post
Share on other sites

Eeey moderator, I don't believe you :P  Are you sure you don't go below 60fps? 

 

Ok you have a better cpu then me but in 3440x1440... Mmmh no.

 

My system: [email protected] EVGA 980Ti Sc+ ++ @ 1440 and I will not have 60 fps all the time.

 

Haha - I did pay £3.6K for my rig..... I would expect that sort of speed from it...

 

I will admit to a little drop on the 80man server, dropped to 52fps I think at one point, but I'm blaming server lag for that...

Share this post


Link to post
Share on other sites

FPS:   Min 20Fps max 35 Fps (50 Players)

CPU:  AMD FX 8350

GPU:  GTX 970 4GB

RAM:  16GB    1600

RES:   1920x1080

Same exact specs and fps EXCEPT I have GTX 980ti. I am getting 120 fps on a server by myself but players seem to bog down the cpu.

Share this post


Link to post
Share on other sites

With the specs of these rigs posted there should be none if any fall in fps based on how many players are on the server.

Sounds more like a netcode issue to me than anything else with too many client side calculations causing the drop in fps.

But i am no developer so I don't know.  :lol:

Share this post


Link to post
Share on other sites

FPS: 35-60 (avg 55+) Dips occur as the server gets more players and more sounds are going off.

CPU: Intel i7 4930K Hexacore (OC'd to 4.3 GHz)

GPU: GTX 980TI

RAM: 16GB DDR3 @2400

Res: 1080p HD

Settings: All Epic (no tweaks)

That's odd as I get higher fps with 980ti and 4790k at 4.7GHz, 8GB ram.

Share this post


Link to post
Share on other sites

That's odd as I get higher fps with 980ti and 4790k at 4.7GHz, 8GB ram.

Not odd at all as Squad is CPU limited and prefers Intel processors at higher clock speeds. At least in Alpha v2.1.

Share this post


Link to post
Share on other sites

Squad is not CPU limited!!! But server hardware limited !

My CPU never goes above 55%.

Only poor server performance reduced your FPS

Share this post


Link to post
Share on other sites

Poor engine/game code limiting your CPU to only 55% usage can still be considered being "CPU limited". More so than "unoptimized".

Share this post


Link to post
Share on other sites

I've gone through the posts to date and came up with the below data. So far it looks like:

  • CPU: the most common bottleneck
  • GPU: require a GTX 960 / R9 380 or better to achieve near 60fps
  • RAM: little bottlenecking, even 8GB @ 1600MHz achieves 60fps
Far from an exact science, but starting to get a feel for it.

 

 

Thank you a lot for your charts!

 

Now I know exactly why I can't play this game, with my actual, "ancient" rig:

 

FPS: 15-20 solo - 5-10 MP

CPU: Intel i5 650

GPU: GTX 660TI

RAM: 4GB

Res: 1280x1024 (4:3 CRT)

Settings: whatever, no difference at all (lowering shadows has a placebo effect for me ;)

 

A massive upgrade (new CPU/Mobo/more Ram) is needed :(

Share this post


Link to post
Share on other sites

FPS25-40
CPU: FX-9590
GPU: GTX 770
RAM: 8GB @ 2400
Res: 1080p

Settings: All Epic

 

New motherboard (Z79-P) and CPU (i5-4690k) and another 8 gigabytes of RAM coming in soon, hopefully that'll bump it up a bit.

 

 

Share this post


Link to post
Share on other sites

FPS: Low 74 (fools road forest), Avg 100-110
CPU: i7-6700k @ 4Ghz stock
GPU: EVGA 980 TI Hybrid 
RAM: 32GB @ 3000
Res: 1080p

Settings: Highest possible 

 

*Installed on a SSD

Share this post


Link to post
Share on other sites

FPS:25-45

CPU: I7 3630QM

GPU: GT650m vram 4gb

RAM: 8gb 1333MHz

Res: 1600x900 - 90% res

Settings: Low(except View Distance High and textures high)

This performance is related to alpha 3 build

Share this post


Link to post
Share on other sites

Squa V3.1

 

i7 4790k @ 4.6GHz

GTX 970 @1350MHz

SSD

16 Gbs RAM

 

All Epic/Shadows high:2048/120%/MSAAx8/no AA

 

FPS: 22( fools road) to 60( Vsync ON)

Share this post


Link to post
Share on other sites

 

FPS: Low 74 (fools road forest), Avg 100-110

CPU: i7-6700k @ 4Ghz stock

GPU: EVGA 980 TI Hybrid 

RAM: 32GB @ 3000

Res: 1080p

Settings: Highest possible 

 

*Installed on a SSD

 

 

Woow 74 FPS is your lowest on fool's roads :o . i'm getting the Zotac GTX 980TI AMP Extrem in 2 weeks, I didn't thought that getting 100+FPS on squad full EPIC could be possible.

 

Will I get similar performance ?

 

4790k @ 4.6 GHz

GTX 970

SSD

16 RAM @ 1600MHz

1080p

 

whats your VRAM usage ?

Share this post


Link to post
Share on other sites

 

FPS: Low 74 (fools road forest), Avg 100-110

CPU: i7-6700k @ 4Ghz stock

GPU: EVGA 980 TI Hybrid 

RAM: 32GB @ 3000

Res: 1080p

Settings: Highest possible 

 

*Installed on a SSD

 

This only can happen in a empty server or a local game.

With 100 players it will hover around 40-50 fps with the game on epic and post processing/shadows on max.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×