Jump to content
sgtcaboose

What FPS do you get playing Squad with your rig?

Recommended Posts

FPS: 46-60 (always 72 slot server)
CPU: Intel i5 2500k 3,3 GHz
GPU: ASUS GTX 970 OC Edition
RAM: Corsair 16 GB DDR3 1333 MHz
Res: FHD
settings: epic, shadows on mid

I am confused, the drop to ~ 46 FPS is always on a full 72 server. When I'm changing the settings to low, I still have ~46 fps. Any Ideas why?

Share this post


Link to post
Share on other sites

FPS: 28-50
CPU: FX 8350 overclocked to 4700
GPU: R9 Fury X
RAM: 16GB
RES: 2560 x 1440

SSD
settings: mix of med and ultra

Share this post


Link to post
Share on other sites

i5 3570k @ 4,4Ghz
Asus P8Z77-I Deluxe
Corsair low profile 2x8GB 1600mhz
MSI gtx 670 power edition
LG 25UM57-P 2560x1080 Ultrawide screen

 

Low-Med settings 40-60
 

Share this post


Link to post
Share on other sites

FPS:45 ~ 100 (Depends what map im playing)
CPU: i7 3770
GPU: GTX 960 4GB SSC EVGA
RAM: 8gb 1600mhz
Res: 1920 x 1080
Settings: Medium and all blur + filters disabled

Share this post


Link to post
Share on other sites

FPS: 40-50
CPU: Intel® Core i7-4770 CPU @ 3.40GHz (8 CPUs), ~3.4GHz
GPU: AMD Radeon R9 390 Series
RAM: 16384MB RAM
Res: 1900 X 1200
Settings: everything low but the FOV is set to 100

 

I am extremely dissapointed as I believe my computer should be getting better performance than this.  The i7, video card, and the 16 gig of ram should allow for much better frames than 40-50.  This is with low settings as well.  I have turned on almost no setting.  

 

One comment I should make is that I always play on a 70+ man server.  My frame rate is obviously better when less people are on the server but the gameplay is clearly superior on larger servers.  Also considering I have sacrificed the visual settings of the game (game looks ugly as sin with nothing turned on) I would expect better frames than this.  

 

Also should mention it takes forever to load this game up.

Share this post


Link to post
Share on other sites

Can't you overclock your CPU ? You will have almost 10FPS gain.

 

Is there anybody here with a crossfire of AMD cards ? If yes, is the crossfire only works in the FireRange ? Because for me it's the case... When i play on real servers, only card is working.

Share this post


Link to post
Share on other sites

I am extremely dissapointed as I believe my computer should be getting better performance than this.  The i7, video card, and the 16 gig of ram should allow for much better frames than 40-50.  This is with low settings as well.  I have turned on almost no setting.

 

Patience. Your not alone with that level of performance. At least you have playable frame rates just like myself. The devs are hard at work updating the animations which they believe is the major factor leading to poor fps. If you run Afterburner (think the latest version is compatible with EAC) on an empty server you will see your GPU used near 100% and have good fps. When on a full server your GPU is underutilized maybe at around 60%. This does point towards an in game function causing the lack of performance. Let's give the devs a chance to fix things and help them with feedback.

Share this post


Link to post
Share on other sites

FPS: 30-40 (50+server)
CPU: Intel® Core™ i5 750 @2.70
GPU: gtx 750 ti stomx oc 2gb
RAM: 6gb 1333
Res: 1440x900
Settings: 1440x900 150% res scale + all off

 

i will oc the cpu @ 3.70\80 with the CM 212 Evo and upgrade to 8gb ram 1600. im wondering if dx12 will help me too, and im confident that devs will try to put hands on servers because i noticed ( and as i saw in few topics im not the only one) that on a +45\50 gameplay fps will drop. sorry my eng

Share this post


Link to post
Share on other sites

FPS: 60+
CPU
: FX-6300
GPU
:R9 280X 3GB OC
RAM: 24GB DDR3
Res:1920x1080
Settings:Low

 

Everytime, literally, when the enemy shows up on my screen: FPS: 3

Share this post


Link to post
Share on other sites

FPS: 40-60, Fluctuates

CPU: i7 4790k 4.0 GHz

GPU: 2x GTX 760's

RAM: 12 GB Ram

Res: 1080p

Settings: Med-High

Share this post


Link to post
Share on other sites
FPS:  50-70CPU:  i5 3570k not OCedGPU: GTX 970RAM: 32 GBRes: 1920x1080Settings: Most things low or off. 

Share this post


Link to post
Share on other sites
FPS: 50 to 100 (kinda map/sv/situation depending or 50-75 or 65-85 or 80-100)CPU: i7-5930k (4.3, wcd)GPU: 2x GTX 980 Ti (clocked to 1500, both wc'd)RAM: 16GB 2666MHzRes: 1080pSettings: Epic (setting, scrns from firing range: http://i.imgur.com/47tcThT.jpg http://i.imgur.com/GbhXABc.jpg)

happend to play a 80-90 match on +60 ppl server and have 50ish on next map..

 

Share this post


Link to post
Share on other sites

Patience. Your not alone with that level of performance. At least you have playable frame rates just like myself. The devs are hard at work updating the animations which they believe is the major factor leading to poor fps. If you run Afterburner (think the latest version is compatible with EAC) on an empty server you will see your GPU used near 100% and have good fps. When on a full server your GPU is underutilized maybe at around 60%. This does point towards an in game function causing the lack of performance. Let's give the devs a chance to fix things and help them with feedback.

 

Sounds good to me ;)

Share this post


Link to post
Share on other sites

Finally made my new rig and its totally shredding!

 

i3-6100 (skylake) (single monitor, 1080p).

GTX 950 SC

4gig DDR4 ram

120g sandisk SSD (only for games)

 

40-60 FPS on a mixture of mostly medium and some high settings.  No ini tweaks (thank god).  135% res scaling (I can push it to 150% but don't really notice any graphical imporovement beyond 130-5%).

 

No lag, no drop below 35FPS at most intense moments including smoke.  

 

65-72 player servers!

 

So happy!!!!!

 

FYI, in case anyone else is thinking of upgrading, the whole set up cost about $450 dollars (cpu @$130, gpu @$150, ram @$20, psu (430W evga)@$50, mobo @ $55) and SSD @$45.  I used an old case I have used for over 10 years bc, why not? ;)  Prices are US and bought on Newegg.

 

Good luck to you all!

Share this post


Link to post
Share on other sites

FPS .. 55 - 65

CPU .. i5 6600 3.3 turbo 3.9

GPU .. GTX 950

RAM .. 16GB DDR4 2133MHz

RES .. 1280 x 720

SETTINGS .. Epic

Share this post


Link to post
Share on other sites

FPS: 37-80 (map dependent)
CPU: I5 4460
GPU: GTX 970 (msi)
RAM: 8GB
RES: 1080p
settings: mix of medium and high, shadows on medium. Resolution scaling @ 140%

Share this post


Link to post
Share on other sites
Guest HabitatBabs

FPS: 0-30
CPU: AMD FX-8350
GPU: Asus Radeon R9 280X
RAM: G.SKILL Ripjaws X 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Memory Model F3-12800CL9D-8GBXL
Res: 1920 X 1080
Settings: Graphics settings are all off or set to low. I've also followed all optimization guides with the only improvement being during VoIP chat there is no longer a frame-rate drop but my current FPS is unplayable as it is. 

Share this post


Link to post
Share on other sites
Guest Guest

How the f**** you get 0 to 30 fps?
My rig: FX 6300, R7 260x 2gb and 8GB RAM

I can get 60fps on a low populated server (around 20 each side) and 30fps on a full 75

I play on 768p and most of my settings are on EPIC or MED, only AA is off. 

Share this post


Link to post
Share on other sites
FPS: 40-65 (map dependent) (140 on Jensen's Range) 

 

CPU: i5

 

GPU: EVGA GTX 960 SSC

 

RAM: 12GB

 

RES: 1360x758 (using a 32" TV as a temporary monitor, that res is the highest the game will allow for me.)

 

settings: Max Settings, Shadows on Medium (for FPS Boost), Res scale @120%, 2gb for VRAM. All of the new options are off with the exception of Eye Evaluation thing being 'On'. 

Share this post


Link to post
Share on other sites

FPS 30+

 

CPU i7 4510u 2.6ghz

GPU Nvidia GT 840m

8gb ddr3

1024x768 -High

1366x768 - Med

 

100% res scale

Share this post


Link to post
Share on other sites

Updated specs : 

FPS: 40-60 FPSCPU: i7-4790k 4.7 GHzGPU: 980 TIRAM: 12 GBRes: 1920x1080Settings: 120% Res, always play on 72 man servers, full. Ultra settings

Very disappointed. Even with the highest tier consumer GPU and CPU, this game still fails to run well. Even OC'd my CPU, and still don't get the frames I SHOULD be getting. This game REALLY needs optimization, and quick. I should be maxing the settings and easily be over 80 frames.

Share this post


Link to post
Share on other sites

Updated specs :

FPS: 40-60 FPSCPU: i7-4790k 4.7 GHzGPU: 980 TIRAM: 12 GBRes: 1920x1080Settings: 120% Res, always play on 72 man servers, full. Ultra settings
Very disappointed. Even with the highest tier consumer GPU and CPU, this game still fails to run well. Even OC'd my CPU, and still don't get the frames I SHOULD be getting. This game REALLY needs optimization, and quick. I should be maxing the settings and easily be over 80 frames.
This. I know it's Alpha and all but people will start walking if performance remains bad.

Share this post


Link to post
Share on other sites

One of the downsides of a high ish priced Alpha, people will naturally expect more sooner. IMO performance should be the very first thing to be dialled in.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×