smo0ths

Performance tweaks for extra FPS.

525 posts in this topic

Noticed the map as soon as I spawn it takes a while to load and that the texture of the uniform right after spawn does take a little bit to load as well.

Share this post


Link to post
Share on other sites

Amazing. Tweaked it a bit and now on my AMD system I was averaging 30-55fps on all Epic settings. Or lower.

.

Now I can get as high as 100+ with tweaked settings, incl. shadows on epic, textures on epic WHILE recording in 60fps 1920x1080p in SP.

 

I managed to hit 190+ fps even on low.

 

Crazy.

Share this post


Link to post
Share on other sites

Just tried it. Oddly enough it made absolutely no difference in FPS on my system. My GPU was 99% utilized before and after.

 

i5-2500k @4.3GHz

GTX 770

16GB RAM

1680x1050 resolution

In-Game Settings:

View Distance = Epic

AA = Low

Shadows = Low

Post Processing = Low

Textures = Epic

Effects = Epic

AA hard disabled in DefaultEngine.ini

 

Regardless, still a bit thank you to Smooths for putting this together and I'm glad that it has helped others

Share this post


Link to post
Share on other sites

Nice work smooth.. much appreciated..  doing our work for us.   ;)

 

I will see what makes sense to include as default. very cool. 

 

If you want to PM more detailed results.. feel free. 

Share this post


Link to post
Share on other sites

Yea but Problem are not the gfx settings, at least not for users with a gaming PC (like gtx970 range and 2500k up) . Problem is only the Server fps or the CPU, with to much players FPS goes down very hard.

With like 40 Players all fine, 70 Players FPS like 40, even if you have no players close.

Share this post


Link to post
Share on other sites

Amazing. Tweaked it a bit and now on my AMD system I was averaging 30-55fps on all Epic settings. Or lower.

.

Now I can get as high as 100+ with tweaked settings, incl. shadows on epic, textures on epic WHILE recording in 60fps 1920x1080p in SP.

I managed to hit 190+ fps even on low.

Crazy.

I'm guessing that all this is in SP only right. What are your specs?

Share this post


Link to post
Share on other sites

this will affect your fps if you have a weaker system for sure. 

 

it will help. 

 

The larger servers FPS rates it wont affect that very much. minor relief for your system./

Share this post


Link to post
Share on other sites

I'm guessing that all this is in SP only right. What are your specs?

 

I have confirmed this working in SP but I tested also in MP for a minute the server was nearly full 48/50 or something.

Did notice a positive change there too for sure with all players nearby.

 

Of course this is with many bells turned off and tweaked heavily.

My system cpu is FX-9590 @ 4.7 Ghz and gpu R9 280 3GB DC II

Share this post


Link to post
Share on other sites

That's great thanks! One odd thing I've noticed after having a great time playing last night was that my CPU was only 50% utilized, and my RAM and GPU were only 60% utilized. 

Share this post


Link to post
Share on other sites

@gringo85 whoa bro the posts mods! halp :P and np man

 

@Ir0nTaXi no problem at all i'm still working on more tweaks eventually i'll flush them all out

 

If the entire fx particle system could be placed on CPU or GPU or split on both by user that could help a lot.

 

@MDInteractive \m/

Share this post


Link to post
Share on other sites

I just made quick vid on how to change the settings as some people do find this sort of stuff hard to do!!! 

 

 

 

 

thanks smooths

Share this post


Link to post
Share on other sites

I tried it out and noticed a performance improvement (in exchange for much worse visuals), but one or more of those proposed changes makes the game unbearable. 

 

Essentially I see the terrain differently than it really is, height wise. That means that objects are floating in the air, people are in the ground, completely hidden when prone, etc. 

 

Y5Dd65R.jpg

 

Any idea which one of those commands is the culprit?

Share this post


Link to post
Share on other sites

Happened once or multiple times? What I mean by multiple times is after at least one restart.

Share this post


Link to post
Share on other sites

Multiple times, it's always like that, unless I revert back to my old settings. I gather that I am the only one having such terrain issues?

Share this post


Link to post
Share on other sites

Well I wouldn't say that. I do get some texturing lag or delays but nothing like what you got but different systems can present different issues too

Share this post


Link to post
Share on other sites

Multiple times, it's always like that, unless I revert back to my old settings. I gather that I am the only one having such terrain issues?

I had issues where the terrain quality was set to epic but would the level of detail change was taking too long. For example my gun and textures around me would look super low texture and then pop in as epic. I tweaked a few things and will try again

Share this post


Link to post
Share on other sites

Ah, there's no loading of any kind for me. Just low LOD all around me.

 

1tpy6T6k.jpg

 

 

Me ducking into the ground and looking through a hill.

1tpCCJxZ.jpg

Share this post


Link to post
Share on other sites

I had issues where the terrain quality was set to epic but would the level of detail change was taking too long. For example my gun and textures around me would look super low texture and then pop in as epic. I tweaked a few things and will try again

I would expect something like this. But nothing like CC has.

Share this post


Link to post
Share on other sites

Ah, there's no loading of any kind for me. Just low LOD all around me.

1tpy6T6k.jpg

Me ducking into the ground and looking through a hill.

1tpCCJxZ.jpg

Set textures to epic and see if this happens

Share this post


Link to post
Share on other sites

Alright so I did some testing. Apparently changing the texture setting in-game does nothing, unless you set r.TextureStreaming to true. Then it will have a huge impact on what your game looks like. I had mine set on low before trying the tweaks in this thread. That's why my game looked awful after applying them. 

 

So the way I see it, we have three options:

1) r.TextureStreaming = true & texture level on low.

This will result in terrain height problems I illustrated before. Also your map becomes unusable.

 

Squad_2015_10_18_21_52_58_132.jpg

 

 

 

2) r.TextureStreaming = true & texture level medium or higher.

Brings along LOD switching. 

 

2uBbe94.jpg

 

 

 

3) r.TextureStreaming = false (default)

Your textures will be good and forced to whatever level is default regardless of your in-game setting. But unfortunately most of the performance you gained with all these changes will be gone too.

Share this post


Link to post
Share on other sites

I tried it out and noticed a performance improvement (in exchange for much worse visuals), but one or more of those proposed changes makes the game unbearable. 

 

Essentially I see the terrain differently than it really is, height wise. That means that objects are floating in the air, people are in the ground, completely hidden when prone, etc. 

 

Y5Dd65R.jpg

 

Any idea which one of those commands is the culprit?

 

 

I know what is happening.. i dont know which command is affecting it. 

 

Basically what you are seeing is the lower resolution terrain Levels of detail. 

Share this post


Link to post
Share on other sites

Well I wouldn't say that. I do get some texturing lag or delays but nothing like what you got but different systems can present different issues too

how do i get rid of the texture lag?

Edit: the answer was right in front of me. cc's Post #47

Share this post


Link to post
Share on other sites

I know what is happening.. i dont know which command is affecting it.

Basically what you are seeing is the lower resolution terrain Levels of detail.

yes i had the same problem where people are invisible while prone, i would like to know which command to remove to go back to normal.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now