Jump to content
zeep

Starting Squad in full screen mode still leads to black screen / freeze.

Recommended Posts

Starting Squad in full screen mode still leads to a black screen / freeze, as long as i start in Windowed mode there is no problem.

 

My normal Squad launch routine is start in Windowed mode, then select Full screen in the menu and Apply. Play.

After playing i switch back to Windowed mode and then quit.

 

If i don't set Squad to Windowed mode then the next time i start the game it freezes again with a black screen. Only way to quit is through taskmanager.

 

 

Anyone knows what causes this? Am i the only one (left) with this bug?

 

No other recent Unreal Engine game, nor any other game, does this. It only happens in Squad.

 

Win 7 - i7 3770K -  GTX 970 - 16MB

Share this post


Link to post
Share on other sites

 

 

On 9/12/2015 at 0:28 AM, Usgu said:

Yes, this normally fixes the "black screen" issue. Zeep, can you confirm?

I deleted all the .ini files and restarted Squad. Then i set my settings etc. 1920x1080 fullscreen. Apply. No problem.

Then i quit and restarted. And again Squad hangs at the tips/loading screen and then turns black again.

 

So sadly it didn't fix it..

Edited by zeep

Share this post


Link to post
Share on other sites

I want to confirm that removing the

 

I deleted all the .ini files and restarted Squad. Then i set my settings etc. 1920x1080 fullscreen. Apply. No problem.

Then i quit and restarted. And again Squad hangs at the tips/loading screen and then turns black again.

 

So sadly it didn't fix it..

 

Not a fix, but have you tried borderless mode? As far as I know this should achieve the same result as full screen.

Share this post


Link to post
Share on other sites

Yes i tried borderless, but i'm not sure if it performs as good as fullscreen.

 

For now i will just keep switching from windowed to full, until eventually it will get fixed.

Share this post


Link to post
Share on other sites

I have the exact same problem as Zeep descripes !

 

Except mine freezes at the load screen(screen isnt black), but otherwise totally the same.

 

I tried :

 

1. Deleting the appdata\local\squad foler

2. Reinstalling the whole game, removing everything related to squad completly.

3. I tried editing the GameUserSettings.ini

if i input ANYTHING other than 1920x1080(my native screen res) it can start in fullscreen mode, like 1920x1079 it will start. But 1920x1080 never works.

Share this post


Link to post
Share on other sites

I found a way to start squad in fullscreen.

 

1.start squad

2.ctrl-alt-delete open task manager, right click on squad and choose "minimize"

3.wait until game is loaded

 

it dosnt freeze this way.

This isnt a real fix, just wanted to let you know.

Share this post


Link to post
Share on other sites

Hi McCracken. for me borderless works good all the time, so i just use that now. I don't think it harms framerate so..

 

Haven't tried fullscreen anymore but i'm pretty confident it will lead to the same freezing.

Share this post


Link to post
Share on other sites

Found out exactly what is causing it, in my case.

 

In nvidia shadowplay overlay settings. If i have "camera indicator" enabled the game freezes, as soon as i disabled that it start with no problems. The overlay indicator for status can be enabled, no problem, Only when the camera indicator status is enabled it freezes.

 

Another way to fix it is to have desktop capture enabled, then you can use what ever overlays you want, including camera status overlay.

 

Hope this helps. Ofc this is only for nvidia driver users, maybe amd's driver has something similar that could be causing it.

 

i tried all the regular things, with .ini files, deleting things, reinstalling game and what not, no succes, but this above fixed it.

 

>Zeep, borderless can cause input delay and other problems. Not saying that it does for squad.

Share this post


Link to post
Share on other sites

In my case i don't have Shadowplay installed. Only the drivers from nvidia.

In McCracken's train of though i've turned off Steam overlay and now i haven't had a crash anymore.

 

But once i Exit Squad and get back to the desktop, a window pops up saying Squad has crashed.

So a semi-fix, but it's too bad i can't use the Steam overlay in-game now.

 

Hope the dev's can fix this strange behavior.

Share this post


Link to post
Share on other sites

A temporary fix is to navigate to "...\Squad\Squad\Config\DefaultGameUserSettings.ini" and then set "bUseDesktopResolutionForFullscreen" to "False" if its on true. It's working for me currently, but it does glitch out if you click before the game loads in all the way. Hope this helps! :) (Sorry for me being a year late!)

Share this post


Link to post
Share on other sites

Squad is set to full-screen mode. I don't have ShadowPlay. No "bUseDesktopResolutionForFullscreen" setting.

Before the most recent update to 8.9 Squad run crash the first time, I'd use task manager to kill it then the next run would be fine.

Now it's broken every time unless I do this:

 

On 05/12/2015 at 7:56 PM, McCracken said:

1.start squad

2.ctrl-alt-delete open task manager, right click on squad and choose "minimize"

3.wait until game is loaded

Next time I'll try deleting the ini files and report back

Share this post


Link to post
Share on other sites

If you have to start the game in windowed mode. Try press alt+enter when ingame. This should make it fullscreen. Atleast you dont have to change it in the settings every time.



Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×