Jump to content
Zerzeron

System Requirements outdated?

New System Requirements  

6 members have voted

  1. 1. Overall performance after A15

    • Worsen
      1
    • Better or same
      5
  2. 2. Your RAM is

    • 8 GB or less (no stutters)
      2
    • 16 GB (no stutters)
      1
    • 32 GB or more (no stutters)
      2
    • 32 GB or more (stutters)
      0
    • Other (stutters)
      1
  3. 3. Your CPU is

    • 8+ core less than 4.5 GHz in game (no stutters)
      0
    • 8+ core more than 4.5 GHz in game (no stutters)
      0
    • 6 core less than 4.5 GHz in game (no stutters)
      2
    • 6 core more than 4.5 GHz in game (no stutters)
      1
    • 6+ core 5 GHz in game (no stutters)
      0
    • 4 core 5 GHz in game (no stutters)
      0
    • 4 core more than 4.5 GHz in game (no stutters)
      2
    • 6+ core 5 GHz in game (stutters)
      0
    • Other (stutters)
      1

  • Please sign in or register to vote in this poll.
  • Poll closes on 10/14/2020 at 07:00 PM

Recommended Posts

After A15 release I have huge drop in game performance: from 45-60 FPS down to 1-15 (Still 60FPS in training or empty server). First i wiped out config and cache, reinstalled game - nothing changed. Only one thing actually worked - low sound quality and only "100%" in sound settings. After this i was able to play skirmishes at half-populated servers; more players, or vehicles fight = unplayable lags. In-game I asked players about this problem, and most of them complain about stutters during intense combat.

I was thinking it's bug, that will be fixed soon. But A16 released and I see, it is probably new iteration in game's development. After comparing system configuration examples I was given by the players, who have no stutters after A15, I suggest following changes to System Requirements:

  • (Both parameters changing in configurations simultaneously, don't know what actually fixing it)
    • RAM: 32GB or more
    • CPU: at least 6 core at 5+GHz
  • Storage: 60GB

There is also a probability, that it's still a bug and all players have stutters of different magnitude, but owners of "top overclocked watercooled rigs" are fraud.

 

P.S. Only 3 questions allowed in poll, so no SSD, GPU, connection width and delay to servers...

Edited by Zerzeron

Share this post


Link to post
Share on other sites

I've got an SSD, 32gigs of ram, intel i7-6700K 4.4ghz and a gtx 1070 8gb gpu.

 

Every patch recently has improved my performance, not getting any stutters, unless i'm too stupid to notice them.

Share this post


Link to post
Share on other sites

What you have to understand here is that none of this is the cosumers fault. OWI is basically just really bad at optimizing their game for everyone, and every setup. 

I run with pc specs that far exceed new games requirements, games that require ten times more power than squad, and they run perfectly fine, sometimes updates come, and it goes down-side, but then they fix that issue. With OWI we're dealing with individuals whom seem to forget that programming takes time and obviously rushes out content, new configs and other things too early on that just destroys everything.

Some experience issues, others dont, not because of their specs, but because somehow new updates, or other things interfere with peoples equipment even though its way up to date.

Its the truth. 
Best advice so far, is to just wait for a finished product, if they sell this project to another company, or bail out, or finish a product that is bad, ask for a chargeback of your purchase. You didn't get what they promised in the end. That's kinda what I am looking forward too, unless they actually fix their game.

And the craziest thing is, I have two computers, the outdated one, with a graphics card from 2013, doesn't have issues, but the pc that is my main does. OWI is a laughthingstock atm.

Edited by Atlan

Share this post


Link to post
Share on other sites
1 hour ago, Atlan said:

Best advice so far, is to just wait for a finished product, if they sell this project to another company, or bail out, or finish a product that is bad, ask for a chargeback of your purchase.

  1. When it "finished", it is "finished" (noone plays it). I tried this approach: not working with online games.
  2. 1000+ hours played (most of them without stutters) - too late to charge back.
1 hour ago, Atlan said:

Some experience issues, others dont, not because of their specs, but because somehow new updates, or other things interfere with peoples equipment even though its way up to date.

1 hour ago, Atlan said:

And the craziest thing is, I have two computers, the outdated one, with a graphics card from 2013, doesn't have issues, but the pc that is my main does.

I just have got an idea: never asked people about OS version. A15 was almost same time my PC was infected with 1903 update... Not effected any other games, but still may be a problem there.

3 hours ago, Guan_Yu007 said:

Every patch recently has improved my performance, not getting any stutters, unless i'm too stupid to notice them.

For me it's not "unnoticeable": during intence fight at least every 5 seconds screen freezes for about 1 second. With "high" sound settings it completes with sound distortion and FPS turns into SPF.

Share this post


Link to post
Share on other sites

17-6700

32G ddr4-2133

r9 fury-x 4g

ssd's

atm: running all Epic except gfx(high), bloom and flares off, @1080p x 60(set limit)

 

i been waiting for da choperz, so i've not played much since v4 or 5 i think (this with only 8GB ram at the time - worked fine).

got on to practice my unplanned landings with the new v16 helo's and have not noticed any spikes or lags - i am in the training/range maps however. not had oportunity to pub yet. 

 

going up to 32G ram def helped my system, obviously; what is the real sweet-spot?, who knows, it may be only 16G for actualy playing. SSD's are a must and make a huge dif to system performance and speed. not sure that a pile of cores will do much tbh.

 

2 hours ago, Zerzeron said:

during intence fight at least every 5 seconds screen freezes for about 1 second.

this is concerning. you mentioned about OS and that 1903 patch (woteva that was) - i would be looking further into background processes and programs taking up resources - this screams something other than 'poor optimisation' otherwise everyone would be getting it.

the game does need, and will get, serious optimisation, as you surely know.

 

 

Share this post


Link to post
Share on other sites
On 15.10.2019 at 3:31 AM, LaughingJack said:

this is concerning. you mentioned about OS and that 1903 patch (woteva that was) - i would be looking further into background processes and programs taking up resources

Nothing in background. Probable problem with 1903 - scheduler updated with "topology awareness", which shoud improve performance, and it does in another game for me.

So I dipped into BIOS to tweak and overclock CPU a bit. Still have stutters, but significantly less. So problem is most likely CPU single-thread performance.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×