Jump to content
paragonid

Game lags due to Memory Hard Faults

Recommended Posts

I experienced occasional 0.5 - 1 sec lag once couple hours for long time, although one version of Squad, I think it was v12, I didn't have any at all.

Recently (it feels like after Nvidia drivers / Geforce Experience update) it became worse and I get it quite often, once 5 minutes. During the lag memory hard faults jump for 100/sec, which is my main suspicion right now. Any ways to further test or fix? Squad is on SSD. I do not use page file.

Specs: https://www.userbenchmark.com/UserRun/20814918

Edited by paragonid

Share this post


Link to post
Share on other sites

Had an fps drop with some of the newer nividia drivers after 419.67 might be that . Also check shader  cache off to stop graphics caching to your SSD.  May have to untick cache textures too..  

 

 

spec: https://www.userbenchmark.com/UserRun/20816504

 

Edited by Smee

Share this post


Link to post
Share on other sites

Might I suggest you try a pagefile.  12gb or alike. 

Share this post


Link to post
Share on other sites

Placed pagefile on HDD, tried both 24gb and WIndows managed, similar symptoms, game occasionally (rare again) lags during increased access to game files on HDD

I have a feeling disk access is correlation, not the reason. I loaded HDD with bunch of copy work during game, lag didn't increase

Edited by paragonid

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×