Jump to content
Sign in to follow this  
Root

Server Closed Connection

Recommended Posts

Hello,

This has been happening since about two patches ago, but far more frequently since the latest patch. Every 15 minutes or so, I will be kicked from any server with this message. I have reinstalled the game (on a new HDD and my SSD), repaired and reinstalled easy anti-cheat, checked my firewalls, allowed the game and easy anti-cheat through it, and deleted the folders in appdata a dozen times. I cannot figure out why this is happening. I never had the issue before. As you can imagine, it gets annoying to get into a server after waiting on ques with about 10 other people just to be kicked in 15mins and wait again when I'm playing with my friends. Some of my friends get this issue randomly as well.

Any idea what this could be?
*Also, I'm not in the public testing version, just in the normal Squad version.

Specs:
i7-8700k
RX 580
16GB RAM
500gb SSD

 

Thanks,

Share this post


Link to post
Share on other sites
Posted (edited)

So then it definitely is not a small issue, because if it is me, my friends and some people I saw on the servers I was playing on, then it has to be the patch?

 

EDIT

 

I don't know how to attach the log file, but it has a lot of what looks like errors and I can't paste it because it is too long. :(

Edited by Root

Share this post


Link to post
Share on other sites

I've been digging. This is not a small problem and it seems to have been getting worse and worse every patch.
 

 

 

 

 

I haven't seen a single reply from a dev or any official answer on any of these threads either (or the reddit threads or the steam threads), and there are still tons of people still having this issue. Is it just being ignored? Is it a problem that happens sometimes with latest patches? Are they even aware of this?

Share this post


Link to post
Share on other sites

Since I couldn't get support from Squad or EAC, I decided to reinstall Windows 10 and see if that'll fix the issue. It seemingly fixed the issue. I'll continue to test but the solution should not be to reinstall Windows entirely. At all.

Share this post


Link to post
Share on other sites

Turns out it didn't help. It granted me about 3 hours of reprieve and then returned.

 

What a headache.

Share this post


Link to post
Share on other sites

BUMP

I've now also tried the NIC Offloading suggested here. Did not help, I'm still being thrown to the menu with server closed connection messages. I just want to play the game. I've contacted Squad support, EAC support, reinstalled Windows 10, reinstalled Steam, reinstalled Squad, tried my SSD and HDDs, tried clearing cache manually and automatically (and at different stages hoping it would help), I've tried disabling firewalls, I've tried repairing EAC, uninstalled + rebooting + reinstalling EAC, I've tried reinstalling my GPU drivers fresh (latest, last one before and 3 back from the latest), checking to see if I have a virus (despite being on a new OS install), I've tried enabling Developer Mode on Win10, I've tried removing all unnecessary devices from the PC, I've tried uninstalling everything that is not directly essential (that means even my browser, Firefox!),  I've tried resetting my router, I had my ISP check my connection and make sure my router was healthy and up to date....I think I've tried everything at this point.

Please, someone...help. :(

 

EDIT

 

Does it perhaps have something to do with this???

https://www.tacticalgamer.com/forum/simulation/squad/1789416-server-closed-connection

Edited by Root

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×