Jump to content
Sign in to follow this  
Root

Server Closed Connection

Recommended Posts

Hello,

This has been happening since about two patches ago, but far more frequently since the latest patch. Every 15 minutes or so, I will be kicked from any server with this message. I have reinstalled the game (on a new HDD and my SSD), repaired and reinstalled easy anti-cheat, checked my firewalls, allowed the game and easy anti-cheat through it, and deleted the folders in appdata a dozen times. I cannot figure out why this is happening. I never had the issue before. As you can imagine, it gets annoying to get into a server after waiting on ques with about 10 other people just to be kicked in 15mins and wait again when I'm playing with my friends. Some of my friends get this issue randomly as well.

Any idea what this could be?
*Also, I'm not in the public testing version, just in the normal Squad version.

Specs:
i7-8700k
RX 580
16GB RAM
500gb SSD

 

Thanks,

Share this post


Link to post
Share on other sites

So then it definitely is not a small issue, because if it is me, my friends and some people I saw on the servers I was playing on, then it has to be the patch?

 

EDIT

 

I don't know how to attach the log file, but it has a lot of what looks like errors and I can't paste it because it is too long. :(

Edited by Root

Share this post


Link to post
Share on other sites

I've been digging. This is not a small problem and it seems to have been getting worse and worse every patch.
 

 

 

 

 

I haven't seen a single reply from a dev or any official answer on any of these threads either (or the reddit threads or the steam threads), and there are still tons of people still having this issue. Is it just being ignored? Is it a problem that happens sometimes with latest patches? Are they even aware of this?

Share this post


Link to post
Share on other sites

Since I couldn't get support from Squad or EAC, I decided to reinstall Windows 10 and see if that'll fix the issue. It seemingly fixed the issue. I'll continue to test but the solution should not be to reinstall Windows entirely. At all.

Share this post


Link to post
Share on other sites

Turns out it didn't help. It granted me about 3 hours of reprieve and then returned.

 

What a headache.

Share this post


Link to post
Share on other sites

BUMP

I've now also tried the NIC Offloading suggested here. Did not help, I'm still being thrown to the menu with server closed connection messages. I just want to play the game. I've contacted Squad support, EAC support, reinstalled Windows 10, reinstalled Steam, reinstalled Squad, tried my SSD and HDDs, tried clearing cache manually and automatically (and at different stages hoping it would help), I've tried disabling firewalls, I've tried repairing EAC, uninstalled + rebooting + reinstalling EAC, I've tried reinstalling my GPU drivers fresh (latest, last one before and 3 back from the latest), checking to see if I have a virus (despite being on a new OS install), I've tried enabling Developer Mode on Win10, I've tried removing all unnecessary devices from the PC, I've tried uninstalling everything that is not directly essential (that means even my browser, Firefox!),  I've tried resetting my router, I had my ISP check my connection and make sure my router was healthy and up to date....I think I've tried everything at this point.

Please, someone...help. :(

 

EDIT

 

Does it perhaps have something to do with this???

https://www.tacticalgamer.com/forum/simulation/squad/1789416-server-closed-connection

Edited by Root

Share this post


Link to post
Share on other sites

I see a patch has been pushed through, but no notes on what it is. I really hope it is a fix for this issue and the other crashing issue a lot of us are experiencing...

Share this post


Link to post
Share on other sites

Same issue here. A few of my buddies on discord are having the same issue and have basically quit playing the game because of it. It's really frustrating that even a researched thread where you've shown what you've tried doing to fix the issue and it's still ignored.

 

Share this post


Link to post
Share on other sites

I haven't played since. I don't think it is ever going to work again. My internet is fine, my router is fine, I have nothing wrong with my computer (even checked others). It is something to due with Squad or EAC, but it isn't something I think they can figure out so I guess I'm done with Squad. :(

Share this post


Link to post
Share on other sites

I've had this issue for months now. At one point my hard drive broke so I got it repaired with a whole new hard drive, reinstalled squad, get on, and I have the exact same issue. Devs probably don't have a fix for it, that's probably why they're ignoring it.

Share this post


Link to post
Share on other sites

Recently had 1 episode of this issue aswell.

 

- Mapchange and during staging phase i got dc'd. Server closed connection.

- Rejoined and then it dc'd me while driving my 30mm a few minutes later during a fight with a stryker.

- Quit for 15min, came back and i didn't even get to the team selection but got a UE4 crash.

 

An hour or two later, i could play normally again.

 

Apparently (comes from a friend who does IT) squad seems to be quite strict on packet loss.

Drop one or 2 packets, and it thinks you're disconnecting.

 

Doesn't mean your own connection is bad, but if along the way one station drops a few times, it's game over.

 

 

Share this post


Link to post
Share on other sites

Having the same issue since the past 2 updates as OP. Lots of others complaining about it on the Steam (Squad) forums too. Pretty much unplayable - I'm sick of dropping off randomly and letting my squad down... especially when driving a full truck!!

Share this post


Link to post
Share on other sites
On 12/10/2019 at 5:52 AM, oTec said:

Recently had 1 episode of this issue aswell.

 

- Mapchange and during staging phase i got dc'd. Server closed connection.

- Rejoined and then it dc'd me while driving my 30mm a few minutes later during a fight with a stryker.

- Quit for 15min, came back and i didn't even get to the team selection but got a UE4 crash.

 

An hour or two later, i could play normally again.

 

Apparently (comes from a friend who does IT) squad seems to be quite strict on packet loss.

Drop one or 2 packets, and it thinks you're disconnecting.

 

Doesn't mean your own connection is bad, but if along the way one station drops a few times, it's game over.

 

 

But I do not have packet loss? I checked. Dozens of times. I have called my ISP. I have talked with Squad support, who asked me to check if I had packet loss. My ISP got rather annoyed with me after the seventh call of me requesting to check if there was an issue and to help me determine of there was one on my end. So much so that they came out and repaired all of the lines (which were new since that year anyway) but the issue is still here. Got a new router, too. Issue still here. I got new CATs, issue still here. And no amount of rejoining after amount of waiting fixes it for me. The kick is every 15mins, on any server, straight to the main menu. Only on Squad.  Given that all my tests have come up clean and my ISP is adamant that I do not have these issues and Squad support even thought this and ended up agreeing, I am going to say: it is not on my end. It started with the helicopter patch. Immediately.
 

Let's say it is that issue though. I've had the same connection for years and have been playing without issue on Squad since 2017 (2016?), a near $200 ultimate package from my ISP, so if I have packet loss all of this time (which I don't from my end and my ISP confirms), Squad made a change with the helicopter patch that kicks people for even the most softest of loses—which is asinine and if true, needs to be fixed ASAP.

 

The Steam thread itself now is at 50 comments and still going, and that's just the Steam thread. This is getting ridiculous and the devs need to say and do something about the issue. Ignoring it is just wrong. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×