Jump to content

Recommended Posts

Posted (edited)

System

GPU: GTX 970 

CPU: i5 4690k 3.5GhZ

Monitor: 144hz, G-Sync

RAM: 32GB, DDR-3

Squad installed on SSD.

 

Squad runs fine but after a few rounds it starts to stutter on certain events. For example when I open the complex map (enter) or hold T as Squad Lead it freezes for a half of a second. Sometimes it feels like there is lower FPS but when I restart the game/ computer it runs fine again. 

 

No crashing appears usually. 

 

Whats going on here?

 

Edited by Scheintot

Share this post


Link to post
Share on other sites

First thing first i guess, clear the cache.

 

But reading your post, this feels more like a memory problem or maybe overheating?

 

Have you set a page file size?

At what temp is your cpu after those few rounds?

Share this post


Link to post
Share on other sites
Posted (edited)

I think your problem is related to your 970s Vram. Although it has 4gb GDRR5 anything over 3.5gb of usage causes the cards performance to deteriorate. Here's an explanation of how the memory on the 970 is used.

https://kb.newegg.com/knowledge-base/nvidia-geforce-gtx-970-memory-allocation/

 

You could run something like Afterburner or GPU-Z to check your Vram usage when you experience freezes to confirm.

 

Both of those programs will show your GPU & CPU temps as well.

Edited by Major Trouble

Share this post


Link to post
Share on other sites
Posted (edited)
10 hours ago, oTec said:

First thing first i guess, clear the cache.

 

But reading your post, this feels more like a memory problem or maybe overheating?

 

Have you set a page file size?

At what temp is your cpu after those few rounds?

I will try to clear the cache first. I haven't done that yet to be honest. Might be some trash from older versions, who knows.

 

Page file is disabled duo to 32GB of RAM. Temps should not be over 85° C. Peak might be slightly above it but definitly not above 90°C.

I also got a VR Headset (RIFT-S) and I can play VR Games without stuttering. Oculus Software is offline during Squad. I always check that. Only have had this stuttering issue with PUBG which is also based on UE4. But with the newest update I can't remember it occured again in PUBG. 

Also when I work with UE4 Editor I don't have any stuttering. Same goes for any other UE4 games.

GPU Driver is up to date.

 

9 hours ago, Major Trouble said:

I think your problem is related to your 970s Vram. Although it has 4gb GDRR5 anything over 3.5gb of usage causes the cards performance to deteriorate. Here's an explanation of how the memory on the 970 is used.

https://kb.newegg.com/knowledge-base/nvidia-geforce-gtx-970-memory-allocation/

 

You could run something like Afterburner or GPU-Z to check your Vram usage when you experience freezes to confirm.

 

Both of those programs will show your GPU & CPU temps as well.

Thats true and I already know about that but since the GPU can handle the game quite good (normal fps, at least over 60 steady - full server, any map) it can also be a software problem related to the game. Maybe it is not clearing the VRAM in a decent way and later it starts to fill up aggressively. Also there is this weird crash reported lately - even on newest Nvidia Generation Cards where the game crashes and reports a memory error.

 

 

PS: Also keep in mind that this issue is just happening on specific events. Just if I press T as Squad Lead or open the map. It does not realy sound like a VRAM issue on the first look. Still could be it of course.

 

 

Edited by Scheintot

Share this post


Link to post
Share on other sites

I think that there is an issue with 15.4, in this regard. I have stuttering as well, but I can't relate them to any specific action. It comes out of nothing and goes out of nothing, but while there it's impossible to play. I had to kill squad.exe a few times as my PC became almost unresponsive. And it happens only with Squad.

Share this post


Link to post
Share on other sites
Posted (edited)
14 hours ago, Xeinar said:

I think that there is an issue with 15.4, in this regard. I have stuttering as well, but I can't relate them to any specific action. It comes out of nothing and goes out of nothing, but while there it's impossible to play. I had to kill squad.exe a few times as my PC became almost unresponsive. And it happens only with Squad.

Yesterday I turned off Page File completlely as it turned out that it was not disabled. (My mistake).

Also I installed the newest Windows Updates (1903 now) and when I restarted my computer Shadowplay was offline due to Geforce Experience Error 0x0003 (which has been fixed today by reinstalling Geforce Experience). Squad was fine without shadowplay for 3-4 rounds. Then I stopped playing. This might be an indicator what could have started the stuttering issues. Haven't tested it with shadowplay since yesterday but if it was shadowplay I want to fix it because I need it. Maybe because the temp folder for shadowplay was on a HDD instead of SSD. I changed that now. I will test and report. Maybe one of these will fix someone's elses stuttering. 

Edited by Scheintot

Share this post


Link to post
Share on other sites

I have and AMD graphic card, so in my case can't be Shadowplay. I'm keeping troubleshooting, anyway.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×