Jump to content
rmagid1010

Server Closed Connection Crash

Recommended Posts

I recently purchased and downloaded squad from steam.

 

I have recently been enjoying the game without issue. However, for the last two days a crashing bug has prevented me from enjoying the game. During online gameplay (and never in the offline practice range mode), the game will randomly kick me off the server. I never team kill or flame in squad, and the crashes have happened on multiple servers so i am positive that the server admins are not kicking me themselves. The crashes are unpredictable but inevitable, and happen in between 20 minutes and 30 seconds of game play. This is obviously extremely frustrating so if anyone can help me that would be very appreciated.

 

The error message given is; "Squad Server Closed Connection". This vague error message does not aid in the diagnosis of the problem.

 

Specs

 

Intel i7 7700

 

Nvidea GTX 1070

 

8GB RAM

 

1TB SSD

 

I have extremely fast wifi, with excellent download/upload speeds and sub 30ms ping times, which i know through the stat fps function in the console. I am sure this is not a connection issue on my side.

 

I have attempted to delete the squad appdata and validate through steam. I have uninstalled and reinstalled squad to no avail. I have followed all the steps in another guide somewhere on this forum to maximise pc performance but to no avail.

 

I have never used hacks or mods in any game (never mind any Unreal game) so Easy anticheat is unlikely to interfere with the game but who knows

Share this post


Link to post
Share on other sites
8 hours ago, rmagid1010 said:

I recently purchased and downloaded squad from steam.

 

I have recently been enjoying the game without issue. However, for the last two days a crashing bug has prevented me from enjoying the game. During online gameplay (and never in the offline practice range mode), the game will randomly kick me off the server. I never team kill or flame in squad, and the crashes have happened on multiple servers so i am positive that the server admins are not kicking me themselves. The crashes are unpredictable but inevitable, and happen in between 20 minutes and 30 seconds of game play. This is obviously extremely frustrating so if anyone can help me that would be very appreciated.

 

The error message given is; "Squad Server Closed Connection". This vague error message does not aid in the diagnosis of the problem.

 

Specs

 

Intel i7 7700

 

Nvidea GTX 1070

 

8GB RAM

 

1TB SSD

 

I have extremely fast wifi, with excellent download/upload speeds and sub 30ms ping times, which i know through the stat fps function in the console. I am sure this is not a connection issue on my side.

 

I have attempted to delete the squad appdata and validate through steam. I have uninstalled and reinstalled squad to no avail. I have followed all the steps in another guide somewhere on this forum to maximise pc performance but to no avail.

 

I have never used hacks or mods in any game (never mind any Unreal game) so Easy anticheat is unlikely to interfere with the game but who knows

 

You're not joining on map change, are you?

If you join while the server is changing map, it will kick you after a few minutes.

 

Squad is also having some problems since v13-v14 with mass disconnecting after a map change, so it might not be on your end all the time.

 

Any posibility to try a wired connection just for a test?

Share this post


Link to post
Share on other sites
7 minutes ago, rmagid1010 said:

I always use a wired connection for my internet. I also forgot to mention that i always update my drivers aswell

 

I read wifi, that's why i'm asking.

 

Have you recently update windows or your gpu drivers?

Share this post


Link to post
Share on other sites

I think i've read somewhere that frequent server disconnects became more common with the v14 patch. Maybe it's not your PC that is at fault and it's something for the developers to fix in the upcoming patches. I also get 1-2 disconnects per play session from time to time now and i didn't get any in v13, so it could be the case.

Share this post


Link to post
Share on other sites

yeah im not sure why i wrote wifi when im plugged in with a cable lol

 

I recently updated windows 10 to the latest edition and i use geforce experience to update gpu drivers.

 

I believe i got squad after the v14 patch and this is only a recent problem. I will play now to see if it still happens again and i will let you know.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×