Jump to content
Sign in to follow this  
Kappadini

Squad no servers showing in the browser

Recommended Posts

Posted (edited)

Hi guys, im having trouble with the server browser, i have tried mostly everything so i wanted to ask for your help. Yesterday was the first time I downloaded and installed Squad since about end of 2018 so its been a while. When i first opened up the game i changed the video settings etc before actually looking at the server browser. When i was finally done i wanted to join a server but none showed up, refresh button is kind of transparent and i cant click it, filters dont do anything and it says steam is online. One time when i started the game through steam an error showed up but i didnt read all of it before i clicked OK so i didnt know what it meant until later when i tried running the game (SquadGame.exe, not the launcher) from its main folder in steam, the same error keeps appearing:iR8lRo8.jpg

I dont know if it actually means anything, i tried repairing, reinstalling Easy anti cheat but it didnt fix it, i also have SCUM which uses the same anti cheat and it works fine so its probably not it, just wanted to add it into the post.

 

What i've already tried:

- everything from the offworld industries site, nothing worked.

- i have the killer network drivers (on a gigabyte motherboard) but not the suite, software, manager. I tried installing the manager, uninstalling it and getting the drivers alone, disabling and deleting the controller from Network Adapters, deleting the driver itself from system32 and getting a new one (new one didnt want to work so i put the old one back in, didnt matter which one was in, it always said it cant update the drivers because the latest are already there, even tho they were completely removed).

- i plugged my phone in through usb and enabled the internet, disabled the killer ethernet in Network Connections (adapter settings) and started the game like this but still nothing.

- some guy in a steam thread said turning off the option "run as administrator" on SquadGame.exe and squad_launcher.exe fixed it but mine was already turned off, so i turned it on, checked the game (nothing happened) then turned it off and still no servers.

- the pinned topic on this forum also didnt do it for me.

- i reinstalled Squad, cleared everything.

- changing the maximum ping in steam settings

 

If i go into View in Steam and choose Squad servers only one pops up, its empty and it runs with the anti cheat off. When i try to connect it starts the game but it just stays on the main menu screen.

 

Right now im considering completely deleting steam and downloading everything again or even formatting my pc (wouldnt want to though)

 

Also, i dont know if it has to do anything with it but I also downloaded Red Orchestra 2 (its also been a couple of months since i played it) and it only shows 3/4 servers online instead of many more like before. I tried doing some stuff with it but couldnt fix it either. Now, I dont know if people just completely stopped playing it since the new game came out (doubt it because there would still be some servers, empty but still. And the last time i played it was months after the new game came out and there were plenty people playing) or if its broken aswell, i can join one of those servers and it works fine. It cant be the anti-cheat because RO2 uses Punkbuster not EasyAntiCheat.

 

I would really appreciate any help from you guys, thank you very much in advance.

Edited by Kappadini

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×