Jump to content
Sign in to follow this  
fidanym

Cyrillic Keyboard layout and game controls issue

Recommended Posts

I'm not sure if anyone has noticed it but I have multiple keyboard layouts (English and Macedonian(Cyrillic)) and the default windows toggle hotkey for them is Alt + Shift which is quite a common combo in game, especially when you run and look around so the keyboard switches to Cyrillic. But unlike other games, some of the game controls do not pick up on it, for example pressing any of the letter keys will not trigger a command as they are now in Cyrillic.

Is it possible to make the game ignore whatever keyboard language layout is selected and use standard latin keys? It's quite annoying having to disable the multiple keyboard layouts every time before playing Squad.

Share this post


Link to post
Share on other sites

You can change the settings to whatever you would like by doing the following in windows:

  1. region & language
  2. advanced keyboard settings
  3. Language bar options
  4. advanced key settings
  5. change key sequence
  6. давай

I have the switch between input languages unassigned, English set to Ctrl + 1, and Русский as ctrl + 0.

 

Hope this helps.

Share this post


Link to post
Share on other sites

That is not the problem tho. Perhaps I should give a more clear example.

In most games, particularly in Project Reality:

ENG keyboard: Press Z, go prone

MKD keyboard: Press Z, go prone

 

In Squad:

ENG Keyboard: Press Z, go prone

MKD Keyboard: Press Z, nothing happens because the game picks up its Cyrillic value.

Share this post


Link to post
Share on other sites

There's no way around UE4 not picking up foreign keyboards, even fortnite has issues with AZERTY keyboards. Switching your windows layout hotkey is to something not commonly pressed in squad is the only workaround I've found.

Share this post


Link to post
Share on other sites

Oh well, I'll just have my Cyrillic disabled whenever I play Squad, it's not too much of a big deal.

Share this post


Link to post
Share on other sites

I don't have that problem. Cyrillic symbols works fine. If you bind Z to prone, then switch to Russian and press Z in russian layout, character prone.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×