Jump to content

Recommended Posts

Hi,
My mic stopped working in Squad. The important info:

My set is the Artic pro + game dac.

I have played squad with it a few months ago and the mic worked fine.
The mic works with every other program.

I played with everything settings available to me that I know of (windows input devices, steam input, squad on admin, game dac options)
And this seems to be a common problem.

Offworld industries, we all know this problem requires a patch for the game. Could this be made a priority? The entire selling point of this game is communication and I clearly do not enjoy this game with my mic not working.
Thank you!

Share this post


Link to post
Share on other sites

Has it ever worked with it?

 

I've got Artic pro and works fine.  Just have to make its on at the start of booting.  What can be an issue is that bluetooth enabled  seems to cause issues. or the balance on the DAC of game and chat mix. 

 

And your right this game is all about communication. 

Share this post


Link to post
Share on other sites
Posted (edited)

I'm not too familiar with a dac, but is there a way to plug the headset directly into the pc? Maybe try a different port?

I got a simple hyperX cloud and never had a problem with it, except for the front audio ports of my mobo being worse quality than the back.

 

Does that headset also come with drivers, since it's not a simple plug into audio port type of headset.

Edited by oTec

Share this post


Link to post
Share on other sites

Settle down y'all..  No need to go on about at people who wishes to help others..

 

It seems it is USB connection not 3.5mm aux or Bluetooth with USB converter? 
Please ensure you are doing the following, 
If exist, use the given software from the MFR and see if there is anything in the settings that can be fiddled with. 

Make sure your USB Slot is not at fault; Some of USB connected headset, when lost connection, you have to restart the game, make sure it is not the case. 
Lastly, Make sure to put your mics to default while Squad is turned on, some windows update might reset the said settings, it wouldn't hurt to try to verify that. 

 

\Cleaned thread 

Share this post


Link to post
Share on other sites

Actually, I found the fix yesterday and I'm baffled no one here knows about it. Again, this is a game fix required, not a user end problem. Offworld industries knows it because they tell you to use a third party program to fool the game into thinking you have a 3.5mm jack mic.
https://offworldindustries.zendesk.com/hc/en-us/articles/360002689113-Certain-headsets-not-working

 

Sorry I got ticked off, but I hate when people insert themselves as pseudo computer experts and then tell you you're the problem. And Mod, how come you don't know this?

Share this post


Link to post
Share on other sites

For me the 3rd party driver did not help. What fixed it for me was: 

1.Setting windows default input and output device

2.Setting input and output to default option in steam and discord

3.Deleting squad from discord game activity

Share this post


Link to post
Share on other sites

i have a 3.5 mm and mine doesn't work, I've tried everything and none have worked, my headset worked fine for about 3 months of owning the game then, out of the blue, it stopped detecting my mic all together. In game my ID doesn't even have a mic icon next to it.

 

Edited by MidnightMatric

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×