Jump to content
RipGroove

FPS has tanked since v12??!!

Recommended Posts

I used to get 100fps average @ 3440x1440 Ultrawide with all settings maxed out, I just played my first 2 games since v12 and my FPS was anywhere between 50-100 but constantly fluctuating massively, I assume this is a v12 thing as nothing has changed my end? My other games still perform flawlessly.

 

Spec (for reference):

CPU: i7-7700k

GPU: Evga 1080ti SC2 Hybrid (Driver 416.94, not the latest because BFV ran like shit on the latest one)

RAM: 16GB Corsair Dominator Platinum 3200MHz

SSD: Samsung m.2 nvme

 

I was hoping to get back in to Squad over the holidays but if it's behaving like that that'll put me right off.

 

Edited by RipGroove

Share this post


Link to post
Share on other sites

I run in 1440 with tournament settings 

 

6700k  @4.3 

1080 

32gb 

m.2 

 

and im running the same, around 75 to 95 

Edited by ZXD_Lee

Share this post


Link to post
Share on other sites

I'm still getting a bit of chug on Yeho is all. I think it could use another optimization pass. Talill fps seems to have gotten better, maybe related to reducing the particle effects of the distant burning oil well smoke plumes?

Share this post


Link to post
Share on other sites
On 12/23/2018 at 4:34 PM, Guan_Yu007 said:

In the public testing of V12 i had massive fps drops, but now in v12.2 it's almost back to V11 levels of performance for me.

Are you using an Nvidia GPU? If so what driver are you using?

Share this post


Link to post
Share on other sites
4 minutes ago, RipGroove said:

Are you using an Nvidia GPU? If so what driver are you using?

GTX 1070, latest driver.

But the performance side of stuff in Squad has more to do with the CPU.

Mine is an i7-6700K 4.0-4.4 GHz.

Share this post


Link to post
Share on other sites
On 12/27/2018 at 12:51 PM, Guan_Yu007 said:

GTX 1070, latest driver.

But the performance side of stuff in Squad has more to do with the CPU.

Mine is an i7-6700K 4.0-4.4 GHz.

Yeah I know I've had Squad since 2015 so I've seen all the ups and downs with regards to performance, my current CPU is a 7700k. Maybe I'll try the latest Nvidia driver again as some people are reporting that this latest version of Squad runs as good as v11 did, definitely not the case for me. 

Edited by RipGroove

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×