Jump to content
Dauqs

Pulling up sights on any weapon is wonkey as heck, just me?

Recommended Posts

OS:  Win 10

CPU:  AMD... 6850, I think?

GPU: GTX 670 2GB

RAM: 8GB DDR3

 

 

I can right click 10 times exactly the same way and it does something different every time. I can tap it, hold it, press it, doesn't matter. Sometimes it pulls up my sights no problem, sometimes the sights start to come up and then go back down, sometimes nothing happens at all(or the opposite if my sights are already up). I've had this issue long before V12 but I guess whatever is causing it didn't get fixed so I gotta come complain. Doesn't matter if my ping is 30 or 300, it just acts wonky and I've died many times due to it. Game runs fine otherwise, all the settings on low so it looks like PR but I digress.

 

So annoying all I can do if I unexpectedly come across a enemy is to spray-n'-pray because I cant reliably pull up sights.

Share this post


Link to post
Share on other sites

it sound like your control input is causing a bug

 

maybe you can try this

1. Did you try clear user cache data via ingame menu?

2. if problem still persist maybe try verify cache with steam

3. maybe try change a mouse just to be sure that trouble isn't cause by your device

 

^^^^ if all of this still didn't help then must wait for someone else to answer xD

Share this post


Link to post
Share on other sites

Well that didnt't help but I found out if I change it from RMB to something else it works flawlessly, so what the hell?

 

I have a theory, I remember there being a "hold to use sights" option but its gone now, maybe thats still stuck in my controls somewhere? Even though I wiped the cache...

Edited by Dauqs

Share this post


Link to post
Share on other sites
2 hours ago, Dauqs said:

Well that didnt't help but I found out if I change it from RMB to something else it works flawlessly, so what the hell?

 

I have a theory, I remember there being a "hold to use sights" option but its gone now, maybe thats still stuck in my controls somewhere? Even though I wiped the cache...

Maybe this will help, I find it on 

 

  • Did you take a long break from Squad and just came back? Welcome back!

I need to remind you that Unreal Engine 4, in which Squad is designed with, had a major update on September of 2017. If it was before that time you played the last, you MUST do a clean re-install of the game.

Click ‘Reveal hidden contents to see how to:

  Hide contents

1. Manually delete %localappdata%\Squad

2. Uninstall Squad via Steam

3. Manually delete remaining folders in Squad installation directory
     default: C:\Program Files (x86)\Steam\steamapps\common\Squad

4. Install Squad via Steam

5. Reboot PC

 

  

Share this post


Link to post
Share on other sites

hahaha or like i post ealier you can try use spare mouse just to make sure its not cause by your current mouse anyway hope this working

Share this post


Link to post
Share on other sites
2 hours ago, Dauqs said:

Problem persists and it ain't the mouse either.

damn sorry to hear that look like we have to wait for other to answer I'm running out of idea as well, hope you can get the fix soon

Share this post


Link to post
Share on other sites

Oh well, thought I had it fixed for a minute there but its still doing it, just not nearly as bad.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×