Jump to content
Sign in to follow this  
Bulldouzer

performance issues

Recommended Posts

So before this update i could play this game with all graphic options in low and lowest resolution with 40 fps on maps with 80 players  and some fps forps sometimes . Now after this update I CANT EVEN LOAD THE FIRING RANGE

Edited by Bulldouzer

Share this post


Link to post
Share on other sites

it´s not the graphics (although your specs seem rather low). IT´s some problema many of us are experiencing connecting to any server. SERVER TIMES OUT...

Share this post


Link to post
Share on other sites

As much as i love playing V12 so far, i do wonder how they decided to just release it already, should've given it another week or two of solid public testing. Should keep an eye on the forums and discord, see when a patch or hotfix gets released. :)

Share this post


Link to post
Share on other sites
2 hours ago, Bulldouzer said:

So before this update i could play this game with all graphic options in low and lowest resolution with 40 fps on maps with 80 players  and some fps forps sometimes . Now after this update I CANT EVEN LOAD THE FIRING RANGE

Literally the same problem. Except I could play on medium settings  with a perfectly fine resolution. Now I can’t everything is just unplayable.

Edited by BigBOYJEFF8383

Share this post


Link to post
Share on other sites

Performance is worse in v12 than it was in v11. There seems to be some kind of stutter. 

Share this post


Link to post
Share on other sites
11 hours ago, Guan_Yu007 said:

As much as i love playing V12 so far, i do wonder how they decided to just release it already, should've given it another week or two of solid public testing. Should keep an eye on the forums and discord, see when a patch or hotfix gets released. :)

That’s how I feel. Maybe they wanted to rush it out for the free weekend, which has started already, right?

Share this post


Link to post
Share on other sites

If you are having performance issues, make sure you have Fully Loaded Textures turned off in graphics settings, as that is one of the main performance heavy settings Squad has, if you do not have 4GB+ Vram and 16GB memory.

Also, make sure you have cleared you game cache, which is located in game settings down the bottom of the screen - Note this will remove key binds etc and you will have to reset your graphic settings.

 

Share this post


Link to post
Share on other sites

 

3 hours ago, Dubs said:

If you are having performance issues, make sure you have Fully Loaded Textures turned off in graphics settings, as that is one of the main performance heavy settings Squad has, if you do not have 4GB+ Vram and 16GB memory.

Also, make sure you have cleared you game cache, which is located in game settings down the bottom of the screen - Note this will remove key binds etc and you will have to reset your graphic settings.

 

you can erase your useless comment and ask the devs the problem , et when is the fix ? you are not a BOT who try to help us with automatic sentences like UPDATE YOUR DRIVER.

Share this post


Link to post
Share on other sites
3 hours ago, Dubs said:

If you are having performance issues, make sure you have Fully Loaded Textures turned off in graphics settings, as that is one of the main performance heavy settings Squad has, if you do not have 4GB+ Vram and 16GB memory.

Also, make sure you have cleared you game cache, which is located in game settings down the bottom of the screen - Note this will remove key binds etc and you will have to reset your graphic settings.

 

My problem is when I play Squad V12 on any map, if I turn with Fully Loaded Textures on it becomes a slideshow and lags. I would have to look at one spot for the textures to load and it work fine. When I turn it off, I get 60 FPS

 

But the caveat is when I turn it off, the textures of the game are absolutely abysmal. No detail at all, trees and foliage, some spots of the ground I can see through, and there's no facial features or anything, it just becomes a blob of polygons and the graphics are practically non existant which makes it unappealing to play to say the least. In V11 I disable it and the textures stay as they are and I can play just fine, but not anymore.

 

I need help from anybody who's competent enough, please.

Share this post


Link to post
Share on other sites
47 minutes ago, infamousplayer said:

 

you can erase your useless comment and ask the devs the problem , et when is the fix ? you are not a BOT who try to help us with automatic sentences like UPDATE YOUR DRIVER.

The information I posted is relevant, as they are the most common go-to fixes for a lot of post patch performance issues - and surprisingly, a lot of people aren't aware they might have full texture loading on, or know clearing cache is almost a requirement every major update. The information is here incase people stumble across this thread and aren't aware.

No need to act in a snide & rude manner either, that gets you no where - Only warning.

If you want, head to the official discord and post in the support section there, support staff check regularly.
https://discordapp.com/invite/squad

 

23 minutes ago, Annoying Rooster said:

My problem is when I play Squad V12 on any map, if I turn with Fully Loaded Textures on it becomes a slideshow and lags. I would have to look at one spot for the textures to load and it work fine. When I turn it off, I get 60 FPS

 

But the caveat is when I turn it off, the textures of the game are absolutely abysmal. No detail at all, trees and foliage, some spots of the ground I can see through, and there's no facial features or anything, it just becomes a blob of polygons and the graphics are practically non existant which makes it unappealing to play to say the least. In V11 I disable it and the textures stay as they are and I can play just fine, but not anymore.

 

I need help from anybody who's competent enough, please.

 

Blurred and low res textures are a current texture streaming issue, that the Devs/QA are aware of(Has been an issue since v12 testing) and implemented a partial fix on full release. It's affecting everyone in some way or the other. For me, team selection character models and role selection character models are all low res, but everything else in-game is 100% fine. 


We may have to wait for a hotfix to fully correct it.








 

Share this post


Link to post
Share on other sites
1 hour ago, Dubs said:

(...) For me, team selection character models and role selection character models are all low res, but everything else in-game is 100% fine.

Exactly the same for me

1 hour ago, infamousplayer said:

You can erase your useless comment and ask the devs the problem , et when is the fix ? you are not a BOT who try to help us with automatic sentences like UPDATE YOUR DRIVER.

Because it actually IS the first thing to chek after each release. Have you even given his solution a try ?

Fully Loaded Textures turned ON and V12 is unplayable for me @ 15 FPS max ; OFF and it runs fine @ avg 50 FPS (no other changes in GFX settings since V11).

1 hour ago, Annoying Rooster said:

But the caveat is when I turn it off, the textures of the game are absolutely abysmal. No detail at all, trees and foliage, some spots of the ground I can see through, and there's no facial features or anything, it just becomes a blob of polygons and the graphics are practically non existant which makes it unappealing to play to say the least. In V11 I disable it and the textures stay as they are and I can play just fine, but not anymore.

Try "Verify integrity of game files" in Steam + "clear cache" ingame.

Happened to me in V11 and clear cache fixed it for me.

 

Share this post


Link to post
Share on other sites
16 hours ago, Nubski said:

Performance is worse in v12 than it was in v11. There seems to be some kind of stutter. 

 

7 hours ago, infamousplayer said:

same thing , freeze , 8 minutes for join a server , unplayable

 

same here  game using all the ram , fps and ping go crazy , last night , i had to disconnect and reconnect to a server to join my mates  it took more than 15 min 

Edited by Evans

Share this post


Link to post
Share on other sites
13 hours ago, Dubs said:

If you are having performance issues, make sure you have Fully Loaded Textures turned off in graphics settings, as that is one of the main performance heavy settings Squad has, if you do not have 4GB+ Vram and 16GB memory.

Also, make sure you have cleared you game cache, which is located in game settings down the bottom of the screen - Note this will remove key binds etc and you will have to reset your graphic settings.

 

Having that checkbox tunred off makes the game look like mincraft...so is still unplayable. i hope you guys can figure out another solution like maybe a slider or options for textures  like load low/med/high/ultra textures cause this all or nothing check box is going to put this games performance demands out of reach for most of the players..and or they might as well play a 15 year old game cause thats what the graphics look like with it unchecked.

:(

look at this...this is not playable

unknown.png

Edited by ♠DEG♠

Share this post


Link to post
Share on other sites

This version runs great for me....better than any other version. Turn of preload textures. I did. Smooth and high FPS. 

Share this post


Link to post
Share on other sites
21 hours ago, Dubs said:

If you are having performance issues, make sure you have Fully Loaded Textures turned off in graphics settings, as that is one of the main performance heavy settings Squad has, if you do not have 4GB+ Vram and 16GB memory.

Also, make sure you have cleared you game cache, which is located in game settings down the bottom of the screen - Note this will remove key binds etc and you will have to reset your graphic settings.

 

 

It was fine in V11, used to get around 70-80 frames having settings between medium and high. Now on V12 I can barely hold 60 on the lowest settings. I meet the requirements you have above but I find it a complete joke that a game that doesn't look as good as current gen games has requirements like that.

 

This game is in bad need of a patch dedicated simply to optimization and bug fixing, every patch doesn't need to have new content.

Share this post


Link to post
Share on other sites
8 hours ago, ♠DEG♠ said:

 

A hotfix was just pushed out with improvement on texture streaming :)
 

32 minutes ago, mectus11 said:

 

It was fine in V11, used to get around 70-80 frames having settings between medium and high. Now on V12 I can barely hold 60 on the lowest settings. I meet the requirements you have above but I find it a complete joke that a game that doesn't look as good as current gen games has requirements like that.

 

This game is in bad need of a patch dedicated simply to optimization and bug fixing, every patch doesn't need to have new content.

Optimization is an on-going thing - every patch there is small optimization done. V12 had 3 or 4 small optimization patches done during public testing. The problem is, you can't do a huge optimization patch if things are constantly being added and changed, as it would require you to go over things you've already optimized.

I'm sure the devs will pump out a hotfix or two sometime soon to help remedy current performance issues.

Share this post


Link to post
Share on other sites
3 hours ago, mectus11 said:

(...)I meet the requirements you have above but I find it a complete joke that a game that doesn't look as good as current gen games has requirements like that.

This game is in bad need of a patch dedicated simply to optimization and bug fixing, every patch doesn't need to have new content.

Some players do have perf and/or textures issues and some don't, some with very good PC  specs have issues and some with average PC specs don't...

 

The game is Alpha, its the 12th version, each one brings new and very good things to the game, and new issues too ; devs just can't manage to fix every problem of every player encountering issues ; most of these are fixed after some hotfixes. Bringing a major trouble-fixing update would just fix problems til the next update.

Just deal with it and enjoy with what you have in your hands yet (and I mean : your Squad game of course, not... something... else :P)

Share this post


Link to post
Share on other sites

Ok so devs actually patched the game now i can play the firing range there are stil problems like it take 2 minute for all the texture to fully load or stuff HOWEVER im stil unable to play multiplayer it just loads 2 infinite actually i wated 1h and i hot bored so i closed the game and went playing r6s . Im really gratefull for the patch BUT its just not enough . Now until v12 gets patched i would rlly like 2 be able to choose between v11 or v12 until v12 gets patched

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×