Jump to content

Recommended Posts

Please Help! Confusingly Low FPS!

 

Specs - (ASUS Zephyrus)

GTX 1080 Max-Q with 16gb Vram

Intel i7-7700HQ 

16gb RAM

M.2 960 EVO 512Gb (The game loads in extremely fast so no issues with the M.2)

 

On low and high (yes both low and high, very confused) settings at 1080p I get around 30 - 40 fps on a full 78 man server and around 60 on the firing range...Using task manager I recorded that my CPU was at 90% - 100% utilisation (so no issues there) but my GPU was at around 30% - 43% utilisation with roughly 4-6Gb of VRAM being used. Is the i7-7700HQ therefore bottlenecking the game? Plenty of other games I play perform considerably better so I'm at a loss of what to do. Is there maybe an issue with the bios? 

 

 

 

Share this post


Link to post
Share on other sites
Posted (edited)

I'd say the FPS seems about right for Squad. It is a laptop. 

Edited by CC-Marley

Share this post


Link to post
Share on other sites
Posted (edited)
33 minutes ago, CC-Marley said:

I'd say the FPS seems about right for Squad. It is a laptop. 

Normally I would agree however I can run PUBG at nearly 100FPS on Ultra, WOT at movie at 140 FPS, BF1 at high at 120 FPS.

It is a powerful and capable laptop, the 1080 Max-Q is 10% less powerful than the 1080 and the i7-7700HQ isn't a poor processor 

 

Edited by not_sanpellegrino
adds

Share this post


Link to post
Share on other sites
Posted (edited)

Yeep your performance is lacking.

 

Clear the game cache, if not that work reinstall the game.

 

Edited by Dundish

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×