Jump to content
booker2121

Performance took at hit after 10 release?

Recommended Posts

I have been playing squad up to version 9. Then i went away and come back. I see a huge performance decrease from version 9. At first i thought it was because i was gaming on a 2060x180 compared to my old 1680x1050. But i just went back to play 1680x1050 with black bars and the game is still doing bad compared to what it was on before 10.

 

Before i was doing ok with all max between 30 - 60fps avg of 45 specially on desert maps.

Now i'm doing 15-60 with avg of 25.

 

My GPU is really old but i'm surprise with the performance difference from version to version.

 

I have a r9 280 16gb and i5 4660 3.2ghz

 

I'm planning on upgrading my GPU since from the performance stats i see it's the bottleneck GPU is in red with 60ms sometimes up to 90ms with 11.2 the game and the other which i don't recall the name are on green with 11ms or so

 

but this does not exlpain why the sudden change on performance.

 

 

 

 

Share this post


Link to post
Share on other sites

V9 was the smoothest running version, performance went downhill after v10. So, your guess is right.

Share this post


Link to post
Share on other sites

Performance always goes down after something major gets changed to the game, and in the patches after it goes up again. This has been the case when vehicles were first introduced too.

Share this post


Link to post
Share on other sites

This is probably the best running version of Squad for me yet, did you try all the usual stuff such as clearing your cache?

Share this post


Link to post
Share on other sites

I did.

no difference.

 

What i noticed that it is having a huge impact now for me is the effects. i'm talking about 10fps difference.

Share this post


Link to post
Share on other sites
22 hours ago, MultiSquid said:

This is probably the best running version of Squad for me yet, did you try all the usual stuff such as clearing your cache?

It's interesting that for some people it's better now, but for others it's the opposite. No use clearing caches and such, he's probably on the same boat as I am.

Share this post


Link to post
Share on other sites

@booker2121
When did you take a break and when did you come back? 

I haven't figured out how to quote a part from another post but read this;

```

  • Did you take a long break from Squad and just came back? Welcome back!

I need to remind you that Unreal Engine 4, in which Squad is designed with, had a major update on September of 2017. If it was before that time you played the last, you MUST do a clean re-install of the game.

```

From 

 

Share this post


Link to post
Share on other sites
On 7/4/2018 at 10:08 PM, samwiseOrigin said:

@booker2121
When did you take a break and when did you come back? 

I haven't figured out how to quote a part from another post but read this;

```

  • Did you take a long break from Squad and just came back? Welcome back!

I need to remind you that Unreal Engine 4, in which Squad is designed with, had a major update on September of 2017. If it was before that time you played the last, you MUST do a clean re-install of the game.

```

From 

 

Really i need to reinstall the game? would an update don't take care of any miss match files?

 

The last version i played that performance was great was on V9. Not sure when this was released. Maybe i played V9.x but never get to V10, that's for sure.

 

Do i need to reinstall the game?

Share this post


Link to post
Share on other sites
Posted (edited)
27 minutes ago, booker2121 said:

Really i need to reinstall the game? would an update don't take care of any miss match files?

 

The last version i played that performance was great was on V9. Not sure when this was released. Maybe i played V9.x but never get to V10, that's for sure.

 

Do i need to reinstall the game?

i think u should only update the game

and clear the cache it will fix the lag.

https://offworldindustries.zendesk.com/hc/en-us/articles/115002768887-How-to-manually-clear-your-user-settings-cache

Edited by =VaSh=

Share this post


Link to post
Share on other sites

i noticed that what is killing my FPS is the Game effects. I turned those from epic to medium and it mad a huhe difference

 

I'm not seeing that big difference graphic wise. so i left it medium and game is playable again similar to what it was on V9 with same settings.

 

Some maps works better than other of course.

 

Share this post


Link to post
Share on other sites

Thanks. I didn't see this thread. This explains it. While i don't have a Nvidia card i'm still seeing this so this is not only related to 1080 cards.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×