Jump to content
Sign in to follow this  
El Duderino

Fix/workaround for MODs no more working in a-11

Recommended Posts

Hey there,

 

if you installed Squad for the first time (for e.g. after a clean Windows installation) and you install a Squad Mod, you may experience that you can't join a server running this mod, but others can. The reason for that is, that the registry key holding the Squad installation path is no longer be created in this location in registry.

 

To fix that (this is a temporary workaround until it gets fixed in Squad), you need to create the "old" registry key manually.

If Squad is installed in the default location

C:\Program Files (x86)\Steam\steamapps\common\Squad

then you just need to download the following reg file, unzip and execute it:

 

Squad_a-11-0_Modding_Hotfix.zip

 

 

If Squad is installed in a different location like

D:\SteamLibrary\steamapps\common\Squad

you need to open the reg-file (right click and choose "Edit") and change the "install_path" from

"install_path"="C:\\Program Files (x86)\\Steam\\steamapps\\common\\Squad"

to

"install_path"="D:\\SteamLibrary\\steamapps\\common\\Squad"

(notice the double backslashes \\ )

so that the file content looks like this:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\OffworldIndustries]

[HKEY_CURRENT_USER\Software\OffworldIndustries\Squad]
"install_path"="D:\\SteamLibrary\\steamapps\\common\\Squad"

Save the file and execute it. Your mods should work fine again!

 

Have fun!

Share this post


Link to post
Share on other sites

Yiiiha!
We are very glad that after many hours of investment you found that bug! Thanks for your fast fix, Dude! 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×