Jump to content
EA_SUCKS

Is there a memory leak in V11?

Recommended Posts

is there a memory leak in A11? Ever since I started playing A11 a few days ago I noticed a problem:

 

it starts using 6gb, then 8gb, then it eats all of my 16gb, it`s so bad I cant get to play unless I restart the game (usually after 1 hour of gaming)

is anyone else having this issue? I ask because I suspect the problem may be in my computer, since I havent played lately A10

Share this post


Link to post
Share on other sites
Posted (edited)

I played for several hours yesterday and it didn't break 54% total ram usage (windows included) of my 16GB over Op First Light, Chlora and a little bit of Mestia. 

 

Edit: I played the v11 pre-release and cleared my cache every time an update came out. 

Edited by Psyrus

Share this post


Link to post
Share on other sites
1 hour ago, EA_SUCKS said:

I just played a lot now and it didnt happen this time... strange

Did you shut down Chrome before playing this time? ;-) 

Share this post


Link to post
Share on other sites

There is a definite memory leak. It eats all 16gb of my ram and then throws an error at me within minutes of playing. Seems to only happen on the servers and not the shooting range. 

It also complains about my gcard memory. Its a 4gb card. Never had a game complain about that.

Share this post


Link to post
Share on other sites
Posted (edited)

i guess i had a similar problem yesterday, after 1 hour of play at 60fps stable the game started to freeze (0-3 fps) and all i could to do was restart the game. (sorry for my bad english)

 

p.s temps were fine and i clear the cache after every patch

Edited by X M.A.S

Share this post


Link to post
Share on other sites
5 hours ago, Major Trouble said:

Did you shut down Chrome before playing this time? ;-) 

no, I dont have chrome installed

 

also, I dont have pre-load textures checked

Share this post


Link to post
Share on other sites

i had a problem with a limited page file. set it to auto and problem went away.

Share this post


Link to post
Share on other sites
Posted (edited)

Same problem here, 16Gb filled then I freed some memory and SQUAD eaten that too. The map was Gorodok, will do more tests.

Edited by El Pube

Share this post


Link to post
Share on other sites

This is from my experience and stories I heard from discord without any devs confirmation 

I have 16G DDR3 
I do not use Pre-load Texture option at all 
I use chrome time to time while in-game (Duh, man gets bored :P )

 

One time I was in a Chora round, all of sudden my frames took a dive from 60ish to 20-25 inconstant up and down with in said range(Stat FPS/Unit was ALL in red), My comm started to break, game lags, my mouse started to slow, My instinct was to open up the task manager and see if  I can force close Squad.exe 

and What do I see? It was using 14 out of 16G RAM when this was happening so.....

Share this post


Link to post
Share on other sites
Posted (edited)

Uninstalling the game and manually removing the "SQUAD" folder and then reinstalling the game solved the problem for me.

Edited by Dundish

Share this post


Link to post
Share on other sites
On 10/05/2018 at 6:08 PM, Dundish said:

Uninstalling the game and manually removing the "SQUAD" folder and then reinstalling the game solved the problem for me.

problem still persists for me, after one or two hours I get the 16gb used...

 

I dont believe I will have to reinstall Squad :(

Share this post


Link to post
Share on other sites
1 hour ago, YuriIsLoveYuriIsLife said:

freezing is happening all the ****ing time, it's pissing me off

+1 same here... never happend before V11. I noticed it in Logar if i make sharp turn or use ADS. It's not tied to any specific region of map.

 

4690k; nvidia 1070 8Gb; RAM 16Gb

Share this post


Link to post
Share on other sites

Same here. No Chrome, no preloads texture. The first  game start ok but slowly eat all my ram, I force closing the game and launch again (without restarting the PC)  and everything is ok. Never had this problem until this summer.

 

Any suggestion ?

Share this post


Link to post
Share on other sites

I used to have it using lots of ram without pre load textures..but was playing with 8gb now 16g ..but have started having freezes for some reason... will need to keep eye on ram use/gpu... 

Share this post


Link to post
Share on other sites
On 14/10/2018 at 7:28 PM, embecmom said:

I used to have it using lots of ram without pre load textures..but was playing with 8gb now 16g ..but have started having freezes for some reason... will need to keep eye on ram use/gpu... 

Afterburner does a great job of graphing your ram usage if you want to keep an eye on it.

 

Do you have a SSD for your OS (page file). Is Squad installed on it? That freezing could be Windows dealing with a memory leak. It'll be more obvious if you're using a slower drive. Background programs like Chrome can also use excessive amounts of ram and are notorious for memory leaks so you might want to eliminate those from your leak hunt.

Share this post


Link to post
Share on other sites
17 hours ago, Major Trouble said:

Afterburner does a great job of graphing your ram usage if you want to keep an eye on it.

 

Do you have a SSD for your OS (page file). Is Squad installed on it? That freezing could be Windows dealing with a memory leak. It'll be more obvious if you're using a slower drive. Background programs like Chrome can also use excessive amounts of ram and are notorious for memory leaks so you might want to eliminate those from your leak hunt.

Chrome drives me nuts for that... and yes using old slow prehistoric drive ... game just stops all of a sudden for about 2 or 3 secs...

Share this post


Link to post
Share on other sites
5 hours ago, embecmom said:

Chrome drives me nuts for that... and yes using old slow prehistoric drive ... game just stops all of a sudden for about 2 or 3 secs...

Do yourself a favour and get a SSD. Use it primarily for your OS but Squad will get significant benefits if you install it on the drive as well. It won't cure memory leaks but it will certainly reduce their impact on your PCs performance.

Share this post


Link to post
Share on other sites

i was in my loft the other day and spotted a stack of WD raptor drives I used to have in RAID to get better hdd performance. 10000rpm used to be important :)

 

SSD should be a requirement. It is the most noticeable upgrade you could make to your pc, just do it, 500gb is plenty, the other junk can go on your old slow drives.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×