Jump to content
Fredo

Low FPS after 2 - 3 minutes

Recommended Posts

Posted (edited)

Hello,

 

i just bought squad. The game is very funny, but its unplayable for me. When the round starts, i got 80-90 fps on the maximum settings. After a couple of minutes it starts to get lower and lower.. like 30-40 fps..

 

My Computer:

Windows 10 Pro Activated

Intel Core i7-7700 3,6ghz(Boost 4,20 ghz)

Nvidia gtx 1060 6gb

16gigs of ram (2400mhz)

 

If i lower the graphic settings i don't get more fps, so yeah.. temperature is ok, between 50 and 60..

 

I also tried to google, i did everything what i found, nothing has helped me. 

 

I'm running the newest drivers.

 

//Edit

Games like PUBG runs just perfect..

 

I already tried to clear my user cache. Just installed Squad today.

Edited by Fredo

Share this post


Link to post
Share on other sites

Some of the players also suffer similar issues that you are describing but nothing has confirmed as of yet so I am not able to assist you further other than giving you basic trouble shooting guide 

 

Please do the following;

use DDU(Display Driver Uninstaller) to do a clean install of your graphic drivers 

      - One of the fall creator updates provided by Window 10 has force-downloaded display driver on top of your GPU in which preventing your 1060 to run as proper as it should. 

 

 

Share this post


Link to post
Share on other sites
1 hour ago, samwiseOrigin said:

Some of the players also suffer similar issues that you are describing but nothing has confirmed as of yet so I am not able to assist you further other than giving you basic trouble shooting guide 

 

Please do the following;

use DDU(Display Driver Uninstaller) to do a clean install of your graphic drivers 

      - One of the fall creator updates provided by Window 10 has force-downloaded display driver on top of your GPU in which preventing your 1060 to run as proper as it should. 

 

 

Hello, thanks for your reply. 

 

Its a new PC, its nearly 2 weeks old. The drivers are fresh installed.

 

I changed this in my pc options: 4vsWKl.png

 

And played one full round and i have 70-100 fps now.

 

Maybe its because the server wasn't full of players, maybe its because i changed it. 

 

Before i changed it, the current setting was: fS9Fy4.png

But i have an i7 7700.. so yeah.

 

I will update the post tomorrow when i played a round with 80 people.

 

 

Share this post


Link to post
Share on other sites

No, i still have low fps after a couple of minutes.

 

What the **** guys? Why you sell a game like this.. the gameplay and teamplay is amazing.. why don't you fix it? I've seen many threads from users with the same problem.. i even tried ddu..

Share this post


Link to post
Share on other sites
39 minutes ago, Jasonb said:

I've got the same issue: 

 

Yeah.. you can find many threads and users with these problems, when the round starts, i have 70-100 fps, great feeling, but then it drops to 30-40, its not really good. It feels scetchy..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×