Jump to content
demonstratus

EAC Security Violation Detection

Recommended Posts

Hello, 

I've played Squad quite regularly almost 2-4 hours a day and stream quite frequently with the game. I was shocked after a weekend away from home I tried to play this evening and was met with: https://imgur.com/a/LzYlY

"Squad.exe - Fatal Application Exit
Game Security Violation Detected (#0000000D)"

After reading various other forums, tips and suggestions this is what I have tried, restarts were performed after each;


Uninstalled EAC

Verified the Game Cache
Reinstalled EAC
Uninstalled Squad
Cleared app data
Uninstalled Antivirus software (Malwarebytes, if it matters)
Reinstalled Squad
Reverified Game Cache
Stopped all programs from launching on start up outside of my Gigabyte App Center / RGB Fusion (RGB had an update this weekend) and Sennheiser Audio center.
Deactivated Firewall

In the JoinSquad FAQ it states to make sure there is no CheatEngine software installed, which there is not. From what I see this has been an increasingly growing problem. Windows and nVidia are checked for updates daily same with all other hardware/software.

PC Specs are:
Windows 10 Home 64
AMD Ryzen 7 1800X
NVIDIA GeForce GTX 1060 6GB
16GB Trident Z 3200
Gigabyte X370 K7 Gaming

If I can get any backup on this issue that doesn't involve me having to reformat a PC for one game that would be pretty sweet.

Thanks ahead of time.

 

 




 


Share this post


Link to post
Share on other sites

For any of those that share this problem if you have ANYTHING such as an RGB Mouse, Pad, Keyboard, RGB Fusion, Gigabyte K Series motherboards you CANNOT run the RGB functions of any of these while Squad is in operation.

 

I don't know why. I deactivated my RGB Fusion and LEDs on my devices and I was able to run Squad. This is the by far the dumbest thing I've had to deal with to play a game. I made sure this was specifically the issue by deactivating RGB Fusion (motherboard, ram and peripherals are all listed within client) and attempted to run Squad.

It worked!

Afterwards I attempted to reactivate all RGB functions and received the same error narrowing it down to that.

Please Offworld, get this fixed.

Share this post


Link to post
Share on other sites

Like you, actually created an acct just for this...hard to have a meaningful contribution to a game I cannot play.

 

Like you, I'm pretty positive it's an RGB controller that hasn't been whitelisted by Easy Anti-Play.  Unlike you, I can't figure out which exactly it is to end the process.  Sure as Hell not disabling Synapse and thus my Orbweaver and keyboard.  

 

If you can believe it, this is the response I got from EAC "support"....can't tell if being serious or trolling me?  Kill everything but Windows programs...no kidding, eh?  I didn't buy a Threadripper so I have to neuter my machine to play a game.  Just stupid.

 

Quote

Hello Eric,

Thank you for contacting us!
Sorry to hear you\re having issue running the game. Game Security Violation errors are usually caused by unnecessary programs running in the background. To fix this please start by installing the latest Windows updates. Then perform a 'cold reboot' by running the following command in the command-line as administrator:
shutdown /r /f /t 0

After the restart proceed to close all programs not related to Windows and launch the game again. It should run without issues after that.

Have a great day and enjoy your game!

 

Gonna give it another week and see, I responded to their email.  If I can't get a useful answer, I guess I'll just get a refund.  Crying shame EAC isn't half as good at stopping cheaters as it is at blocking legit users!

Share this post


Link to post
Share on other sites

Found a work-around for Gigabyte users:

 

SamWise, myself, and another person named Moosieus in the SquadOps Discord beat our heads against it for a while, Moosieus found most of the answers.  While it isn't all-inclusive, I can point you directly at ONE program EAC code is freaking out about.

 
Gigabyte Aorus RGB FUSION software (the RGB controller for Gigabyte hardware in their APPS program).  The exact potential processes are:  
 
GvLedServices.exe
SelLedV2.exe
RunLed.exe
 
Of those 3, only SelLedV2.exe was running on my machine (Gigabyte X399 Aorus Gaming 7), might or might not be HW specific...I don't have an answer.  Ending that process got me directly into the game.  I did not have time to play further and insure no other errors popped up, I have to go to bed.  I can/will do so on Thursday when I can play games again and update this thread, if you like.

Share this post


Link to post
Share on other sites

Gonna necro this thread, i got a new pc, motherboard uses Asus Aura, also to control RGB lighting for my case, in my case it was Lightingservice.exe that caused me to get a Security Violation error from EAC. This should be added to EAC as a safe file! Now i gotta deactivate the RGB all together to even start the game.

Share this post


Link to post
Share on other sites

EAC still flipping on SelLedV2.exe

Updated my Gigabyte RGB Fusion softwares last week and suddenly I couldn't launch Squad

Share this post


Link to post
Share on other sites
4 hours ago, Boldtaar said:

EAC still flipping on SelLedV2.exe

it's known. Need to wait for EAC to get their end straight about this, for now just disable any RGB related process and you should be fine. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×