Jump to content
Bushdoctor

V10 FPS drops, poor performance.

Recommended Posts

Posted (edited)

Hello! 

 

I would like to know if there is anyone that knows of any config related fixes applicable to the game.

 

Pre v10 patch i used to roll steady 60-85 fps, never had any issues and the gameplay was buttery smooth

at everything maxed out, the only thing i removed where shadows and bloom etc.

 

Pre v10 i had around 140-170 fps at jensens range, now i range from 60-85...

 

I have a Intel CPU and a AMD graphics card.

 

Squad was my favorite game and i have around 300 hours, now im currently not playing it due to the low fps,

im rocking 30-55 fps and for me that lags way to much, it just takes the enjoyment out of the at times fast paced combat.

 

Im also not planning to buy a new pc any time soon.

 

Any help is appreciated.

Edited by Bushdoctor

Share this post


Link to post
Share on other sites

Have the same issue, I've tried everything like control panel tweaks, power plan, etc. 45-70 fps on full server after v10. 

I5 7500, gtx 970, 16 gb 2400hz ram, hdd.

Share this post


Link to post
Share on other sites

Hello @Bushdoctor

 

5 hours ago, Bushdoctor said:

I have a Intel CPU and a AMD graphics card.

Please specify your CPU & GPU so that I can analyse further 

 

5 hours ago, Bushdoctor said:

Pre v10 i had around 140-170 fps at jensens range, now i range from 60-85...

Please note that Firing Range is locally hosted, thus are not a perfect set-up to 'check' the performance 
I would like to advise you to check the Frames and Stat unit While in a server

 

I will leave a basic trouble shooting guide for your reference 

Please refer to this post 

 

 

Share this post


Link to post
Share on other sites
Posted (edited)

OS: Windows 10 (last version)

CPU:  Intel I-5 7500 stock

GPU: MSI GTX 970 4GB stock (last driver version, clean install)

RAM: 4x4 Corsair LPX 2400 hz 4 GB (page file size set to automatic).

 

When I use 'stat unit' console command it shows 15-17 GPU time even on Fire range, however gtx 970 is in recommended system requirements.

When I play on a full server i get 45-70 fps, average 56 with drops to even 30 sometimes and it kills all fun :(

Also changing everything to low doesn't make any significant performance boost.

I hope things will change in future, because I love this game so much =)

 

 

Edited by Slon

Share this post


Link to post
Share on other sites
12 hours ago, Slon said:

When I use 'stat unit' console command it shows 15-17 GPU time even on Fire range

Please check your Stat Unit data in a populated server, please take a couple of screenshots for me 

Share this post


Link to post
Share on other sites
Posted (edited)
10 hours ago, samwiseOrigin said:

Please check your Stat Unit data in a populated server, please take a couple of screenshots for me 

Thank you for responding! I've captured some screenshots. Server population was about 70, couldn't find more populated server at morning, when I had time. First one was captured on a fire range for comparison.

Spoiler

FZs0AKQ.jpgRPDk61s.jpgvtCQLQE.jpgH5cMRgZ.jpg

 

Edited by Slon

Share this post


Link to post
Share on other sites
Posted (edited)
On 2018-03-11 at 8:08 PM, Slon said:

Have the same issue, I've tried everything like control panel tweaks, power plan, etc. 45-70 fps on full server after v10. 

I5 7500, gtx 970, 16 gb 2400hz ram, hdd.

This is a optimisation issue, i even used a very performance hogging reshade preset that took off atleast 15 fps and i still maintained over 60 fps. 

 

I doubt any new updates will solve anything like this soon, squad is turning dangerously close to the low performance of ARMA games, i logged 1900 hours in A3 and even more in A2, i doubt i will have the same tenacity for squad, even though i love the game.

 

We have roughly the same specs, i have a better graphics card though, and my processor is clocked at 4.5 ghz, it seems like they claim that you would need a better pc to run squad at a fluid framerate which is bogus, the new additions and the animation system just wrecked the performance.

Edited by Bushdoctor

Share this post


Link to post
Share on other sites

@Bushdoctor

Please note that I need your full specs for analysis. After all, you opened the topic 

 

18 minutes ago, Bushdoctor said:

it seems like they claim that you would need a better pc to run squad at a fluid framerate which is bogus

No. As I see it personally, optimization patch will take a good effect on @Slon's case. His/her rigs are well above minimum requirement 

Share this post


Link to post
Share on other sites

Thanks! I'm looking forward to this patch now and hope It will make the game run at stable 60 fps  on my rig (I'm playing on a 60 Hz TV anyway).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×