Jump to content
UKEF-JD

Unofficial SLI configuration for Squad

Recommended Posts

UPDATE:

 

If you are experiencing frequent crashes with the current build and have shadows on epic, change the setting to high. I have experienced consistent crashes with shadows on epic in the new build.

 

 

 

 

 

 

Edit:

 

Ok SLI friends.

 

I have SLI working on the current build following Litoralis's reply.

 

 

Make the following changes in Nvidia Inspector:

 

1) Create a New Profile for Squad

2) Add the application from this path: Squad\Squad-7-23\Squad\Squad\Binaries\Win64\Squad.exe

3) Change Sli Bits Compatibility DX1x: 0x080222F5 (Batman: Arkham Origins)

4) Change Number of GPUs to use on SLI rendering mode to however many cards you have.

5) Apply

 

 

As far as performance goes.. 

 

All settings on EPIC at 1920x1080 resolution I am getting a consistant 70-130fps in Logar offline opposed to my previous 40-70 fps with shadows on medium and 20-30 with shadows on EPIC. 

GPU usage is good. Constantly hovering around 97% to 99% load.

 

 

Notes:

 

Do not change the graphics options after loading into the world. Doing so gives me shadow flickering and crashes almost every time. Change them in the main menu and then load the world again to test.

 

Anti-aliasing on Epic has worked fine for me so far.

 

My system Specs:

 

4790k @4.8ghz

ASUS Maximus Forumla VII

2x Zotac GTX580 3gb 

32Gb 2133mhz G-Skill Ripjaw 

Windows 8.1

Latest Nvidia Drivers

 

Squad installed on ASUS RaidR PCI-e SSD

 

Stability so far I haven't had any issues on stock cpu/gpu/ram clocks or overclocked. I'm not seeing any visual artifacts from shadows or any sort of texture glitching and I have been running this config for around 2 hours now. 

Though it is very early in testing and different system configurations will respond differently, Squad is using SLI stable and without visual error.

 

 

IF YOU EXPERIMENT MAKE SURE YOU BACK UP AND/OR WRITE DOWN YOUR ORIGINAL SETTINGS.

 

THIS IS NOT SUPPORTED BY THE SQUAD DEV TEAM.

Share this post


Link to post
Share on other sites

We have NOT tested this much.

 

If you're in the Closed Pre-Alpha and have SLI GPUs, maybe you can make a thyread and we can try out use cases together:

 

How to get SLI to work in Ark: Evolved (also on Unreal Engine 4 and about same stage of development)

 

MugHug iconGames.png Jun 12 @ 12:18am 

Simple article from PC Gamer.
http://www.pcgamer.com/could-directx-12-or-vulkan-apis-make-slicrossfire-obsolete/

and this
http://wccftech.com/directx-12-multiadapter-technology-discrete-integrated-gpus-work-coherently-demo-shows-big-performance-gains/

'DirectX 12 will hold the fastest adoption rate since DirectX 9 and will have games developed by several developers on game engines that include Unreal 4, Unity 5, CryEngine 3 and Microsoft’s own game studios'

If correct there will be no need for XFire or SLI in DirectX 12. And any combination of AMD, Intel and Nvidia be them intergrated or dedicated can be used together by DX12.

 

 

 

 

[Fix] Make SLI working

This game is an Unreal Engine 4 Game using DX11.
 
With Nvidia Inspector:
 
Creater a new profile:
add the executable to the profile
use Sli Bits Compatibility DX1x: 0x080222F5 (Batman: Arkham Origins)
Set the numbers of your GPU.
 
Dont Use AFR2
Dont Use the Antialiasing on EPIC, the game crash.
 
My 4 GPUs works but thats not optimised maybe another Sli Bits for a better GPUs scalling.

 

 

So DX12 is making SLI/Xfire obsolete because it's not going to be doing AFR anymore, so it doesn't matter how many GPUs you have. That has nothing to do with UE4 not natively supporting them, the UE4 devs have said more than once but here's one time: https://answers.unrealengine.com/questions/21746/does-the-ue4-engine-support-sli.html that UE4's rendering just doesn't work for AFR. Which was my entire point.

 

 

Source:

http://steamcommunity.com/app/346110/discussions/0/594820656449314774/

http://steamcommunity.com/app/346110/discussions/0/615086038667040715/

 

IF YOU EXPERIMENT MAKE SURE YOU BACK UP AND?OR WRITE DOWN YOUR ORIGINAL SETTINGS.

 

THIS IS NOT SUPPORTED BY THE SQUAD DEV TEAM.

 

I'm just curious to see if we can pull off same tricks that work for Ark: Evolved.

Share this post


Link to post
Share on other sites

We have NOT tested this much.

 

If you're in the Closed Pre-Alpha and have SLI GPUs, maybe you can make a thyread and we can try out use cases together:

 

How to get SLI to work in Ark: Evolved (also on Unreal Engine 4 and about same stage of development)

 

 

 

 

Source:

http://steamcommunity.com/app/346110/discussions/0/594820656449314774/

http://steamcommunity.com/app/346110/discussions/0/615086038667040715/

 

IF YOU EXPERIMENT MAKE SURE YOU BACK UP AND?OR WRITE DOWN YOUR ORIGINAL SETTINGS.

 

THIS IS NOT SUPPORTED BY THE SQUAD DEV TEAM.

 

I'm just curious to see if we can pull off same tricks that work for Ark: Evolved.

 

Thanks for the reply Litoralis.

 

I'll play around with the profiling somewhat and see if i can get something stable. So far I have had both GPU's active but frequently crashing. Will report back later.

 

Cheers again

Share this post


Link to post
Share on other sites

Ok SLI friends.

 

I have SLI working on the current build following Litoralis's reply.

 

 

Make the following changes in Nvidia Inspector:

 

1) Create a New Profile for Squad

2) Add the application from this path: Squad\Squad-7-23\Squad\Squad\Binaries\Win64\Squad.exe

3) Change Sli Bits Compatibility DX1x: 0x080222F5 (Batman: Arkham Origins)

4) Change Number of GPUs to use on SLI rendering mode to however many cards you have.

5) Apply

 

 

As far as performance goes.. 

 

All settings on EPIC at 1920x1080 resolution I am getting a consistant 70-130fps in Logar offline opposed to my previous 40-70 fps with shadows on medium and 20-30 with shadows on EPIC. 

GPU usage is good. Constantly hovering around 97% to 99% load.

 

 

Notes:

 

Do not change the graphics options after loading into the world. Doing so gives me shadow flickering and crashes almost every time. Change them in the main menu and then load the world again to test.

 

Anti-aliasing on Epic has worked fine for me so far.

 

My system Specs:

 

4790k @4.8ghz

ASUS Maximus Forumla VII

2x Zotac GTX580 3gb 

32Gb 2133mhz G-Skill Ripjaw 

Windows 8.1

Latest Nvidia Drivers

 

Squad installed on ASUS RaidR PCI-e SSD

 

Stability so far I haven't had any issues on stock cpu/gpu/ram clocks or overclocked. I'm not seeing any visual artifacts from shadows or any sort of texture glitching and I have been running this config for around 2 hours now. 

Though it is very early in testing and different system configurations will respond differently, Squad is using SLI stable and without visual error.

 

 

IF YOU EXPERIMENT MAKE SURE YOU BACK UP AND/OR WRITE DOWN YOUR ORIGINAL SETTINGS.

 

THIS IS NOT SUPPORTED BY THE SQUAD DEV TEAM.

Share this post


Link to post
Share on other sites

I'll be keeping my eye on this. I've got four GTX 780s between two systems and I'm really tempted to build a 3-way or 4-way rig to test some things.

 

This should probably be in the Tech sub forum Lito. :)

Share this post


Link to post
Share on other sites

Tried this with my 2x 970 GTX, worked fine on the "deploy now" test map. Near perfect SLI scaling, both in utilization and framerate. All settings at Epic.

 

I only did the SLI compat bits though, and left the GPU count, SLI scaling mode etc to default values.

 

I did notice the occasional shadow flicker, but I haven't "played" the test map enough to say if that's SLI related or not.

 

Will report back in next weekend if it works in MP as well.

Share this post


Link to post
Share on other sites

I was able to play all last night between the virgina server and the sydney server without a crash. Playtime was about 5-6 hours. 

Share this post


Link to post
Share on other sites

I tested this on my GTX690 worked like a charm. I went from everything on low and resolution scaling down to 50 with just barely playable. NOW I get between 70 and 120 FPS on extreme with resolution scalling on 100. :D

Share this post


Link to post
Share on other sites

I'm experiencing the occasional flicker on the test map ("deploy now"), and I recorded this using ShadowPlay. It seems one frame is suddenly rendered without the sun light. Here are two consecutive frames:

 

https://dl.dropboxusercontent.com/u/64660590/Squad%2007.27.2015%20-%2022.18.18.24.mp4_snapshot_01.21_%5B2015.07.27_22.30.15%5D.png

https://dl.dropboxusercontent.com/u/64660590/Squad%2007.27.2015%20-%2022.18.18.24.mp4_snapshot_01.21_%5B2015.07.27_22.30.22%5D.png

 

This seems to happen at most once every few minutes, so not an annoyance. I can't recall getting this before enabling SLI, though I'm not 100% certain about this.

Share this post


Link to post
Share on other sites

I'm experiencing the occasional flicker on the test map ("deploy now"), and I recorded this using ShadowPlay. It seems one frame is suddenly rendered without the sun light. Here are two consecutive frames:

 

https://dl.dropboxusercontent.com/u/64660590/Squad%2007.27.2015%20-%2022.18.18.24.mp4_snapshot_01.21_%5B2015.07.27_22.30.15%5D.png

https://dl.dropboxusercontent.com/u/64660590/Squad%2007.27.2015%20-%2022.18.18.24.mp4_snapshot_01.21_%5B2015.07.27_22.30.22%5D.png

 

This seems to happen at most once every few minutes, so not an annoyance. I can't recall getting this before enabling SLI, though I'm not 100% certain about this.

 

Post you system specs Crc

Share this post


Link to post
Share on other sites

Sure:

 

i7 4770k

Asus Z87-Pro

2x MSI GTX 970 GAMING 4G

32GB RAM

SSD

Windows 8.1 x64

 

I just remembered I didn't upgrade to the latest drivers, still running 353.30. I'll try updating when I get home.

 

edit: updated to latest drivers (353.62), and I still get the same flickering.

Share this post


Link to post
Share on other sites

I tested this on my GTX690 worked like a charm. I went from everything on low and resolution scaling down to 50 with just barely playable. NOW I get between 70 and 120 FPS on extreme with resolution scalling on 100. :D

Whats your cpu?

Share this post


Link to post
Share on other sites

WOW! Thx to "Litoralis" who informed me on this topic!

Will certainly do some testing with my GTX 580 SLI setup this weekend! 

Share this post


Link to post
Share on other sites

WOW! Thx to "Litoralis" who informed me on this topic!

Will certainly do some testing with my GTX 580 SLI setup this weekend! 

Me to :)

Share this post


Link to post
Share on other sites

Did you guys test in a 40 or 50 player server because with more players the cpu will bring down your fps so it doesent matter if you have sli on.

Should test it with a empty and a full server.

Share this post


Link to post
Share on other sites

Tried it and seems to spread the load between GPUs, making my top card run cooler.

 

Did see some performance gains with few players around / not much going on. As soon as the action starts, it's the CPU taking the beating and the FPS drops either way. 

 

As mentioned, changing settings will make textures flash. However, it also crashes the game if you leave it like that for a minute or two with a 'driver crashed' error from the game. 

Share this post


Link to post
Share on other sites
 

Did you guys test in a 40 or 50 player server because with more players the cpu will bring down your fps so it doesent matter if you have sli on.

Should test it with a empty and a full server.

 

 

You wont see much benefit if your cpu is a massive bottleneck

Share this post


Link to post
Share on other sites

For some reason my load is not moving over to my second GPU :( I did every step using nvidia inspector. Any help?

Share this post


Link to post
Share on other sites

For some reason my load is not moving over to my second GPU :( I did every step using nvidia inspector. Any help?

 

 

 

 

Check hat SLI is enabled in the nvidia control panel

Share this post


Link to post
Share on other sites

For some reason my load is not moving over to my second GPU :( I did every step using nvidia inspector. Any help?

 

Try posting some screenshots of your Nvidia inspector window. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×