Jump to content
Sgt_Dogface

Can't Bind Vehicle Turret Zoom To RMB

Recommended Posts

I would really like my RMB to be the "zoom" key for my weapon while gunning in vehicles but for some reason it wont let me bind that key to that function. Is there a reason why & if not could anything be done to make this possible ?

Share this post


Link to post
Share on other sites

I think it's just a bug...mildly annoying as it would be comfortable to mimic the infantry behaviour of using RMB for sights/optics. Hope they fix it. 

Share this post


Link to post
Share on other sites

Use your mouse macro to change hotkey, you can bypass with logitech and most other brands.

 

But i feel you )

Share this post


Link to post
Share on other sites
Posted (edited)

In the Settings/Controls/General section of the dashboard there is the "Zoom/Alt Use" key. This is the default key to ADS or utilize your rifle scope if you have one. As long as your RMB is mapped as the primary key for this function you can not map another key as the alternative key for this function. Additionally in the Settings/Controls/Vehicle section of the dashboard there is the "Turret Optic Zoom" key. If you map your RMB as the primary key for this function then try to map your "Q" key as the alternative key for this function it automatically swaps the two. There is obviously some sort of conflict going on here between infantry controls & vehicle controls which prevents you from mapping your RMB as your "Turret Optic Zoom" key. This is extremely frustrating for not only me but several other players I've talked to who want our RMB to be our zoom key when gunning in vehicles. Obviously this isn't a high priority bug but it seems that it should be a fairly simple fix for whichever dev is in charge of key mapping but I don't know. Is this not the case ? Is there some reason we can't get this fixed in one of the updates ?

Edited by Sgt_Dogface

Share this post


Link to post
Share on other sites

How about if you edit the .ini file that lists the controls? I can't experiment for you as I am not anywhere near my gaming pc. If it does work a downside would be you'd need to edit your .ini every update. 

Share this post


Link to post
Share on other sites
On 2/10/2018 at 1:22 AM, Voice said:

Use your mouse macro to change hotkey, you can bypass with logitech and most other brands.

 

But i feel you )

Yeah, that's what I did. I use the same key as Sprint on my mouse, works great. 

 

I do hope in the future, we will have much more freedom in setting up binds

Share this post


Link to post
Share on other sites
On 3/19/2018 at 9:41 AM, LugNut said:

Yeah, that's what I did. I use the same key as Sprint on my mouse, works great. 

 

I do hope in the future, we will have much more freedom in setting up binds

Ya I figured since I didn't know what .ini files were then I probably shouldn't be altering them & I've never used macros before. My son used them in World of Warcraft & that was enough to keep me away from them lol. I'll take a quick youtube macro lesson & try to bind one of my mouse keys like you suggested. Question: so using the macro method should I be able to bind it to my RMB like I wanted or will it only work on the other "non-conflicting" mouse buttons ?

Share this post


Link to post
Share on other sites

On a similar topic, it used to be possible to bind weapon ranging on mouse wheel(click) in V10.0 and now it isn't because logic*. Please fix
*input logic is all sortof ****ed in 0.1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×