Jump to content
[7cav]Dusty

[Solved] High latency constantly.

Recommended Posts

Hey there,

Ever since the last update I have been suffering from high pings/rubber banding. It will periodically fall to 40 for one minute then shoot up to 500-600 and idle around there for a few minutes before falling again. This happens no matter what server I join. I am from the UK and it happens on uk servers, too.

 

http://beta.speedtest.net/result/6816996792.png

 

My internet connection is not the problem. It is wired to my PC with a cat6a cable. I routinely reset my router and what have you. I clean my pc a couple of times a week. I have zero ping issues in any other game I play. Just seems to be Squad. I have also cleaned game cache data as well Is this a known thing? Can anyone give me any clues on how to fix this annoyance? I just want to play the game x) . 

Share this post


Link to post
Share on other sites

Can I ask you where you are playing and what server you usually play in?

Also refer to 

Also make sure your Windows updates are up-to-date

Edited by samwiseOrigin

Share this post


Link to post
Share on other sites

If you ping the servers through your windows command prompt (using the -t flag if possible) does it also have those big ping spikes?

Share this post


Link to post
Share on other sites
6 hours ago, samwiseOrigin said:

Can I ask you where you are playing and what server you usually play in?

Also refer to 

Also make sure your Windows updates are up-to-date

 I am in the UK, I play on UK servers mostly. I ping the server I usually play on through cmd prompt and got 17ms average. But when in game it goes all the way up to 500. So, the internet locations are fine and what have you. i live quite close to where they house a lot of uk servers. PC is up to date. The problem arouse straight after the recent updates. It was fine before that.

 

6 hours ago, Psyrus said:

If you ping the servers through your windows command prompt (using the -t flag if possible) does it also have those big ping spikes?

Just tried it on 164.132.200.153 for 15 minutes (QFF's server - my regular server) minimum 10, max 32, average 17. No spikes. 

Share this post


Link to post
Share on other sites

I've also been experiencing this on some EU servers but not others...

Share this post


Link to post
Share on other sites
16 minutes ago, Grugbug said:

I'd try a router reset and see what happens.

 

tried it this morning - no change. Only squad gives me rubbing banding and high ping.

Share this post


Link to post
Share on other sites
3 hours ago, samwiseOrigin said:

Just tried it on 164.132.200.153 for 15 minutes (QFF's server - my regular server) minimum 10, max 32, average 17. No spikes. 

Did you run this in the background while playing squad, or independent of playing squad? I would suggest running it in the background while playing squad, and alt-tabbing to the ping cmd while your in-game ping is showing high values. 

 

The reason I ask is because I'm trying to figure out if it's one of the following:

- Squad packets are being de-prioritized by your router or ISP

- Your ping to the servers really does go up, regardless of protocol, when playing squad. 

 

The reason it is confusing is that it's not consistent, your ping sits how it should be (40ms) for a little while, then shoots up to 400+ms randomly, as you said. Normally this behavior can be seen in basically just one case:

- Network saturation

 

What that means is that either on your upstream or downstream, the number of required data packets exceeds the bandwidth available, so they get queued, which obviously increases the latency because packets are now waiting as well as traveling to the server and back. This behavior can be demonstrated by seeding a very popular torrent at which point all your upstream bandwidth is used, if you jump into those other games that don't usually have ping problems, you should see pings double to ten times your usual ping. 

Share this post


Link to post
Share on other sites

I was lead to this tool: Leatrix Latency Fix

 

Straight from their "About" section: "Leatrix Latency Fix will reduce your online gaming latency significantly by increasing the frequency of TCP acknowledgements sent to the game server. For the technically minded, this is a program which will modify TCPAckFrequency. 

You will see reduced latency in many online games including World of Warcraft, WildStar, Heroes of the Storm, Elder Scrolls Online, Guild Wars 2, Diablo 3, Star Wars: The Old Republic, Rift and more."

 

my ping has been reduced to 30-45 but spikes up to 150 on a full uk server for squad. No spikes what so ever in any other game I play. Even MMOs.

 

I believe it was just the router etc de-prioritising packets. This newly acquired program seems to have fixed it for the most part. Still get the odd rubber banding. But not as much as it was.

 

 

Share this post


Link to post
Share on other sites

Whilst the previous thing I stated lowered my ping. It still felt a little laggy. so I changed the DNS server of my pc to google as opposed to the default "automatic" 

 

Google DNS Settings  <-- Link

 

This made everything quite a bit more speedy as one could imagine. Also smoothed out the rubber banding. To which, I was left with tiny micro stuttering. There is always something that likes to crop up. For this I noticed whilst I use my usb headset with it's own software, it was competing against the on board sound software (Which I thought I had fully disabled, but it was playing up). So, completely disabled that in favour of my headset. And I tweaked the max audio channels for squad and everything, finally, is lag and stutter free.

 

Phew.

 

 

Share this post


Link to post
Share on other sites
Glad to hear you fixed the issue(s).
And thank you for sharing the solution with us.
 
If you need this thread unlocked, PM a Moderator.
 
/locked

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×