Jump to content
dor

Ping on servers list is 80+, while in-game it's ~130

Recommended Posts

Lies!

 

I blame my ISP. BT in the UK is built from straw and run by a team which is 90% middle management and 10% low paid call centre staff.

Share this post


Link to post
Share on other sites

The difference is due to the menu taking a simple ping (ICMP?) to the servers on the list returned by the master server, however in-game your ping is calculated on a per-frame basis (or something like that) which means that as the server load gets higher and the server FPS drops, the calculations end up taking longer (due to the lower amount per second) and thus the reported ping is higher. 

 

I used to have a bookmarked source for this from I think IronTaxi, but I can't find it anymore so I may have got some of the details wrong. 

 

Think of it like:

- Menu ping = simple packets' back and forth time

- Game ping = packets' back and forth time plus the server's internal processing latency

Share this post


Link to post
Share on other sites

Sorry for kicking thy dead horse.  So in theory the better the server hardware, the better/lower latency correct?

Share this post


Link to post
Share on other sites
Posted (edited)

Try to play regionally solves a lot of issues. Sometimes your fave server is on the other side of the country, but SQUAD is also  about community , so the ping becomes secondary

Edited by Shaldag

Share this post


Link to post
Share on other sites

@dor have you improved this? mine still sucks and i think mine is more effected when server performance drops.

eg everyones ping doubles, so i go from 70-150 to 140-300 while they get just go from 60 -120.

 

ping -t to the server ip is always stable at 60 or 70 even while playing. Ping to other games is also stable. 

Ping to squad is very unstable and I really want a solution.

 

 

Share this post


Link to post
Share on other sites

I only play on Chicago and New york servers and i can't get anything under 120.  Which is weird since I'm closer to Chicago (70ms+/-),  than I am to New York (50ms+/-).  Could it be my ISP routes through Antarctica and therefore I suffer lol?

Share this post


Link to post
Share on other sites

ive just installed on a new laptop with some nice specs and my ping is the same. Seems to be network related but I would love some clever person to tell me what I can change.

I am open to anything up to burning the local exchange to get it replaced. Perhaps there are some settings I can change instead :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×