Jump to content
IronMole

Will Squad run with SweetFX?

Recommended Posts

Your settings are just... wow :blink: but lil FPS hungry.

My fav one atm, TY !

 

Really?  only costs me 3 fps.

Share this post


Link to post
Share on other sites

With the proper settings, SweetFX enhances the visuals with a minimal drop in performance. It is in my opinion that everyone should give it a try. I don't run the game without it

Share this post


Link to post
Share on other sites

Tommy's preset is very taxing on foal roads  (at least 10fps loss) contrary to Kohat (less  4 fps loss). I will try to disable HDR in the SweetFX cfg file.

I still use Tommy's preset with less saturation.

Thanks for sharing !

Share this post


Link to post
Share on other sites

Really? only costs me 3 fps.

Looks great with your settings.

Best one so far in that regard.

But it is taxing for me, lose 5-10 FPS.

Great to be able to play with sweet fx again :)

Thanks fellas

Share this post


Link to post
Share on other sites

Honestly, I was afraid to loose FPS with Tommy's settings (saw a loss of at least 10 FPS on Firing Range) but actually tried it on Fool's Road which the most demanding map for me and switching ON/OFF SweetFX didnt change anything to my global FPS... Of course disabling it will be LITTLE smoother but its not worth the loss of sharpness, especially on Fools' Road !! Played a complete round on Fool's last night on the (full) 100 players test server and had at least 38-40 FPS all the time (1x R9 280X, settings Epic / High except Shadows on med).

Share this post


Link to post
Share on other sites
30 minutes ago, Nightstalker21 said:

Looks like SweetFX makes Squad V.5 unplayable, asks to delete files added at launch of Squad :(

Anyone reporting the same ? Any solution ?

TY

I tried this since two days and while it costs me too much fps, it does work with squad V5:

 

Share this post


Link to post
Share on other sites

Tells me to delete opengl32.dll ; did it and then Squad launches, but looks more laggy than usual, maybe because I deleted this file ? To sum it up, it works, but maybe not at 100%...

Share this post


Link to post
Share on other sites

Delete all those files, and start fresh with this
 

Just extract to the Squad/Squad/Binaries/Win64 folder as is, and start the game. Tell me if it works. Scroll lock to toggle it on/off.

Share this post


Link to post
Share on other sites

so... I just downloaded it, and it seems to work.. well i dont know if it works... because I see no difference what so ever, in frames, resolution, brightness or nothing..

i can turn it off and on on scrnlck and it has the startup page when i run squad..

can i be doing anything wrong?

Share this post


Link to post
Share on other sites

so... I just downloaded it, and it seems to work.. well i dont know if it works... because I see no difference what so ever, in frames, resolution, brightness or nothing..

i can turn it off and on on scrnlck and it has the startup page when i run squad..

can i be doing anything wrong?

Installing sweetfx just creates the necessary folders in your game file. You now need to download a sweetfx profile and put that in the squad folder. Forgot where it is it when you dl the profile (it's a text file) it usually Ella you where to put it. Without the profile there is nothing for it to do.

You can find profile files on the sweetfx website under squad. You can even use profiles from other games, like ARMA.

Share this post


Link to post
Share on other sites
2 hours ago, Shovely Joe said:

so... I just downloaded it, and it seems to work.. well i dont know if it works... because I see no difference what so ever, in frames, resolution, brightness or nothing..

i can turn it off and on on scrnlck and it has the startup page when i run squad..

can i be doing anything wrong?

You have to be running the game in Window-borderless. Don't worry, it's just like full screen.

Share this post


Link to post
Share on other sites
3 minutes ago, JozoNalozil said:

is sweetfx allowed? no EAC ban?

 

It's perfectly fine.

Share this post


Link to post
Share on other sites

Hi !

And my problem with SweetFX is back with V.8, fatal error on launch each time. If I remove dxgi.dll from my /win64 Squad's file, Squad runs but with SweetFX off.

Any feedback please ?

 

EDIT : see my answer to this topic

EDIT 2 (09/11/2016) : V 8.4 seems to fix the problem, I can use Reshade 3.0.4 with Squad and don't get "disconnected by server"

Edited by Nightstalker21
Found a solution !!

Share this post


Link to post
Share on other sites

@TommyI installed your sweetFX (see picture) but now the game doesn't start (fatal error). Can you offer any assistance?

 

4v3as0h.png

Edited by Shieldss

Share this post


Link to post
Share on other sites
12 hours ago, Shieldss said:

@TommyI installed your sweetFX (see picture) but now the game doesn't start (fatal error). Can you offer any assistance?

 

4v3as0h.png

 

Are you using the latest ReShade version (3.0.6) ?

Try verify game cache in Steam

Try reinstall EAC

Share this post


Link to post
Share on other sites
12 hours ago, Shieldss said:

@TommyI installed your sweetFX (see picture) but now the game doesn't start (fatal error). Can you offer any assistance?

 

4v3as0h.png

 

 

rename dxgi.dll to opengl32.dll and it'll work.

 

Something changed.. this fixes it.

 

EDIT: I've edited the download files above to now work with latest version of squad.

Edited by Tommy

Share this post


Link to post
Share on other sites
10 hours ago, Tommy said:

 

 

rename dxgi.dll to opengl32.dll and it'll work.

 

Something changed.. this fixes it.

 

EDIT: I've edited the download files above to now work with latest version of squad.

 

Awesome! Will try this tonight. 

Share this post


Link to post
Share on other sites
On 11/01/2017 at 10:58 AM, Tommy said:

 

 

rename dxgi.dll to opengl32.dll and it'll work.

 

Something changed.. this fixes it.

 

EDIT: I've edited the download files above to now work with latest version of squad.

 

Thanks @Tommy! Makes the game look MUCH better. Thanks again.

Share this post


Link to post
Share on other sites
On 1/12/2017 at 2:58 AM, Tommy said:

 

 

rename dxgi.dll to opengl32.dll and it'll work.

 

Something changed.. this fixes it.

 

EDIT: I've edited the download files above to now work with latest version of squad.

 

Can confirm this is working - so good, thanks @Tommyyou bloody legend! 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×