Jump to content
a rather small moose

[Solved] Updated pushed on steam, game is now broken

Recommended Posts

Got a weird 1-GB patch when I started steam when I tried to play Squad today, and it seems to have broken the game. Already been through the quick-fixes, reinstall EAC, reinstall the game, verify integrity of game files, clear cache data, etc. When starting the game, I get a series of asset errors, and trying to join a server results in a variety of errors ranging from an invalid auth token to an Unreal Engine crash.

 

Specs:
i7-3770k @ 4.5GHz

16GB Corsair Vengance Ram

256GB Samsung Evo 840 SSD
Asus GTX 1080

Dedicated PCi Ethernet Card

In the middle of writing this, I tried to download the game from another Steam Server. Downloaded completely and tried starting it, got a BSOD. Lost all of the EAC error snapshots.

 

 Steam now says the game is not installed, despite all of the files being there. While I played the steam circus of making file space to install a game that already exists, I reinstalled my graphics card drivers since Google said to do that. (BSOD code 1033).

Steam proceeded to download more files. Fired up the game, got a single EAC error. https://imgur.com/a/SCu1W At least I can snip it. I'm now able to join a server. Walked around for a few seconds, get EAC Kicked: Authentication Timed Out. I'm pretty sure this issue has more to do with my PC now than Squad, but I'm still posting this just in case someone knows some black magic.

 

**** me.

Share this post


Link to post
Share on other sites
19 minutes ago, a rather small moose said:

Steam now says the game is not installed, despite all of the files being there

I suggest you do complete install by following the same steps as 

Also for EAC, Anti cheat issues : Quick fix for me is to completely get out of squad. Kill the process if it's still running in process tab. Restart the Game. 

 

Edited by samwiseOrigin

Share this post


Link to post
Share on other sites
5 minutes ago, a rather small moose said:

Unless I missed something [...]

Hint: step 3

Share this post


Link to post
Share on other sites

Got to the bottom of it, was a bad ethernet card driver. (https://imgur.com/a/aCnDT) Reinstalled the driver, then re-downloaded Squad. Went much smoother this time. I can get into servers again without a hitch. Going to go out on a limb and say that was corrupting the download.

 

Also, the only thing the Steam uninstaller leaves behind in the installation directory is an EAC log file.

Share this post


Link to post
Share on other sites
1 hour ago, a rather small moose said:

Got to the bottom of it, was a bad ethernet card driver. (https://imgur.com/a/aCnDT) Reinstalled the driver, then re-downloaded Squad.

good find.

thx for sharing with us.

 

if you need this thread reopened, PM a Moderator.
/locked

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×