Jump to content

Impossible to join a squad

Recommended Posts

Hey everyone,


9 times out of 10 when joining a game here is what happens: the game loads' in; I enter the respawn screen to join  a squad; when clicking on a squad to join I get moved on to the role screen but I actually am not in a squad, if I go back to the squad page my name appears nowhere. I've tried reinstalling the game but the issue persists. Because of this problem I just can't play at all; almost every game I join the problem occurs and I have to quit and restart until I am tired of trying.


Any suggestions or similar issues ?

Share this post

Link to post
Share on other sites

Hello and welcome to Squad @InsideReality,


not really aware of such an issue.


does this also happen if you try to create a squad?

does this also happen on the "Firing Range" (local server) when you try to create a squad?

Share this post

Link to post
Share on other sites

I found another thread describing this issue. http://forums.joinsquad.com/topic/27041-cant-joincreate-squad-or-spawn/


a solution for one user who had this issue:

On 7.5.2017 at 1:54 AM, estropilleur said:

Problem solved Mendes ! B|


In some case , it's a network problem. If you use wifi or CPL option , network packets were maybe losed and server closed connection !

Two possibilities :

- Highly recommended to turn off wifi and connect your PC in wired

- Change your DNS address in IPV4 (Tutorials on Google) and take Google Dns (Primary and*)


* Not necessary


do you use wifi?

do you also have this issues when joining a healthy (green square), unpopulated server?


if I were you, I'd also contact [email protected]

describe your issue and link this forum thread.

Share this post

Link to post
Share on other sites

Tried what the linked thread said to try but didn't change anything.
I don't use wifi.

It could be due to connection because it doesn't occur if the server is at like half capacity or less I would say.
Still very irritating !


I have contacted squad support, waiting on an answer.

Share this post

Link to post
Share on other sites

exact same issue, the game is unplayable for me, if there is more than 25 people on a server i can't spawn or join a squad at all.
i've tryed so many things to only be able to play a single game today, the only one i could spawn in was emptying and i've played for no more than 2 minutes before the game end and the server emptyed completly.

It seems like (looking at steam stats) the more players are playing at a time, the more unlikly i am going to be able to spawn.

Edited by Tryust

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now