Jump to content
LaughingJack

SDK: updates and issues

Recommended Posts

Thought i'd start a thread for any SDK issues, problems and for update info/changes.

Starting from the SDK update in September 2017.

 

Couple questions to start off:

1. after the update i have now only 4-5 maps in the Contents - is this right? were the other maps removed for a reason?

2. can we expect any form of change-log, even rough, for each update?

 

 

 

 

 

Share this post


Link to post
Share on other sites

I can only say that I miss them on my side as well.

Also there are some issues with landscape material it seems that some texture2d node has no input or some shit...

And looks like there are some lighting issues on some maps or It's may be me...

 

They removed Jankins Range. Cheesus Christ where a hell I should do all my tests now?! O___O

 

UPD: This three nodes (well more precisely they all are an instance of one) missing a texture... O_o

So after I've added textures for them and recompiled they began to work...

IlHhiAJ.png

Edited by FishMan

Share this post


Link to post
Share on other sites

Downloaded the SDK last night after I screw it all up for like the 3rd time a few weeks ago and like everyone stated previously the range, goro, yeho and sumari are missing yet now there is basrah, narva and logar... What happened to those folders? Are they being updated for another update? Also, anyone know what version of the game is the SDK now?

Share this post


Link to post
Share on other sites
18 hours ago, FishMan said:

U mean squad? Or UE?

 

If we talk about the engine version you can watch in Help>About...

FZfxln9.png

 

 

I'm talking about Squad not UE4. Anyway, as far as the SDK goes I loaded it up while we were out mucking around in the woods all day and every map I load doesn't have a material instance applied to the landscape and once I load one in it doesn't show the layers etc. Is this some new feature where that lives in another folder or something?

Share this post


Link to post
Share on other sites
On 14/10/2017 at 4:06 AM, FishMan said:

I can only say that I miss them on my side as well.

Also there are some issues with landscape material it seems that some texture2d node has no input or some shit...

And looks like there are some lighting issues on some maps or It's may be me...

 

They removed Jankins Range. Cheesus Christ where a hell I should do all my tests now?! O___O

 

UPD: This three nodes (well more precisely they all are an instance of one) missing a texture... O_o

So after I've added textures for them and recompiled they began to work...

 

Hey Fisho, yeah i agree, i miss them too.

oh man!, that Texture2d thing, iv'e seen that before! you just reminded me - can't remember where tho, and it was before the latest update.

lighting issues? lols! so many instances of offset shadows (CSM = rubbish) in nearly all the maps i see played (youtubes). i've given up even worrying about them now - maybe one day Epic will give us a proper solution for Dunamic Lighting.

 

 

 

Edited by LaughingJack

Share this post


Link to post
Share on other sites

I think I've properly migrated all my standard UE4 assets into the Squad SDK Content folder but I'm still having trouble applying a material instance to my landscape plus in numerous asset folders the textures aren't showing up. Was there like a drastic change in the SDK or something? Before I could just migrate my whole library into the Squad SDK content folder and everything worked fine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×