Jump to content
Mr. Sandwich

CPU testing, old AMD vs Ryzen with Rx 580

Recommended Posts

WARNING: This post is a giant mess. I'll make pretty when done.

 

 

Previous Important stuff:

CPU Stock: AMD 1035t 2.6 GHz 6-core with a boost to 3.1GHz (similar to other AMD chips around 3.1GHz)

CPU Overclocked: AMD 1035t 3.7 GHz - Roughly equal to a 1090t or a FX 8150/8350 or Phenom ii 965 BE running at the same Overclocked GHz speeds (roughly)

RAM: Corsair XMS3 DDR3 1600MHz Ram 8GB running at 1493mhz (game crashed any higher than that)

GPU: Powercolor Rx 580 Red Dragon 

 

New Important Stuff:

CPU: AMD Ryzen 7 1700 3.64GHz

RAM: Corsair Vengeance LPX 3000MHz 16GB (2 x 8 GB) Running at 2926.4 Mhz 

GPU: Powercolor Rx 580 Red Dragon (yeah same GPU in both tests).

 

userbench scores + hardware running at 3.80 GHz:

http://www.userbenchmark.com/UserRun/4715025

 

 

If you have a Ryzen 3 or Ryzen 5 running at similar GHz, I'm pretty sure you can expect similar results. Squad does not care about my extra cores (actually disabling 4 of my cores shows an increase of 2 fps).

 

 

So Here are some Numbers:

Old AMD CPU with rx 580

AMD 1035t @ 2.6 GHz @ 1920 x 1080 LOW/OFF- 41 FPS in firing range, unknown unplayable rage FPS in multiplayer (ASSUME 19-22 area).
AMD 1035t @ 3.7 GHZ @ 1920 x 1080 LOW/OFF- 58 FPS in firing range, 28-31 in multiplayer (70 players in server).

 

New Ryzen with rx 580 *note, all tests were ran at 3.64 GHz unless otherwise stated*

 

Ryzen 7 @ 3840 x 2160 4k resolution

Spoiler

Low/OFF Firing Range: Dips to 33 FPS when full auto on ground below me (bipod LMG full mag). When running around it's steady at 70-80 fps, peak of 98 fps
Ryzen 7 @ 3840 x 2160 4k resolution Low/OFF Firing Range with audio quality set to LOW: still dips to the same 33 fps when I unload on the ground below me, no difference.
Ryzen 7 @ 3840 x 2160 4k resolution Low/OFF Online 70 players: 30-60 FPS, dips to low 30s during firefights

 

Ryzen 7 @ 3200 x 1800 resolution

Spoiler

, Low/OFF: 84-99 FPS in Firing Range. Dips to 45 fps when going full auto on the ground otherwise steady at 84-99 FPS when running around
Ryzen 7 @ 3200 x 1800 resolution, Low/OFF, Online 70 players: 45-65 FPS, likes to hover right around 55 FPS. 

 

Ryzen 7 @ 2560 x 1440

Spoiler

Low/Off Firing Range: Running around steady at 90-99 FPS, dips to 67 FPS when full auto into the ground
Ryzen 7 @ 2560 x 1440 Epic Preset in Firing Range: 51-68 FPS running around, 60 average. Dips to 42 FPS when going full auto on the ground below me
Ryzen 7 @ 2560 x 1440 Low/Off online 70 players: 55-75 FPS, over 60 fps most of the time
Ryzen 7 @ 2560 x 1440 Epic Preset online 70 players: 47-59 FPS, usually right around 50 with a very short dip to 34 fps during a large battle

Ryzen 7 @ 1920 x 1080

Spoiler

 

Ryzen 7 @3.20GHz@ 1920 x 1080 LOW/OFF: 90-94 FPS running in firing range, dip to 88 going full auto on ground. 50-65 in multiplayer. Dip to 45 during combat.

Ryzen 7 @3.64GHz@ 1920 x 1080 LOW/OFF: 99-101 FPS firing range, dip to 94 FPS when full auto on the ground below me.  Edit:- Chora Valley map 55-78 with dips to 48FPS in heavy smoke combat. avg 50s in the city areas, 70s in nature. Fool's Road map (half cores enabled): 60-75 FPS avg with a dip to 58.  Chora Valley map: 100-134 FPS in main base spawn, 70s when in nature/fields, 50s in buildings, dip to 48. Sumari Bala map: 50s in city, 70s in nature. Chora Valley (half cores enabled): still about the same FPS. 50s-70s and same temp also. Sumari Bala: 45-55 in city all round. Kohat Toi River Valley:  50-55 FPS. Sumari Bala  28 players 90-120, 80FPS with 50 players, 49-65 with 72 players

Ryzen 7 @3.80GHz 1920 x 1080 LOW/OFF: 95-100 FPS when running around in firing range, dip to 94 FPS when full auto on the ground below me. 106 max.. multiplayer Al Basrah map 55-60 fps, Kokan Valley (20 players): 110-160 FPS, (30 players 105-120) (48 players 90-100) (60 players 75-80 fps) (78 players 55-60 in city, 80s in nature) 60c max after multiplayer round 1.384v.  Fool's road (72 players) 60-70s in heavy combat, 80-90 in nature max temp 63c. Sumari Bala (40 players) 90-120 FPS, 72 players 60-70FPS max temp 53c 1.406v. OP First Light Map: 60-78 fps 63c

Ryzen 7 @3.80GHz with affinity set to only use the best 4 cores 1920 x 1080 LOW/OFF: 100-111 FPS when running around in firing range 116fps max, dip to 97 FPS when full auto on the ground below me. Chora Valley (74 players 49 ping): 55-65 FPS in city, 55c max at 1.373v , Al Basrah: 50-55 in city, 55c 1.373v

 

 

Ryzen 7 @3.20GHz@ 1920 x 1080 EPIC Preset: 68-93 FPS in firing range running round, dips to 58 going full auto on ground. 45-58 multiplayer. Disabling cores made no noticeable difference in multiplayer.

Ryzen 7 @3.64Ghz @ 1920 x 1080 EPIC Preset: 70-98 FPS in firing range running around, dips to 65 FPS when full auto on ground below me, 58-74 in multiplayer (70 players)

Ryzen 7 @3.80Ghz @ 1920 x 1080 EPIC Preset: 70-98 FPS in firing range running around, dips to 61 FPS when full auto on ground below me. TBD multiplayer

 

 

Edits (keeping track of all the numbers):

Spoiler

 

@ 3.80 GHz 1920 x 1080 low/off, looking at 1 direction without moving. Number in [brackets] is the same test ran at 3.20 GHz 

Set affinity 0-15 cpu (all cores enabled): 108 FPS [95 FPS] 

Set affinity 0-14 cpu (unchecked 1 of 16):  108 [95] 

Set affinity 0-13 cpu: 108 [95] 

Set affinity 0-12 cpu: 108 [95]

Set affinity 0-11 cpu: 108 [95]

Set affinity 0-10 cpu: 108 [95]

Set affinity 0-9 cpu: 108 [95]

Set affinity 0-8 cpu: 108 [95]

Set affinity 0-7 cpu: 110 FPS [96]

Set affinity 0-6 cpu: 110 FPS [96]

Set affinity 0-5 cpu: 108  [94]

Set affinity 0-4 cpu: 106 [92]

Set affinity 0-3 cpu: 102  [89]

Set affinity 0-2 cpu: 102 [90]

Set affinity 0-1 cpu: 86 [76] (2 boxes checked)

Set affinity 0-0 cpu: 68 [54] (only 1 box checked)

 

With SMT Turned off same test 3.64GHz:

Set affinity 0-7: 106

Set affinity 0-6: 106

Set affinity 0-5: 106

Set affinity 0-4: 106

Set affinity 0-3: 110

Set affinity 0-2: 110

Set affinity 0-1:  108

Set affinity 0-0: 67

 

 

 

5120 x 2880 resolution (highest possible resolution) using virtual super resolution AMD setting: 27-65 FPS in firing range, dip to 25 when full auto on the ground below me, otherwise steady in the mid 40s. Online untested, assuming unplayable FPS (below 30)

1024 x 728 resolution LOW/OFF (lowest possible setting): 99-103 steady fps running around in Firing Range, dip to 97 FPS going full auto on the ground. Online untested, probably in the 80-90 range based off of the numbers.

 

 

@ 3.64GHz at 1920x1080 low/off looking at the same spot: 101-102 with all cores enabled, 106-107 with only 0-7 enabled. 

3.7 GZz: 105FPS, affinity 0-7 110FPS, affinity 8-15 112 FPS.

EDIT: at either 1024x728 or 1920x1080 on LOW/OFF I am able to get 108 FPS at 3.8 GHz looking at the same spot.

EDIT AGAIN: If I set affinity and disable the last 4 cores, I now get 110 FPS as a max at 3.8 GHz 1024x728 or 1920x1080 low/off looking a little below the sun on firing range off into the distance (same spot as before).

Edit Again Again: Now if I do the same test at 3.8 GHz but disable the first 4 cores (because they are worse apparently): 116 FPS

 

 

 

Other hardware just in case you are interested:

Spoiler

 

Hard drive: KingDian 480gb SSD on Sata 3 (KingDian? it's actually been awesome and gets great benchmark scores too).

Power Supply: EVGA Supernova 650 G2 Gold (love it)

OS: Windows 10 64bit

Motherboard: Asus Prime x370-A

CPU Cooler: Stock spire cooler that came with 1700. Have 212 evo I will use and test in the future.

Hooked into a Sony STR DH550 4k Receiver, hooked into a 55" Vizio 4k TV (60hz actual with fake 120 hz), Logitech G35 headphones, razer deathadder mouse 3500 dpi

 

 

More info about ryzen at different speeds: 

Spoiler

 

@ 3.20 GHz, I just selected "eco mode" in my motherboard settings. I wanted a slower clock just for reference. Voltage varies 0.403 - 1.41, 30c idle , 50c max temp after running squad ~1hr in firing range then multiplayer. This mode had a turbo boost to 3.7ghz which seemed to do absolutely nothing except increase voltage.

 

@ 3.64 GHz, I select  "power" mode in motherboard settings, nothing manual yet. 30c idle, voltage 0.403 - 1.264v. 0-6 Affinity 47c [46c SMT off] max temp stress test in CPUz. 62c then later test 63c [52c SMT OFF] with all cores enabled. Max 55c (all cores) @ 1.253V during online match 1920x1080 getting stressed out @ 50fps low/off (Chora Valley). 54c [48c smt off] With half cores enabled max temp after full match 1920x 1020 getting average 60 fps (fools road). 53c max squad temp, test 2, full cores. Test 3, 53c at half cores.

--With SMT off, 51c max temp after full match, cpu went to 3662 rather than the usual 3643, 1.264v

--With SMT off, squad running on half cores, 48c max temp, 3643 mhz 1.264v

 

CPUz Single thread score: 424.0 [Tested again after a full match, ran 3 times, 423.7, 424.2, 423.2] *With SMT turned off in bios 423.7, 424.5, 420.6*

-- With affinity 0-7: 422.7 [422.7, 422.3, 422.7]

-- With affinity 0-6: 421.2 [422.7, 422.0, 423.8]

-- With affinity 0-5: 416.4

-- With SMT OFF Set affinity 0-3 (4 cores, same as using 0-7 w/ SMT on): 424.4, 422.7, 422.2

 

CPUz Multi thread score: 4530.8 *with SMT off 3342, 3349.3, 3356.1 *

-- With affinity 0-7 : 2267.5

-- With affinity 0-6: 2121.5

 

 

@ 3.7 GHz 

CPUz Single thread score:

-- With affinity 0-15 (all): 426.2, 426.8, 426.3 

-- With affinity 0-7: 428.4, 426.4, 427.4

-- With affinity 0-6: 425.5, 427.4, 426.0

-- With affinity 0-5: 426.3,  426.1, 425.8

-- With affinity 0-4: 427.9, 425.9, 426.4

-- With affinity 0-3: 423.0,  421.5, 421.8

-- With affinity 0-2: 419.5

-- With affinity 0-1: 303.9

-- With affinity 0-0: 418.7

 

0-0 only: 418.1

1-1 only: 420.0

2-2 only: 421.0

3-3 only: 418.9

4-4 only: 420.8

5-5 only: 420.7

6-6 only: 419.5

7-7 only: 421.2

8-8 only: 421.7

9-9 only: 421.1

10-10: 421.4 

11-11: 421.8

12-12: 420.9

13-13: 421.0

14-14: 421.2

15-15: 421.4

 

0-7 single: 426.2, 426.7, 427.3

multi: 2298.2, 2300.0, 2299.0

 

8-15 single: 430.5, 430.5, 430.9

multi: 2300.8, 2301, 2300.8

 

Top 6 from above test 7, 8, 10, 11, 14, 15:

430.4, 430.6, 430.0

 

Top 4 from above test 7, 8, 10, 11: 

429.1, 430.3, 430.3

 

Worst 6 0,1,3,4,5,6:

427.1, 425.3, 427.7

 

Worst 4 0,3,6,1

423.9, 425.2, 425.8

 

 

CPUz Multi thread score: 4576.6, 4584.7, 4581.8

-- With affinity 0-7: 2299.4, 2299.4

-- With affinity 0-6: 2150.7

 

Ok so based on the above test, it seems cores 8-15 are better than cores 0-7. This makes a difference because I've been disabling cores 8-15 when running tests on half cores -- oops, it appears that I should be disabling cores 0-7 instead.

 

Max Temp after full round: 3.7ghz 54c 1.275v, 60-75fps avg

SMT off CPUz Stress test 58c all cores 1.286v... half cores 49c 1.264v

 

 

@ 3.80 GHz *Max Stable Speed*

*pc failed to post this morning  after being turned off all night. turned SMT back on and it seems to work for now*

 

 

SMT on, 3.8GHz:

Idle: 26c-27c

CPUz single core score (all cores enabled): 438.3, 438.9,  438.1

                                          --- top 4 cores only: 442.1, 441.8, 441.9

multi core score (all cores enabled): 4698.4, 4634.9, 4706.9

                             --- top 4 cores only: 2253.8, 2363.2, 2363.3

smt on cpuz stress test (all cores): 67c @ 1.395v

smt on cpuz stress test (half cores): 51c @ 1.384v

prime 95 stress test (all cores): 75c @ 1.406v 

prime 95 stress test (half cores):64c @ 1.384v

 

3.8 GHz SMT on, set in bios to only be a 4 core cpu. 

437.1, 438.9, 437.9

2329.8, 2336.3, 

cpuz stress test 1.363v 55c

Prime 95: 1.384v 65c

Firing Range 92-99 FPs, 104 FPS max looking at sun   1.363v 45c

 

SMT off 3.8 Ghz

cpuz single thread score all cores enabled: 438.3, 440.6, 438.4

best 4 cores enabled only: 442.4, 442.5, 442.2

 

smt off cpuz stress test (all):  62c @ 1.375v,

smt off cpuz stress test (half) 55c @ 1.363v

 

 

@ 3.875 GHz: boots, 1.439v 72c CPUz stress test all cores **Crash during prime 95 stress test**

@ 3.90 GHz: boots, crashed during cpuz stress testing 1.428v

 

@ 3.925 GHz boots, completes userbench (http://www.userbenchmark.com/UserRun/4714786) 100% cpu ovr, 117pt single, 469pt quad,  1320 multi

***Crash during cpuz stress testing***

All cores:

CPUz Single: 452.3, 452.9, 452.4

Multi: 4865.2, 4863.8, 4862.8

 

Best 4 cores set affinity:

Cpuz single: 457.1, 456.9, 456.5

multi: 2442.0, 2440.4, 2441.7

 

 

@ 3.950 GHz boots, completed userbench, (no link saved. 102% cpu, 118pts single core, 199% multicore is what i remember) crashed during cpuz stress test

@ 4.00 GHz boots at 4GHz, crashes during userbench 8 core multi test

 

 

 

Side notes:


 

Spoiler

 

Windows Power Plan  is set to "Ryzen Balanced" - this is new, it keeps the speed up for less delay in gaming. works great! no worse than "high performance"

 

setting priority to "high" in task manager does absolutely nothing for my fps. running apps are chrome, fraps, hwmonitor and squad. windows 10

 

With the 6 core AMD 1035t, I found no loss of FPS in training mode when I only had 2 cores enabled. I kept 4 cores enabled when I overclocked, turning off 2 cores allowed me to increase voltage without as much heat. Task manager shows all cores being used at a low %, however Squad doesn't seem to use 6 cores all at once. No fps loss with only 2 of 6 cores enabled,  a lot of FPS lost with only 1 core enabled.

 

While running the old system at 3.7 GHz, the game would crash unless my RAM speed was below 1500MHz even though it was proven stable at 1600MHz (the ram speed is supposed to be 1600 MHz but you have to enable XMP to get above 1333MHz). Voltages and timings were not in play here. Game insta-crash at over ~1550Mhz then 0 issues at 1493Mhz).

 

New system, no issues so far at 3000.

 

Why do I have a 1035t? Because I burned up my AMD 4Phenom 965 and my FX 8150 then found this guy on ebay for pretty cheap, full intentions of burning him up too. 

I originally ordered a Ryzen 5 1600 but it failed to post with the motherboard, so I RMAd it, while I waited I overclocked the crap out of my CPUs. Little did I know that core temp and HW Monitor showed readings roughly 20 degrees below actual. The first CPU I thought ok sure, then the 2nd... 

So then the replacement Ryzen 5 1600 and the replacement motherboard showed up, aaand still CPU error, no post. Luckily I got to just return it all. I bought the Ryzen 7 1700 simply because I've read DOZENS of horror stories about how the Ryzen 5's do not post with many motherboards unless you borrow a ryzen 7, plop it in, update the bios, then it's good to go.. After 2 failed Ryzen 5's, Give me the Ryzen 7.

 

Windows now boots so fast, it no longer says "Loading Operating System" in the upper left corner of the screen. The black screen appears, but the text doesn't have time to show, already off to the next screen.

 

 

 


 

Edited by Mr. Sandwich

Share this post


Link to post
Share on other sites
Psyrus   

Thanks for posting that extensive review. I just bought a new CPU etc combo today and after much deliberation, decided to stick to Intel this time even though I so badly want to support AMD for picking up their game with Ryzen :(. 

 

Glad it's working out for you (for the most part) though! 

 

Share this post


Link to post
Share on other sites

Squad alone is not worth skipping Ryzen. All other games runs great with Ryzen, it's a great CPU line.

Anyway - thanks for posting FPS ranges, It's nice to have it.

Share this post


Link to post
Share on other sites
15 hours ago, palanoid said:

your 1080p epic preset result is a lot better than what i have been getting.

 

are you on the latest radeon crimson driver?

Yes the latest version, 17.7.2 

My Rx 580 is very slightly overclocked from manufacturer as well

Share this post


Link to post
Share on other sites
palanoid   
12 hours ago, Mr. Sandwich said:

Yes the latest version, 17.7.2 

My Rx 580 is very slightly overclocked from manufacturer as well

so it'd be running at 1350mhz, right? i wanna try to match your clockspeeds with the rx480

Share this post


Link to post
Share on other sites
5 hours ago, palanoid said:

so it'd be running at 1350mhz, right? i wanna try to match your clockspeeds with the rx480

Yes 1350

 

GPU Radeon RX 580
Boost Clock 1350 MHz

Memory

Effective Memory Clock 2000 MHz (8.0 Gbps)
Memory Size 8GB
Memory Interface 256-Bit
Memory Type GDDR5

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×