Jump to content
EAndersen

How to get better fps?

Recommended Posts

When im away from the action and not close quarters, i have 60 plus fps. When im in close combat my fps drops to 40. How can i fix this?

Share this post


Link to post
Share on other sites

 

Turn off Bloom, Eye adaptation and Ambient Occlusion. When I  turned these off it gave me 10+ fps, as well as that the game looks more realistic without ambient occlusion. For Super Sampling never go above 1.25x, it eats your FPS. Hope I helped!

Share this post


Link to post
Share on other sites
4 hours ago, Igno said:

Turn off fps indicator. It is just a placebo!

The difference between 60fps and 40fps is not a placebo mate.

Share this post


Link to post
Share on other sites
On 03/08/2017 at 2:05 PM, EAndersen said:

When im away from the action and not close quarters, i have 60 plus fps. When im in close combat my fps drops to 40. How can i fix this?

what are your system specs please.

CPU
RAM

GPU
Resolution played at

We need to establish a sensible minimum FPS for your system then we can advise better re settings.

Share this post


Link to post
Share on other sites

gonna high jack this thread

 

i7-2600k @ 3.4ghz

16 gb ram

1080 ti 

2k resolution

 

average 50 fps... doesn't seem right to me

Share this post


Link to post
Share on other sites

In be4 somebody tells you to upgrade your rig.

Share this post


Link to post
Share on other sites
1 hour ago, Flavin913 said:

i7-2600k @ 3.4ghz

Did you turn off turbo boost?

 

Use the "stat unit" method to see what component is bottlenecking you. I would assume it's the CPU given you have a 1080ti

Share this post


Link to post
Share on other sites

Lower the effects quality and try some settings that give you higher average fps to make up for those drops.

When theres lots of things going on that gotta be rendered its to be expected that the frames drop. Same goes for the amount of people within your area. The higher the population the more weight your cpu has to pull.

 

I dont think thats a technical issue.

 

Whats your gpu? If youre already using the lowest preset theres not really much you can do besides overclocking your cpu/gpu.

 

Also do what psyrus says, hes a wise man.

Edited by Chew_Kok_Long

Share this post


Link to post
Share on other sites
9 hours ago, Psyrus said:

Did you turn off turbo boost?

 

Use the "stat unit" method to see what component is bottlenecking you. I would assume it's the CPU given you have a 1080ti

No, I cant say that I know how to turn off the turbo boost, also I'm not sure what the "stat unit" method is, I will definitely give it a google, thanks for pointing me in that direction.

 

someone in game suggested turning sound quality to low and that help a bit, but still no where near the frames I was hopping for, atleast average 80fps would be nice.

Share this post


Link to post
Share on other sites
6 hours ago, Flavin913 said:

I'm not sure what the "stat unit" method is, I will definitely give it a google, thanks for pointing me in that direction.

Sorry I was responding from my phone so I wrote things as concisely as possible. 

 

Please read this blog post for more information 

https://www.unrealengine.com/en-US/blog/how-to-improve-game-thread-cpu-performance

Share this post


Link to post
Share on other sites

my draw is always the lowest number, so that's my gamethread that is bottlenecking...

 

also I lowered all my graphics settings except my resolution and I still end up with the same FPS lol, so very strange.

I couldn't find out how to upload attachments to these forums but I have some photos of my "stat unit"

Share this post


Link to post
Share on other sites
9 minutes ago, Flavin913 said:

my draw is always the lowest number, so that's my gamethread that is bottlenecking...

 

also I lowered all my graphics settings except my resolution and I still end up with the same FPS lol, so very strange.

I couldn't find out how to upload attachments to these forums but I have some photos of my "stat unit"

Yeah it makes sense that draw is the lowest with the type of GPU that you have. The reason that lowering settings has no effect on your FPS is because as suspected, you're CPU bottlenecked and thus while your GPU can render the commands it gets very quickly, it's constantly waiting for your CPU to send it new commands. 

 

The reason why turning down the sound settings helps marginally is because that also puts load on the CPU, so with less CPU power going to sounds, it can get commands to the GPU quicker which means more FPS for you. 

 

The only options are:

- Wait for more optimizations

- Overclock your CPU to about 4+ ghz

- Buy a new CPU with better IPC and clock speeds. 

 

There are no settings that you can change that will help you, unfortunately. 

 

Edit: I assume you have cleared the user data since installing the v10 patch, right?

Edited by Psyrus

Share this post


Link to post
Share on other sites

Thanks for the wise words Psyrus, and I had assumed it could have been the CPU aswell, since that is the oldest part of my PC atm, but what confurse me was that when I open task manager, my CPU usuage caps at 45% when using SQUAD so I thought that meant it was good.

 

any recommendations on a CPU?

Share this post


Link to post
Share on other sites
3 hours ago, Flavin913 said:

any recommendations on a CPU?

I personally feel that throwing money at a solution should be the last thing to be considered. You have a K series CPU, and some brief googling netted me this guide:

http://www.tomshardware.com/forum/265056-29-2600k-2500k-overclocking-guide

 

Depending on your CPU cooler, you should be able to get 4.2ghz quite easily.

 

3 hours ago, Flavin913 said:

when I open task manager, my CPU usuage caps at 45% when using SQUAD so I thought that meant it was good.

It would be a long explanation, but that's unfortunately not how it works. :) 

Share this post


Link to post
Share on other sites

Testing now, psyrus, thanks again for the advice, I seem to have gotten my maximum processor Fequency stably to 4.43 Ghz with a amx temp of 77C.

Testing on a few maps now, so far though it seems like my draw stat is still much lower than my others.

 

average FPS is at around 60-65 now but it is constant. definitely an improvement, not the 80fps I was looking for and expecting though :(

 

My active core count is constantly changing in Intel extreme utility, not sure if that has something to do with it.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×