Jump to content

Recommended Posts

Hello. 

I just rented a server. This will be mainly Nordic and Englishspeaking people on.

There is only one problem, the server sends messages in German (as shown in the picture top left).

 

20170801222322_1.jpg

 

Where in the cfg do i fix this? :)

 

[NVIK] DanieleN

Share this post


Link to post
Share on other sites
Posted (edited)

AFAIK this depends on the server OS language, because steamcmd (as Steam overall) typically localizes anything to equal the OS  language.

 

You could try using the "app_update <appid> [-validate] [-language <lang>]" command line option steamcmd offers and see if it changes the game language... that seems less overkill as installing EN localized OS at least.

That would should work by altering the Start-Script line

%STEAMCMD% +login anonymous +force_install_dir "C:\servers\squad_server" +app_update 403240 validate -language english

And to be clear, I haven't tested that myself, that's plain theory :-)

Should you have rented a managed server/slot-based... well, good luck asking your provider to change it for your instance.

Edited by char0n
a bit correction/clarification :)

Share this post


Link to post
Share on other sites

The problem is not SteamCMD. I have the same problem and in the squad.log for me it says:

[2017.11.19-10.40.45:628][  0]LogInit: Using OS detected language (es-ES).
[2017.11.19-10.40.45:628][  0]LogInit: Using OS detected locale (es-ES).

So it's Squad that chooses which language to use. It's weird to not have a parameter to manually change it, tho. 

 

Share this post


Link to post
Share on other sites

Is there a way to set the language manually instead of selecting the OS one?

On my Windows 2008 server is not possible to change the default language to English unless I format and reinstall the whole thing.

Share this post


Link to post
Share on other sites

Quick update, I have managed to change the server language to English by changing the Windows machine language. Still, it would be best to have a parameter to set the preferred language when launching the Squad server.

 

Cheers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×