Rivvern

G35 surround sound issue

Logitech G35 headset with 7.1 surround sound. Cannot hear audio from certain angles. Makes playing very difficult. Tried new drivers, tried verify files. Ive read about others having the same problem but no solution. Please help.

 

Microsoft Windows 10 (10.0) Professional 64-bit   (Build 14393)
Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz 
Z170 PRO GAMING
NVIDIA GeForce GTX 980
Logitech Gaming Software 8.94.108

Share this post


Link to post
Share on other sites

Hi and thanks. 

 

I cant seem to change that in the options. I also cannot change that in windows...

Can you point me in the right direction? Thanks

  

Qzeqf1n.jpg

RkW8YQw.jpg

Share this post


Link to post
Share on other sites

Not sure if I can help. I don't own such a fancy headset. ¯\_(ツ)_/¯

 

Usually you can enable/disable such feature via software or hardware (button/switch)

 

have you ever tried flipping the switch?

"Using the switch with the Dolby logo on the back of my G35 headset"

http://support.logitech.com/en_ch/article/11663?product=a0qi00000069vCLAAY
EjC48uX.png

Share this post


Link to post
Share on other sites
12 hours ago, Rivvern said:

Logitech G35 headset with 7.1 surround sound. Cannot hear audio from certain angles. Makes playing very difficult. Tried new drivers, tried verify files. Ive read about others having the same problem but no solution. Please help.

7.1 surround sound is broken in Squad. My guess is somehow it switches the game into 10.2 surround sound mode(which is broken, there are no  even 10.2 mainstream sound cards yet):

intro_to_sound_recording1049x.png

 

That's why you're missing sounds. I can even tell you where you miss your sounds, it's in the -45° to -90° and 45° to 90° areas(around +-60° by my tests), if I remember correctly.

 

Some time ago I even found this in BaseEngine.ini in Squad Modding Kit:

[Audio]
MaxChannels=256
CommonAudioPoolSize=0
UnfocusedVolumeMultiplier=0.0
UseAudioThread=true
EnableAudioMixer=false
[AudioChannelAzimuthMap]
FrontLeft=330
FrontRight=30
FrontCenter=0
BackLeft=210
BackRight=150
FrontLeftOfCenter=15
FrontRightOfCenter=345
BackCenter=180
SideLeft=270
SideRight=90

That's an azymuth map for 10.2 surround sound system AFAIK: there are no BackCenter, FrontLeftOfCenter and FrontRightOfCenter channels/speakers in 7.1 system. There are in 10.2, thgough.

What's up with that? Can you comment on it, @anders?

 

For now I use 5.1(choose 5.1 in Windows Control Panel), it works wonderfully for me with my Roccat Kave 5.1.

Edited by Skul

Share this post


Link to post
Share on other sites
9 hours ago, Rivvern said:

I cant seem to change that in the options. I also cannot change that in windows...

Can you point me in the right direction? Thanks

Just switch to stereo, as Beginna suggested.

 

Your Logitech G35 is just another stereo headset(you've been defrauded by guys from marketing section and paid extra $50(or whatever) for a function which will actually hurt your positioning in video games) with only 2 speakers and which uses virtual surround sound:

http://www.overclock.net/t/1135471/logitech-g35-g930-real-7-1

 

By using any kind of virtual surround sound technologies you will only make your positioning worse.

 

To enjoy actual true surround sound, you want to buy true 5.1 headset, such as Roccat Kave 5.1:

1267186740.jpg04032756-photo-roccat-kave-hp.jpg

 

This one isn't a fraud, it will deliver you your 5.1 surround sound for reasonable price. There are some other models of true 5.1 headsets, too.

Edited by Skul

Share this post


Link to post
Share on other sites

Thank you for all your comments. 

 

The button does something, but it does not set stereo sound. It still recognises as 7.1 and i miss out on audio in Squad.

Very interesting that the G35 is 7.1 headset with emulated surround. Always thought it was the real deal but after googling i see that you are right! Damn!

 

Too bad. Looks like its either get a new headset, or wait until its fixed. :(

Share this post


Link to post
Share on other sites
53 minutes ago, Rivvern said:

Too bad. Looks like its either get a new headset, or wait until its fixed. :(

Dude. Why give up so easily?

If you are going to wait for a real 7.1-fix, you'll probably have to wait for a very, very long time.


did you check out the link I posted?

read especially the part I highlighted.
l4GirKB.png

 

AFAIK, if you switch off the dolby (7.1), it is just an ordinary stereo headset.

Share this post


Link to post
Share on other sites
12 hours ago, beginna said:

Dude. Why give up so easily?

If you are going to wait for a real 7.1-fix, you'll probably have to wait for a very, very long time.


did you check out the link I posted?

read especially the part I highlighted.
l4GirKB.png

 

AFAIK, if you switch off the dolby (7.1), it is just an ordinary stereo headset.

Already replied to that. "The button does something, but it does not set stereo sound. It still recognises as 7.1 and i miss out on audio in Squad."

Sorry for not quoting.

Share this post


Link to post
Share on other sites
13 hours ago, Rivvern said:

Already replied to that. "The button does something, but it does not set stereo sound. It still recognises as 7.1 and i miss out on audio in Squad."

Sorry for not quoting.

That's odd.. when i switched it, it turned to stereo..

Edited by ChiefSOSA

Share this post


Link to post
Share on other sites
17 hours ago, Rivvern said:

Already replied to that. "The button does something, but it does not set stereo sound. It still recognises as 7.1 and i miss out on audio in Squad."

Sorry for not quoting.

Please post a screenshot of the G35 software.

Share this post


Link to post
Share on other sites

Think i fixed it here.. with dolby 7.1 on , whether i'ts virtual or not.. still sounds 100% better than stereo..

 

Here is what i did : http://imgur.com/mwxIC6h

 

Check> turn on 7.1 virtual sound, this completely fixed the issue with 7.1 on.

 

 

 

 

 

 

Edited by ChiefSOSA

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now