Jump to content

The "Failed to start game" error

Recommended Posts

Hey guys. So, i bought Squad on this first day of summer sale. had the "failed to start the game error", which consists in executing the game, waiting for that initial loading bar, and when the bar is full, the "failed to start the game" appears. 

So, i tried installing vc redist 2015 x86 and x64, and vcredist 2013 x86 and x64. Unninstaled and installed again the anti-cheat. executed everything possible as admin, and nothing worked. the only thing i didn't try was to keep my windows (i have windows 7) updated as much as possible, because for some reason, my windows update refuses to download the updates.
So i still can't play the game. BUT, i found this in the launcher_log of the anti-cheat (common/Squad/EasyAntiCheat). Picture below. 
So i wanna know if this is what have been stopping me to play the game. But, even if it is or if it's NOT, i'll need help to fix this (maybe there's already a topic with this error solved, so someone could send me a link?)

so that's it guys. Hopefully, i'm dumb and this error can be easily fixed. 
Image: https://ibb.co/hukXDQ

PS: tell me if the link is broken

Share this post

Link to post
Share on other sites

Okay so try repairing EAC in the game directory, then clear appdata/local/squad folder, restart your PC, and then start your game from steam. That should fix the problem.


If you find this hard, feel free to contact me on official discord, as its easier to communicate on it

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now