Jump to content
Balmergeddon

High ping and bad lag only in squad

Recommended Posts

I've been playing Squad for a while now. While the performance was great when I started, over the last couple of months I've been getting extremely high pings to some of the servers I used to play on frequently without problems. Checking with other players, they aren't experiencing the problems I've had. I've done a lot of searching online for a fix and haven't seen any solutions that have worked for me so hopefully someone can give me some pointers.

 

I live in the UK and I have fibre internet so I should be able to connect to a UK/EU server without any problems. Right now though, servers like RIP/QFF/Yellow Ants are showing as around 1000ms ping in the server browser and that is pretty much constant for me over the last couple of months. When I connect to the servers, my ping is solidly 300ms+. I also know from experience that even when I connect to other servers with lower pings in the server browser (e.g. ~70ms), I get a ping solidly over 300 in game. A lot of queries on these (and other) forums have responses saying the ping numbers aren't accurate but I'm definitely having latency issues. I haven't been able to play for a while now without constant rubber banding and teleporting around and it's made it very frustrating/nearly impossible to play. It feels like I'm connecting to an Asian server with a dialup modem! To answer an obvious question, this is only a problem in squad and none of the other games I play. I also only have the one device on this network so it's not anyone else gobbling up the bandwidth.

 

I tried pinging a couple of those servers in windows and got average times around 12ms so I'm really confused about what's causing the problem. I'm not an expert on traceroutes but I'm lead to believe that this one (I've used the RIP server as an example) also looks fairly normal (I don't know exactly how to interpret the timeouts but apparently that's common):

 

Tracing route to ip184.ip-213-32-112.eu [213.32.112.184]
over a maximum of 30 hops:

  1     1 ms     1 ms     1 ms  dsldevice.lan [192.168.1.254]
  2     *        *        *     Request timed out.
  3     *        *        *     Request timed out.
  4    10 ms    10 ms     9 ms  be3-3100.pcn-ir01.plus.net [195.166.143.128]
  5    10 ms    10 ms    10 ms  core1-BE1.colindale.ukcore.bt.net [195.99.125.132]
  6     9 ms     9 ms     9 ms  195.99.127.81
  7     *        *        *     Request timed out.
  8    13 ms    12 ms    12 ms  be10-151.rbx-g1-a9.fr.eu [91.121.215.178]
  9     *        *        *     Request timed out.
 10     *        *        *     Request timed out.
 11    12 ms    13 ms    12 ms  ip184.ip-213-32-112.eu [213.32.112.184]

 

I've tried opening ports on my router without that making any difference (it would help to get confirmation of exactly what ports are required as I've seen different things stated in different places). I've also tried a full re-install, even onto another drive, without any success. I've tried changing graphics settings but I get pretty good hardware performance on max settings so I wasn't surprised that made no difference. In case it's relevant, my specs are i7-6800k, GTX1070, 16GB RAM.

 

I've completely run out of ideas so I'm desperate for someone to help me out.

 

Thanks!

Share this post


Link to post
Share on other sites

Kinda have the same problem, good connecton good comp

 

i was on server yesterday empty hade a ping 70--80 (before 9 i hade 50-60 on this server) 

when it started to seed and we hitt 76 players my ping is 110-120 and i get rubberbanding. any ides? 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×