Botch_DK

troubleshooting
FPS drop middle game since 9.5 update!

After the recent update I've experienced a heavy drop in fps – from a stable 60+fps to 25 and below.

At game start, everything is peachy, but a few minutes in and forward the fps just dives off a cliff. I tried running the Squad Troubleshooter V2, nuking the game cache both through game and OS, un- and re-installed GPU drivers (also a rollback), reinstalled the game twice on two separate hdds(maybe the first was broken right?), following performance guide setups etc. – Nothing helps, no matter the graphic settings and hardware setup the fps stay below 25!

 

It is to be said that Squad has never crashed because of this, the FPS drop is just too severe to keep on playing! I've also not made any changes to my setup during the rollout of the 9.5 update, all my other games behaves like normal. I also had no problem running Squad before the update, stable 60fps and no crashes since I bought the game.

 

BUT tried I enabling Full Texture Loading which bumps the fps to 45 without any too severe drops. Anyone else with fps problems since recent update that can verify? - Could this be a memory leak thing?

 

I'm at work, so will post logs and monitor data when I get home, do a third play-through to verify and then submit an official bug report.

Rig:

 

• Core i7-4770k 3.5Ghz

• MSI GTX 1070 Aero ITX 8GB OC

• Corsair XMS3 - 16 GB DDR3 1600 / 2x 8GB sticks

• Gigabyte - Z87-Wifi Mini ITX LGA1150

• Kingston SSDNow V300 120 GB

Share this post


Link to post
Share on other sites

Did you clear game cache in settings yet?

 

 

Share this post


Link to post
Share on other sites
1 minute ago, SHO-SHIN said:

Did you clear game cache in settings yet?

Yes, first thing I did - but I'll report back later with some logs, if that'll help with anything.

Share this post


Link to post
Share on other sites

What resolution are you playing in?

 

Be careful with Full Texture Loading, with it on you can use upwards of 10GB VRAM in 1440p, I have a 1080ti with 11GB VRAM and play with it off (the lower VRAM setting) as I found it can increase micro stutter in game when enabled (I think due to bandwidth being maxed at times).

Share this post


Link to post
Share on other sites

Posted (edited)

1920x1080 same as my desktop so native  – Is there any other information one would need to further hone in on the problem? Is this just me that has this bug? I thought I saw several ppl posting on the steam forum about this.
Thanks for the heads up, I'll have to disable it then just to not burn my rig to the ground :)

Edited by Botch_DK

Share this post


Link to post
Share on other sites

After each release there is always a bunch of issues for some, and no issues for many. (the nature of alpha development).

 

Some others will chip in I am sure and we will find the issue.

 

Personally I have had no/very minor issues relating to updates since the start of the project. I can't recall any of my Squad mates saying they had issues since the last update wither and we play everyday for hours.

Share this post


Link to post
Share on other sites

Posted (edited)

Hello!

Try to rollback nVidia driver to 372.90 or 368.81. There are many post that confirms Squad 9.5 works on UnrealEngine 4.14 that works fine on older drivers.

 

I play on Radeon R7 370 OC and after rollback to driver "Non-WHQL-Win10-64Bit-Radeon-Software-Crimson-16.11.3-Nov8" and installed program to unpark cores in CPU (ParkControl Free) and it brings a lot of FPS. I bet that drivers gave that boost not that program but don't have time to check when game works fine now :)

 

Source:

http://forums.joinsquad.com/topic/27772-fps-tweak-for-gtx-9xx-users/

http://forums.joinsquad.com/topic/26439-low-frames/

http://forums.joinsquad.com/topic/27095-gtx1080-low-fps-woes/#comment-289864

https://answers.unrealengine.com/questions/525001/what-driver-version-is-recommended-for-unreal-engi.html 

https://docs.unrealengine.com/latest/INT/Platforms/Linux/BeginnerLinuxDeveloper/SupportedGfxDrivers/

 

Write some feedback if it helped :)

Edited by LuQeRo

Share this post


Link to post
Share on other sites
4 hours ago, LuQeRo said:

Hello!

Try to rollback nVidia driver to 372.90 or 368.81. There are many post that confirms Squad 9.5 works on UnrealEngine 4.14 that works fine on older drivers.

 

I play on Radeon R7 370 OC and after rollback to driver "Non-WHQL-Win10-64Bit-Radeon-Software-Crimson-16.11.3-Nov8" and installed program to unpark cores in CPU (ParkControl Free) and it brings a lot of FPS. I bet that drivers gave that boost not that program but don't have time to check when game works fine now :)

 

Source:

http://forums.joinsquad.com/topic/27772-fps-tweak-for-gtx-9xx-users/

http://forums.joinsquad.com/topic/26439-low-frames/

http://forums.joinsquad.com/topic/27095-gtx1080-low-fps-woes/#comment-289864

https://answers.unrealengine.com/questions/525001/what-driver-version-is-recommended-for-unreal-engi.html 

https://docs.unrealengine.com/latest/INT/Platforms/Linux/BeginnerLinuxDeveloper/SupportedGfxDrivers/

 

Write some feedback if it helped :)

Dude thanks for the tip! I'll try this as soon as I can and report back!

Share this post


Link to post
Share on other sites

I get the same thing halfway through fools road  th3 towards the end of the game it goes away. 

Share this post


Link to post
Share on other sites

Posted (edited)

On 6/20/2017 at 10:09 AM, LuQeRo said:

Hello!

Try to rollback nVidia driver to 372.90 or 368.81. There are many post that confirms Squad 9.5 works on UnrealEngine 4.14 that works fine on older drivers.

 

I play on Radeon R7 370 OC and after rollback to driver "Non-WHQL-Win10-64Bit-Radeon-Software-Crimson-16.11.3-Nov8" and installed program to unpark cores in CPU (ParkControl Free) and it brings a lot of FPS. I bet that drivers gave that boost not that program but don't have time to check when game works fine now :)

 

Source:

http://forums.joinsquad.com/topic/27772-fps-tweak-for-gtx-9xx-users/

http://forums.joinsquad.com/topic/26439-low-frames/

http://forums.joinsquad.com/topic/27095-gtx1080-low-fps-woes/#comment-289864

https://answers.unrealengine.com/questions/525001/what-driver-version-is-recommended-for-unreal-engi.html 

https://docs.unrealengine.com/latest/INT/Platforms/Linux/BeginnerLinuxDeveloper/SupportedGfxDrivers/

 

Write some feedback if it helped :)

After uninstalling all GPU drivers and trying out the different ones listed in the thread you linked to, I found that the best for my setup is the 372.90 build – the other ones listed did the same fps cliff dive middle game as the newest one. Now I get a steady 75-80 fps without dips in every game so far, tried 3 different servers last night and all had a stable result.

 

Did a custom resolution in the nvidia panel, sampling 3840×2160 to 1900x1080. All in-game settings, besides effects which is set to low, are on high + scaling off, and TXAA. No steam launch options, but I'll test with the "-USEALLAVAILABLECORES -novsync -mammoc=system" string later. – Afterwards I also bumped my CPU to 4.2Ghz and gained an average 6-8fps as well.

Thank you so much for the information, I was about ready to give up :D 

 

To sum up:

 

New A9.5-10697 build update tanked FPS to 15-25 – Rollback GPU driver to 372.90 build fixed it.

 

• Core i7-4770k 4.2Ghz

• MSI GTX 1070 Aero ITX 8GB OC

• Corsair XMS3 - 16 GB DDR3 1600 / 2x 8GB sticks

• Gigabyte - Z87-Wifi Mini ITX LGA1150

• Kingston SSDNow V300 120 GB

 

 

Edited by Botch_DK
Words

Share this post


Link to post
Share on other sites

Thanks for feedback. I'm glad that this helps. Will try that launch options if they really give boost to FPS .

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now