Jump to content
suds

Out of memory

Recommended Posts

Windows 10 x64

12gb ram

4gb video ram on a 970

i5 2500k

SSD is fine for space

No page file

 

I get a windows popup after about 2 hours of playing squad saying im out of memory (doesn't specify video or main ram) and that I need to close programs, it offers to close programs automatically and the one time i clicked that it closed squad. If I ignore the error and leave the window open I can carry on playing, if i click cancel it pops up again a few mins later.

 

Watching the GPU ram it sits full most of the time while in squad.

Regular ram is not even close to maxed.

 

Anyone got similar/ideas to fix?

 

Share this post


Link to post
Share on other sites

Don't know about solving the problem, but i have GTX950 with 4gb vram and 8gb DDR4 memory and the poput never showed up to me. But got 30 fps after last update anyway, so i can not play it anymore :D

Share this post


Link to post
Share on other sites

It might simply be due to the 970 not really having 4GB of RAM, with the 0.5GB being super slow the game might think you're out of it.

Share this post


Link to post
Share on other sites

Ensure texture streaming feature is on, so lower amount of VRAM is used.

 

Then you may need to tweak a couple of graphics settings down to ensure your VRAM use never goes above 3.5GB at all times, across all maps. (are you playing in 1440p by any chance?).

 

This issue is popping up now and again since last game update.

 

I am lucky as I have 11GB VRAM, so I turn texture streaming off and can consume up to 10.8GB VRAM in Squad at 1440p, on some maps.

Share this post


Link to post
Share on other sites

nah just 1920x1080

 

Ill check that setting next time i go in

Share this post


Link to post
Share on other sites
11 hours ago, suds said:

nah just 1920x1080

 

Ill check that setting next time i go in

LOL I just realised OP is - U!

Yeah let us know, it may or may not be VRAM use of course but would be good to know.

Share this post


Link to post
Share on other sites
On 5.6.2017 at 3:39 PM, suds said:

Windows 10 x64

12gb ram

4gb video ram on a 970

i5 2500k

SSD is fine for space

No page file

 

I get a windows popup after about 2 hours of playing squad saying im out of memory (doesn't specify video or main ram) and that I need to close programs, it offers to close programs automatically and the one time i clicked that it closed squad. If I ignore the error and leave the window open I can carry on playing, if i click cancel it pops up again a few mins later.

 

Watching the GPU ram it sits full most of the time while in squad.

Regular ram is not even close to maxed.

 

Anyone got similar/ideas to fix?

 

You allready gave the answer in your initial post i underlined it and made it bolt  :-)

Share this post


Link to post
Share on other sites

@moppela small page file seems to have resolved the problem. This only appeared since v9.

 

Thanks tho.

Share this post


Link to post
Share on other sites
On 6/5/2017 at 9:41 AM, SHO-SHIN said:

Ensure texture streaming feature is on, so lower amount of VRAM is used.

 

 

should you do this if you have 8gb ram and am getting this error

Share this post


Link to post
Share on other sites

Sorry I need to correct myself full texture loading needs to be off to use less VRAM, turning it on uses more.

CR1T1CALIRL do you mean system RAM (I think you do) or GPU VRAM?

Either way turn full texture loading off (I can use up to 10GB plus of both RAM and VRAM with it on).

Share this post


Link to post
Share on other sites
On 8/8/2017 at 1:25 AM, SHO-SHIN said:

Sorry I need to correct myself full texture loading needs to be off to use less VRAM, turning it on uses more.

CR1T1CALIRL do you mean system RAM (I think you do) or GPU VRAM?

Either way turn full texture loading off (I can use up to 10GB plus of both RAM and VRAM with it on).

8 gig system ram, gtx 980, amd fx 6300, and am getting this error

Share this post


Link to post
Share on other sites
12 minutes ago, SHO-SHIN said:

did you try this?

tried both on and off, texture loading on i cant even join a server without a crash

Share this post


Link to post
Share on other sites
41 minutes ago, CR1T1CALIRL said:

tried both on and off, texture loading on i cant even join a server without a crash

ok, well off is the right setting for that aspect.

Do you have other things running as well as Squad, when playing of course?

If you have anything significant in the background it could be eating resources and causing Squad to crash out perhaps?

What resolution do you play in 1080p or something else?

 

Share this post


Link to post
Share on other sites
18 hours ago, SHO-SHIN said:

ok, well off is the right setting for that aspect.

Do you have other things running as well as Squad, when playing of course?

If you have anything significant in the background it could be eating resources and causing Squad to crash out perhaps?

What resolution do you play in 1080p or something else?

 

nothing else running in background, even go as far as disabling windows defender/other similar programs.

 

could it be msi afterburner thats causing it?

 

also, i figured out something odd,  putting on settings on medium/low/high (the default settings) and not changing a single thing, will reduce ram usage and increase gpu consumption.... where as if i create a custom setting, it pretty much uses my entier 8 gigs of ram, and barely any of my gpu... my gpu will sit at 23% usage, while in full combat and only getting 30 fps...  I just, don't understand why squad uses barely any of gpu, and only half of my cpu, but an entire 8 gigs of ram... is this a problem with squad? or my hardware? settings?

Also, yes 1080p, of course i could lower my resolution, but i'd rather play 30 fps of glorious 1080p than 60 fps non hd res.

 

 

Share this post


Link to post
Share on other sites
7 minutes ago, CR1T1CALIRL said:

nothing else running in background, even go as far as disabling windows defender/other similar programs.

 

could it be msi afterburner thats causing it?

 

also, i figured out something odd,  putting on settings on medium/low/high (the default settings) and not changing a single thing, will reduce ram usage and increase gpu consumption.... where as if i create a custom setting, it pretty much uses my entier 8 gigs of ram, and barely any of my gpu... my gpu will sit at 23% usage, while in full combat and only getting 30 fps...  I just, don't understand why squad uses barely any of gpu, and only half of my cpu, but an entire 8 gigs of ram... is this a problem with squad? or my hardware? settings?

Also, yes 1080p, of course i could lower my resolution, but i'd rather play 30 fps of glorious 1080p than 60 fps non hd res.

 

 

I don't think it will be MSI Afterburner, I have used it since the start of the game with no issues.

What drivers are you using for GPU?

I havn't tested the default graphics settings, i always used custom settings since day 1.

This sounds like a driver issue or it is indeed Squad, which can happen re alpha stage. Have you visited discord and asked for support there? I am sure one of the guys,, that know can help.

Share this post


Link to post
Share on other sites
6 minutes ago, SHO-SHIN said:

I don't think it will be MSI Afterburner, I have used it since the start of the game with no issues.

What drivers are you using for GPU?

I havn't tested the default graphics settings, i always used custom settings since day 1.

This sounds like a driver issue or it is indeed Squad, which can happen re alpha stage. Have you visited discord and asked for support there? I am sure one of the guys,, that know can help.

gpu drivers are always up to date, basically check it everyday. geforce 385.28

 

i have not visited discord, i just found this thread and thought to try here first.

 

thanks for the responses!

Edited by CR1T1CALIRL

Share this post


Link to post
Share on other sites

Pop on discord, find the support room and post a detailed message on whats happened and where you are at. You will  be helped and this will be sorted.

Share this post


Link to post
Share on other sites

There are quite a few post regarding NVIDIA drivers and reasons NOT to use the latest drivers, some members (not me) have put a LOT of time into testing various versions and come to the conclusion that version 368.81 is one of the better options. I took their advise and loaded these drivers without all the other crap that comes with them as per Skuls suggestion and saw an increase in my FPS (no screen shots to prove it, but it did improve!)  see the two post below or search on NVIDIA DRIVER

 

Edited by scoobi

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×