Jump to content
NightMaker

[Solved] No Servers in Server Browser - Just bought the game

Recommended Posts

Tried all posted fixes, both from Zendesk and here on the forums. 

Even if I try to connect from steam server browser, it wont join - just opens the game and nothing happens. 

I can join firing range, nothing else.

MSI motherboard, Killer Lan suite is removed, and driver without software installed.


Contacted Psyrus, as it seems to be a problem with my Router.

Share this post


Link to post
Share on other sites
Posted (edited)

UPDATE

 

No self fix was available for my problem, but I contacted my ISP ( Internet provider ) and I received a new router. This fixed the problem and I now see all servers. 

So if you experience the same symptoms as me, where you don't see any servers at all and you have tried every option on the forums, try changing out your router - as it most likely will fix your problem.

Special thanks to Psyrus for helping me identifying the problem.

See you all on the battlefield!

-Nightmaker

Edited by NightMaker

Share this post


Link to post
Share on other sites

Glad to see it worked out eventually, and thanks for updating the thread :) 

Share this post


Link to post
Share on other sites

Nice work, i knew @psyrus can help you as i told you,99 % was router problem.

Share this post


Link to post
Share on other sites

Glad you got the issue sorted out @NightMaker, also thanks for doing a bit of research on your own prior to posting and updating your thread as you progressed.

 

Have fun in Squad!

 

 

/locked

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×