Jump to content
Sign in to follow this  
CircularCore

Unplayable

Recommended Posts

Hi All.

Tonight I finally decided to buy SQUAD, but during the matches on any map I have FPS drops that make the play unplayable.
I tried any setup, and any updates .... I updated the MB bios, updated the VGA drivers, changed the render distance settings etc ... but it has changed nothing.
Yet when start a new match Squads works perfect, it does so after a few minutes and I can't understand the reason.
Can someone help me? I spent my money in vain :(

 

My hardware spec:

GTX 980 SC

i5 6600k

16gb 3000mhz Apacer DDR4

Asrock Gaming K6 Z270

Share this post


Link to post
Share on other sites

If you played squad for less than 2 hours, you can still get a refund from steam. 

 

If you have played over 2 hours, then it's gonna be troubleshooting time. With the 6600k, even at stock speeds, you should be managing over 30 FPS at all times, which is in the "playable" range, I assume. 

Share this post


Link to post
Share on other sites

How low does your FPS get? The game isn't fully optimized yet so low frame-rate is going to happen.

Share this post


Link to post
Share on other sites
35 minutes ago, Psyrus said:

If you played squad for less than 2 hours, you can still get a refund from steam. 

 

If you have played over 2 hours, then it's gonna be troubleshooting time. With the 6600k, even at stock speeds, you should be managing over 30 FPS at all times, which is in the "playable" range, I assume. 

Unfortunately I can no longer get the refund, it seems impossible that a 6600K has problems with a game

28 minutes ago, justachap said:

How low does your FPS get? The game isn't fully optimized yet so low frame-rate is going to happen.

I noticed that when in a game FPSs are stable at about 60.
When I get killed I go down a lot (10 fps), and the situation stays the same

 

Fps are displayed at the left top

Before:

hkve2L0.jpg

 

After:

Yii4SJX.jpg

Share this post


Link to post
Share on other sites
Posted (edited)
4 minutes ago, CircularCore said:

I noticed that when in a game FPSs are stable at about 60.
When I get killed I go down a lot (10 fps), and the situation stays the same

 

Yeah that is not normal, there is something strange going on. 

 

When you play next time, don't bother with fraps, just use this method:

 

Open the console (~ button) and type:

stat fps (then push enter)

stat unit (then push enter)

 

Then take a screenshot of before and after the frames go down. It should help us see which part is causing the problem, and from there we can troubleshoot to see what is happening to cause that. 

Edited by Psyrus

Share this post


Link to post
Share on other sites

It's quite odd, I agree with the above post. Stat unit & stat fps to see what's going on. Maybe even monitor your GPU, CPU and Memory usage and see if any hiccups happens. I run a 6600k overclocked and have had no issues.

My current build
EVGA GTX 1080ti
i5 6600k @4.4Ghz
16GB Corsair dominator DDR4 2133Mhz

Usually 40 - 90 fps max settings at 1440p depending on map and player count.

Share this post


Link to post
Share on other sites
Posted (edited)

Have you tried using DDU to remove your Nvidia drivers, and then install the latest?

Which Windows version are you using? I see you're using Fraps, which does not play well with Squad, so try not using Fraps with Squad and use console commands or go into Game settings and Toggle performance stats to display fps and latency.

 

If you're playing with Vsync, turn it off and use Fast sync in Nvidia control panel (should work the same + reduce input lag a bit).

Also set your GPU performance to maximum performance and Windows performance as well (could be the reason your GPU downclocks).

 

Other than that, I would suspect the GPU having driver issues and it downclocks to idle states. Check this with either GPU-Z or MSI Afterburner.

 

Edited by MrOcto

Share this post


Link to post
Share on other sites

Looks to me like a old fashioned delete app data and cache scenario, have you tried to clear cache?

Should have great performance with your setup.

Share this post


Link to post
Share on other sites

Today I played all day and I didn't have any FPS drop .
I have not changed anything, I don't explain how it is possible.

I will keep you update in the coming days.

 

Thanks to all for support ! :D

Share this post


Link to post
Share on other sites
On 28/04/2017 at 2:47 AM, Psyrus said:

If you played squad for less than 2 hours, you can still get a refund from steam. 

 

If you have played over 2 hours, then it's gonna be troubleshooting time. With the 6600k, even at stock speeds, you should be managing over 30 FPS at all times, which is in the "playable" range, I assume. 


Eeep. That's a scary thought. 30 fps playable? Perhaps if what is being played is a movie haha

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×